Kext's + DSDT for Asus K53SV Series R5
1 1

(1)

About This File

These are the kexts and DSDT for the asus k53sv, Everything works except: nVidia GT50M (Graphics card) due to the nVidia Optimus switching technology and the Intel wireless card. If you want the wireless to work you can buy an atheros AR5B95 on ebay/amazone. The kext's work in Mountain Lion/Mavericks.

Link to ebay for AR5B95: http://www.ebay.com/itm/NEW-Atheros-AR9285-AR5B195-592775-001-Half-WLAN-WIFI-BT-3-0-BlueTooth-Card-/200928889248

Buy at your OWN RISK.

 

 

-sloeberGJ

 

You can always mail me if there are questions 

:talking:


What's New in Version R5   See changelog

Released

  • Fixed:
  • - HDMI Audio
  • - Battery
  • - Audio not working after sleep


  • Download this file


  • User Feedback


    Alain Frenois

    • 5
      

    Share this review


    Link to review
    • Similar Content

      • By misutowolf
        Radeon 5650M Kexts?
        So, I have successfully installed Yosemite Zone on my Toshiba Satellite laptop (L655-S5114), but I can't seem to get my video working properly.

        No matter what kexts I have installed, I consistently get -extremely- laggy video, as well as the card not being detected in System Information (instead, it shows a generic video card with 3MB of memory).

        What kexts should I be using for this card, exactly?   The card's an ATI (AMD) Radeon 5650 Mobile, Vendor + Hardware IDs are -->  0x68c1 & 1002 respectively.

        I'm at a complete loss.  No matter what I've done, I'm stuck at 1024x768 with no hardware acceleration at all (QE/CI?).  This is my first time messing with Hackintosh.  I'm happy that my system has installed/booted fine, but I really need to get this graphics stuff sorted out.
      • By Christian1992usb
        Hi everyone, finally I managed to have a successful installation of Niresh's Yosemite Zone 10.10.1 on my AMD configuration with this specs :
        Mobo: Asus M5A97 EVO r2.0
        CPU: AMD FX6300
        GPU: Sapphire Radeon r9 270x vapor x
        HDD: Western Digital Caviar Blue 1tb
        Ram: 8gb 1600mhz corsair vengeance
        I boot with /amd npci=0x2000 -v and the installation has completed successfully but when the PC restarts and when I boot with npci=0x3000, computer shows me a grey screen with an infinite spinning beachball cursor. I can only enter Yosemite in safe mode whit boot flag "-x". I tried lots of boot flags include "GraphicsEnabler=No" and the result is always the same grey screen. I've set the uefi bios disabling Vtd, turning on AHCI and so on without result. When I boot in Verbose mode with bootflag "-v" the black screen with white signs shows me after PCI configuration :
        "Warning: IOPlatformPluginUntil : GetCPUIDInfo: this is an unknown CPU model 0x3a
        --Power management may be incomplete or unsupported"
         
        Please help me
         
      • By MWF_AL
        Alright, here's my dilemma. I'm trying to boot up Niresh Mavericks on an AMD64 desktop (I'm not using Yosemite because it takes 5 minutes to load all the HFS+ files on that one). I've gotten stopped by the infamous "PCI Configuration Begin" hang, and I can't fix it; I've tried pretty much every combination of PCIRootUID=0/1, npci=0x2000/0x3000, pci=no, GraphicsEnabler=Yes, dart=0, -x, and so on with both /amd and /amd64 (this is not an FX system); no luck on any try. I finally found some custom kexts somebody made that are supposed to be able to bypass this. I know they go in the Extra\Extensions folder. But here's where things get tricky;
        The computer's motherboard doesn't support booting from a USB drive, so I have it burned to a DVDR-DL that I'm booting from; I've got like 50 of these laying around, so I've no worries about burning more. Of course, this means I'm using the ISO file, which can't be edited; only extracted, edited, and then put back together. Problem is, I can't for the life of me get it put back together properly. I'm using PowerISO, although I do also have IMGBurn and Image Master at my disposal. What I've been doing is taking the ISO, backing up the boot information, extracting it, manually extracting the [BOOT] folder with 7zip, putting it back in, adding the kexts, and then putting them all back into PowerISO, making it bootable, and using the boot information from the official ISO. It does create a valid ISO file, but it doesn't actually boot; it just hangs on the boot screen (I've been using VirtualBox to test it, where the normal ISO works fine).
        To make matters worse, I can't browse the filesystem contents of the disc on my Windows computer, so I can't just edit it directly that way (haven't tried on Linux yet, but I'd assume it's no different). I do have a Mac Mini available, but it has no disc drive, and I don't have any external disc drives to hook up to it. I need some way to add custom kexts to the Niresh ISO file, and still be able to burn it to a disc and have it work.
      • By willkuer
        Hello
        if somebody could help me to create DSDT for my laptop? I can't do it by myself. Would be very kind of you
      • By Biso007
        Hello,
         
        I have a working El Capitan on HP Elitebook 8460p except the battery status. I tried many DSDT patches with no luck. Any one with similar laptop can provide me with the required DSDT patch and a working AIACPIPM kext.
        P.S PM is working fine with a modified SSDT and the laptop has a 6-series MB.
        TIA
    • Popular Contributors