AnV's amd_kernel 10.8
0

By Deepak
(0)

About This File

The latest kernel, which i'm posting here as amd_kernel, was built by Andy Vandjick, but that wouldn't be possible without the amazing work by Sinetek (who made the first ssse3 emulator ever, enabling non FX-series CPUs to run OSX in 64-bit kernel mode), R:A:W:x86, Bronzovka (who made Lion on AMD possible) and the Voodoo team. Many thanks to them all!

The correct boot flags to run the kernel are amd_kernel arch=x86_64. FX-series users must also add the correct busratio. The kernel is not working properly with nVidia graphics (and some ATI ones), so their users must also either add -x (safe mode) boot flag or disable GeforceGA.plugin and GLDriver.bundle in System/Library/Extensions.

FX users may also try the 12.0 AMD kernel by sinetek, which is confirmed to be working nicely with newer AMD CPUs (Bulldozer and Piledriver chips). Bad news are that, since it's a 12.0 (10.8.0) kernel, it won't work with 10.8.2 without mods; specifically, it's necessary replacing the 10.8.2 AppleFileSystemDriver.kext, IOACPIFamily.kext and perhaps AppleACPIPlatform.kext by the 10.8.0 versions of each one.

Good luck to all and please post feedback. The sources are also included for anyone wanting to build the kernel from the sources, or help improve it - there's still a lot of work to do.


What's New in Version 10.8

Released

  • Working CPU :
  • Athlon II x2, x3, x4
  • Phenom II x4, x6
  • AMD Athlon 64 X2 3800+
  • AMD A6-4400M APU with Radeon(tm) HD Graphics


  • Download this file


  • User Feedback

    There are no reviews to display.

    • Similar Content

      • By wirdgeladen
        Question: How do I update from Yosemite Zone to macOS Sierra?
        Dear forum,
        My question is about Yosemite Zone. It works perfectly now but I want to update to Sierra to run some apple apps. Thanks for help!
        Laurent




      • By YoWhatUp
        After installation stuck on Apple logo with spinning wheel
        Having some trouble getting Mavericks to boot, after I select the hard drive that I installed it on it goes into a gray apple loading screen with a spinning wheel, after a minute or two it freezes and will not boot.
        My specs:
        AMD Fx 6300 Six-core Processor  
        MSI 970A-G43 Mobo
        Evga Geforce Gtx 750 ti 
      • By Sea
        Some time ago, I tried dual-booting Yosemite with Windows Vista on the same drive, as I don't have access to another. I successfully installed it and almost everything seemingly worked perfectly, with the exception of sound and wifi, I had yet to even try to get my sound working on it, it wasn't a big priority at the time (though next time, I'd like to get it working right away if possible), and I just used an external wifi adapter while running OS X.

        Anyway, I noticed when going back on Windows, the generic volume driver would be missing, and the only way to restore it was to do a system restore, which would allow Windows to reinstall it. I feel this could be related to the fact that I didn’t even have sound working on OS X in the first place, but I can’t say for sure. I’m probably incorrect. Anyway, I didn't think much of it at the time, but then a much larger problem occurred.

        After waking up from sleep mode on OS X (which had actually worked fine up until this point), HDMI stopped working. My monitor was showing nothing, and I ended up forcing my computer to shut down only to find that HDMI still wasn't working at all. I couldn't see anything, even outside of OS X. I eventually attached another monitor via VGA, which allowed me to see everything again, I then booted into OS X to find that HDMI would work in that, but still nothing else. The only way to fix it was to again to a system restore on Windows.

        After that, I removed OS X and I haven’t bothered with it since, however I would still very much like to dual-boot OS X with Windows again. Is there anything I can do to avoid these problems in the future? Thanks in advance.
         
        My Specs
      • By JorgeArias
        Niresh Mavericks AMD A4
        Hi people, I trying to install Niresh Mavericks but when I type the boot flag and press enter, the system just restart and put me again in the black screen of the boot installation, someone who can help me.
        i trying to install in a asus laptop k53ta
        Thanks!
      • By juliomejia93
        Help amd fx 4300
        Hello good I have a pc
        AMD FX-4300
        asus-M5A78L-MLX v2
        Nvidia geforce gt 730 2gb DRR3
        8gb ram
        Mavericks installed intala all well but does not enter the desktop I get this error
        flow_divert_kctl_disconnect (0) group 1 disconnecting
        I have tried all the command that is me and nothing anyone help me
        sorry for my English is my language is Spanish and I am translating
    • Popular Contributors