• 0

Kext for Qualcomm Atheros AR5B125 Wifi
0

Question

Hi,

 

Can anyone pls tell me the Kext for Qualcomm Atheros AR5B125 Wifi.. and Broadcom Netlink Gigabit ethernet?

 

Thanks

Siva

1 person likes this

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Unfortunately the AR5B125 wifi card is reported as not working :(  No use of adding vendor and device ids to a card that is not supported. 

Check this list out : wifi compatibility list

 

tl;dr : This card doesn't work 

 

 

Edited by Devonic
1 person likes this

Share this post


Link to post
Share on other sites
  • 0

Oh yay, something I can help with!

 

For the Atheros AR5B125, I just read an article on osx86  about you not needing one. http://www.osx86.net/topic/16740-ar5b125-atheros-kext/

 

Maybe at this point, you're thinking "No because it's not working..." That is at first what I thought. What you do to activate it is as follows:

 

1. Obtain your Device ID and your Vendor ID. There is an application for Mac, Windows, and Linux that can list these. Here is the link:

 

http://www.osx86.net/file/2243-system-info/      The MacOSX version is the SystemInfo.zip.

 

 

2. Now we are going to find where the .kext, or Kernel Extension, for your device is. Is it located in /System/Library/Extensions or Extra/Extensions?

 

 

3. Once you find it, use one of these commands in the Terminal depending on where the .kext is located.

 

sudo nano /System/Library/Extensions/[yourwifidriver].kext/Contents/Info.plist
 

sudo nano /Extra/Extensions/[yourwifidriver].kext/Contents/Info.plist

 

 

4. Once in, scroll down and try to locate <key>IOPCIPrimaryMatch</key> or <key>IOPCINameMatch</key>. If you find <key>IOPCIClassMatch</key> instead, change IOPCIClassMatch to IOPCIPrimaryMatch.

 

Below the key you should see a string of numbers either preceded by 0x or pci. Delete all the strings there, and enter in your Device ID in this order:

 

0x[deviceID][vendorID]. Remember to omit the period.

 

If you had <key>IOPCINameMatch</key>, then enter your Device ID in this order:

 

pci[vendorID], [deviceID].

 

 

To show you an example, I will use 96ef as my Device ID, and 3602 as my Vendor ID.

 

If you had <key>IOPCIPrimaryMatch</key>, then 0x96ef3602 is what you would enter. If you had <key>IOPCINameMatch</key>, the you would enter:

 

pci[3602], [96ef].

 

Once done, press Control+O and Control+X. Now reboot and at the boot prompt type -f.

 

 

I hope this helps you!

 

1 person likes this

Share this post


Link to post
Share on other sites
  • 0
Thanks eMacOSBuntu!!

 

I have tried what you said... but i still not able to get my wifi...

 

My kext located in

System/Library/Extensions/

 

In terminal i entered, 

sudo nano /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist

 

system prompts for password, i entered it. and the plist file has opened in terminal..

 

i found this:

 

<key>IONameMatch</key>

<array>

<string>pci168c, 30</string>

<string>pci168c, 2a</string>

<string>pci106b, 0086</string>

<string>pci168c, 1c</string>

<string>pci168c, 23</string>

<string>pci168c, 24</string>

</array>
 
and i changed it to:

 

<key>IONameMatch</key>

<array>

<string>pci168c, 0032</string>

<string>pci168c, 2a</string>

<string>pci106b, 0086</string>

<string>pci168c, 1c</string>

<string>pci168c, 23</string>

<string>pci168c, 24</string>

</array>

 

my dev id is 0032 and ven id is 168c

 

After overwriting the terminal i had reboot it with -f.

 

but wifi is not working....

 

did i anything wrong.. please guide.. 

 

I tried it second time,  in terminal i entered sudo nano /System/Library/Extensions/IO80211Family.kext/Contents/PlugIns/AirPortAtheros40.kext/Contents/Info.plist

then it prompts for a password, but i cant enter any value over there.. so i cant open it in terminal now. manually i opened the plist file in text editor. and the values i entered are there...

 

And Using Vietnam tool now i got my ethernet worked, but i dont know how to configure it..  :)

 

Eagerly waiting for your reply.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
0