• 0

How To Set Nvidia Card As Default Instead Of Hd3000 ? Help
2 2

Question

Someone please advise me how to set Nvidia Geforce 520m as the default and only Graphics card? I would like to replace the Intel Intel HD3000 with Nvidia 520m. I went through a couple's topic but I could not find anything. I tried to install KEXT (this) but still nothing. I think that you need to set some Nvidia graphics card ID, which would be fed. I really do not know. Does anyone have any experience with this?

 

Notebook specs:

  • [*]Processor: Intel Core i3 2310M (2,1 GHz) [*]Chipset: Intel HM55 [*]RAM: 4 GB DDR3 1066 MHz [*]Graphics Card: Intel HD3000 and NVIDIA GeForce GT520M (1024 MB)

 

Mac os X install (Drivers and config):

Posted Image

Posted Image

Posted Image

Posted Image

 

 

 

 

About mac:

Posted Image

Posted Image

 

 

 

 

 Nvidia graphics card ID (one of the methods)

0x104010de&0xffc0ffff1040 = "NVIDIA GeForce GT 520"1050 = "NVIDIA GeForce GT 520M "1056 = "NVIDIA NVS 4200M"1057 = "NVIDIA NVS 4200M "

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

I have only AppleIntelIVBVA.bundle in my Extension folder.

 

I wanted to take the information from this list:

 

- AppleIntelHD3000Graphics.kext

- AppleIntelHD3000GraphicsGA.plugin
- AppleIntelHD3000GraphicsGLDriver.bundle
- AppleIntelHD3000GraphicsVADriver.bundle
- AppleIntelHD4000Graphics.kext
- AppleIntelHD4000GraphicsGA.plugin
- AppleIntelHD4000GraphicsGLDriver.bundle
- AppleIntelHD4000GraphicsVADriver.bundle
- AppleIntelHDGraphics.kext
- AppleIntelHDGraphicsFB.kext
- AppleIntelHDGraphicsGA.plugin
- AppleIntelHDGraphicsGLDriver.bundle
- AppleIntelHDGraphicsVADriver.bundle
- AppleIntelIVBVA.bundle
- AppleIntelSNBGraphicsFB.kext
- AppleIntelSNBVA.bundle

 

but only one file is located in my Hackintosh... What next?

Share this post


Link to post
Share on other sites
  • 0

No, this is Optimus, the Nvidia will never work in OSX, only your HD3000 will work, you must deactivate the  Nvidia in Bios , then your HD3000 will work.

1 person likes this

Share this post


Link to post
Share on other sites
  • 0

I also face same thing with my.

i select nvidia move extension and boots ok,it detected intel hd 4000 with 64 mb shared.but my video and launchpad is so laggy,safari dont works well.i think intel drivers not install properly.see attached picture.

please help me to work grpahics with full accleration.

 

Niresh please help.

I want anyone of intel hd 4000 or nvidia gt 620m to be work perfect.or both can work together

or if you can (please) provide me a kext with easy step.i dont know too much about mac.

post-44-0-32523400-1386901784_thumb.jpg

post-44-0-49218000-1386901802_thumb.jpg

Share this post


Link to post
Share on other sites
  • 0

try MACBOOK PRO 8,1 SMBIOS to enable hd3000 latest version of Chameleon bootloader ...

Share this post


Link to post
Share on other sites
  • 0

guys, I have Asus a53sc model laptop with same specs.

 

Intel HD 3000 working well with QA and transparency windows and menu bar.

 

But I cannot load nvidia graphic card. Geforce GT 520 MX

 

can you help me about that. I just wanna use also nvidia.

 

ps: there is no option in bios change video card.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
2 2