• 0

Get Triple Monitors Working on 10.9 With XFX HD 7750
1 1

Question

Hey Guys!

 

I've managed to get Niresh's OSX 10.9 running on my ASUS M5A97 LE R2.0, AMD FX 8350, XFX HD 7750 System...

 

Works pretty well apart from the network adapter locks up every now and then when multiple downloads are running, and onboard sound was broken (no problem for me as I'm using an external USB M-Audio).

 

It even works well with 'Dual' 1080 Monitors and I seem to have full Graphics Acceleration.
(One monitor connected via an active Display-Port to DVI, and the other on DVI Output 1).

 

My Stable Config is:

GraphicsEnabler=No

NPCI=0x3000

 

The only real issue is that I have to disconnect my third monitor (plugged in to DVI Output 2) before power-on in order for the system to not lock up around 10 seconds after log on. I have tried several methods but have NEVER (well, nearly never) managed to get the third monitor to display anything other than black at all.

 

The configs I have tried are:

 

  1. GraphicsEnabler=Yes
     
  2. PCIRootUID=0
     
  3. NCPI=0x2000
     
  4. GraphicsEnabler=Yes
    NPCI=0x2000

But none of these have proved fruitful, they have all ended in the same way.... with only a black screen on the third monitor (the other two showed the desktop fine and had the translucent menu bar) and then the system would lock up around 10 seconds later. Apart from number 4.... after a lot of flickering and 'FBRotate' doing it's thing the system didn't lock up but the third monitor was powered on, but black. A quick check of the more info on about this mac showed that all three monitors were recognised and active, but no picture.... I did notice that when moving the mouse between 2 screens the cursor would disappear while it apparently was travelling across the black screen, and then it would finally appear on the other working monitor! Strange! :P

 

I have also tried the FBRotate on user login fix, but this didn't work.

 

I have tried the sleep fix, which showed some promise, by which I mean the system would wake from sleep and all 3 monitors would come on and show a desktop (not mirrored! yay!) but immediately either the mouse and keyboard wouldn't work or the system had locked up (I couldn't tell which).... plus, it seemed that my CPU cooler hadn't powered back up (I use a Corsair Hydro H80i) so I immediately hard-powered off to avoid burning out the CPU!

 

I have even tried 'hot-plugging' the third monitor into the free DVI port, sometimes I get nothing, sometimes I get the equivalent of analogue tv static).

 

As a last resort I also tried the kexts for the HD 7850 from: osx86.net/file/3687-amd-hd7850-maverick-kexts-1092/ - but OSX didn't even seem to recognise my card with those installed (I did check that the device ID 0x683f existed inside them first), no avail :'(

 

So does anybody have any ideas in getting triple monitors working on this card, or has had any luck with anything similar?

 

Sorry if this is information overload!

 

Thanks in advance for any and all replies ;)

Share this post


Link to post
Share on other sites

1 answer to this question

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1