Martín Isla

ALC892 not working properly (crackling sound)

3 posts in this topic


I’m new to the forums. So, first of all: I’m Martín, from Argentina. 19 years old.
I installed Niresh’s distro like a month ago, and I couldn’t find a working kext for this ALC892 audio card. I either get crackling sound or no sound at all. Some kexts work better than others, but no one is really ok.
Tried MultiBeast, Slytherin and many (MANY) kexts from this forums.
This is my PC:
-AMD Phenom II x6
-AMD 6870 Sapphire (1 GB GDDR5)
I don’t use DSDT. 
This is my bootloader file in Extra folder.
<key>Legacy Logo</key>



Everything else works perfectly.
I hope you can’t help me so I have the perfect Hack Pro.

Thanks for everything!

Share this post

Link to post
Share on other sites

Oh! This could be important. I noticed that (contrarily from my laptop) the lower the "Format" (sorry, I don't know the English word for this) in the MIDI configuration app, the more the sound crackles.

Share this post

Link to post
Share on other sites

Same problem with a GA z77 Wifi board. using nVidia 650 Ti boost, and an ASUS screen. I fixed the crackling audio problem by uninstalling the VoodoHDA from the pref panel.

so now there is no sound, an improvement from the volume not working properly also, but, sound does not work.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now