• 0

OSX recognize graphics card, but is not using it.
2 2

Question

Hi all,

I had a problem to run hackintosh with integrated graphics card support on my laptop for months. Today I achieved some progress and my pc finally is recognizing graphics card as 'Intel HD4000 1024mb' but still, works the same as on 64mb(safari still goes to fullscreen in 8sec with nice slideshow). I tried every combination with 'org.chameleon.Boot' file and I no longer know what to do. Could anyone tell what a problem is? 

Here is some info:

Laptop: Lenovo G580, i3-3110M, 4gb ddr3, HD4000 + NVidia GeForce 710M 1024 mb gddr3.

OS: Niresh 10.9.

Bootloader: Chameleon-2.2svn-r2377.

And my boot flags:

<key>Credits</key>
<string>www.hackintosh.zone</string>
<key>EthernetBuiltIn</key>
<string>y</string>
<key>Graphics Mode</key>
<string>1366x768x32</string>
<key>device-properties</key>g
<string>7f0000000100000001000000730000000200000002010c00d041030a000000000101060000027fff04002c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000003006601140000006800640061002d0067006600780000000d0000006f6e626f6172642d31</string>
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>
<key>Timeout</key>
<string>2</string>
<key>USBBusFix</key>
<string>y</string>
<key>UseKernelCache</key>
<string>y</string>
 
I would really appreciate some help :).

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

I have tried a few values of IntelCapriFB but I will try again. I forgot to mention that my computer recognized the graphics card after i installed AppleIntelFramebufferCapri.kext. Is there any other kext i should apply to get HD4000 working?

Share this post


Link to post
Share on other sites
  • 0

Ohhh did you only install AppleIntelFramebufferCapri.kext ?

If yes, yeah there is others kexts you should install. Just use Multibeast or download HD4000 kexts from internet. There is defenetely a few more kexts to install, not just one.

 

Hope it will works dude :)

Share this post


Link to post
Share on other sites
  • 0

Yea, but everything I need is working: mouse keyboard, usb, touchpad. Only one thing I need more is graphics acceleration for better performance. I need mac only for programming and it doesnt matter for me if net or sound doesnt work. So my question was about graphics, I need to install any other kexts to get it working?

Share this post


Link to post
Share on other sites
  • 0

Okay, problem solved. I updated system from 10.9 to 10.9.4 because xcode 6 ask me to do and everything is working after that(except wifi and builtin speakers). Thank you for help. 

 

Writing from smoothly working mac os x. :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
2 2