• 0

problem with niresh on lenovo s510p
3 3

Question

my laptop is lenovo s510p specs as follows

processor : Intel® Coreâ„¢ i3 4010U Processor (3M Cache, 1.7 GHz)

ram  :          6 gb

video card : intel HD graphics 4400

 

when booting niresh installation on hp probook 4540s the installation works like charm , 

and when booting on lenovo s510p the bootloader doesnt even show up 

 

please help !!

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Ya ... same problem. When booting on lenovo s510p the boot loader doesn't even show up.

Tried making different bootable pendrives from Niresh DMG and ISO versions as detailed in the guides.

The pendrive works flawlessly on other laptops i.e. my Asus K53SD , installed and working fine.

But when booting on Lenovo S510p , the bootloader doesn't even show up giving up a black screen.

I am not able to reach the Niresh's Mavericks boot screen.

Also tried with different bios settings ... like changing UEFI and Secure boot... etc.

 

Please HELP .!

 

My Specs

 

Lenovo Ideapad S510p..came with pre-installed Windows pro 8.1
 
CPU
            Intel Core i3 4010U @ 1.70GHz
            Haswell ULT 22nm Technology
RAM
           8.00GB
Hard Disk
           1 TB
Motherboard
           Lenovo IdeaPad S510p (CPU Socket - U3E1)
Graphics
           2047MB NVIDIA GeForce 820M 
Audio
           Realtek High Definition Audio
Network
          Qualcomm Atheros AR8172/8176/8178 PCI-E Fast Ethernet Controller (NDIS 6.30)
          Qualcomm Atheros AR956x Wireless Network Adapter

Share this post


Link to post
Share on other sites
  • 0

Hi, I've got a Lenovo ideapad s510p as well.

Mine has got i7 but is anyway an haswell CPU.

Well, I tried and tried lots of times booting the Hackintosh Zone USB distro, but nothing. All your problems are because of the Haswell CPU

I made the Yosemite 10.10.1 by Hackintosh Zone DVD (It's very important to burn the iso file on a DVD, USB doen't work with haswell cpus) with the iso file  you'll find in hackintosh zone site (you must buy a DVD DL),

I booted with /haswell flag and it worked!!!!

Be careful, you first MUST DISABLE THE DEDICATED GRAPHICS CARD, because it doesn't work (You must go to the BIOS and select Graphics Mode - UMA Only).

Install it DISABLING THE INTEL VIRTUALIZATION TECHNOLOGY.

Possibly your INTEL HD 4400 will not work immediately, just shutdown and turn on the pc several times.

Idk wich network card you have, but mine did not work and there were no kext for it anywhere, it were not compatible. If this happens also to you It's a very big problem, because lenovo put a block in the Bios that impede to change it (this block is called Whitelist), I spent weeks trying to understand what did I have to do.

All what you have to do is go here https://www.bios-mods.com create a new account and ask them for a modified bios without the Whitelist for your lenovo, they will answer immediately. It's free of charge. Than you must patch your bios ( is very easy and you'll find the instructions in that site) and then you can buy a new network card. I bought the Azurewave NB037H on eBay (15 euros), and with the kext that I've attached here it will work (Idk if the Bluetooth works, just try)...

Now I've got my hackintosh perfectly working... sorry if the screenshot that I've attached is in Italian...

If you have any problems ask me, I'm not an expert but I'll try to help you.

Let me know...

P.S. I'm so sorry for my incorrect English, excuse me....

AirPortAtheros40.kext.zip

2628-Bluetooth_10.7_10.8.zip

Senza titolo.png

Edited by Alcatraz_2000

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
3 3