• 2
Dillon DeRosa

OSX Mavericks 10.9.0 AMD help


I'm 100% new to hackintosh. I've been PC users for years and now finally trying to install a hackintosh on another hdd. Here are my specs.


AMD FX 8350

Asus M5a97 R2.0

EVGA Nvidia Gtx 660ti


Here's what I've done so far.


1) Downloaded and made a bootable USB from this guide http://www.hackintosh.zone/file/75-niresh-mac-os-x-mavericks-109-with-amd-intel-usb/


2) Booted with the kernel flag amdfx -v


3) disk utility to format hdd to mac os extended (journaled)


4) installed the osx with no alters to the customization of kernel texts


5a) After successful installation I couldn't boot, even with kernel flags such as -x or -v


5b) To resolve this I used the kernel flag -s and did the following:


fsck -fy

mount -uw /

grafix backup all



6) Success with booting up with and without using kernel flag -x


7) I let niresh install its things and this is where I become confused.....


First, my screen resolution is off.... I've read that some people have same thing but onyl when it boots up but when they enter the osx it fixes... my however does not. My screen resolution stays in the center of my screen suround by like an inch of black border all around...  a resolution of 1037x733 or something like that, it doesn't really matter just that its small when I have 24" 1920x1080p monitor.


To note: I went into the "about mac" and I see that my CPU says,   4.01ghz unkown (so mac is not recognizing that I have an amd fx 8350)

Also that it recongizes i have the evga nvidia gtx 660ti EXCEPT; the vram is recongized as "0mb" instead of "2gbs"

Final note is that the video is really choppy, like the mouse stutters and lets say I open safari browser...  it looks as if a wave is going on with the image because its stuttering so much... I beleive this is either the video card not being correctly installed or its because my cpu is not being used correctly. Or i could be wrong?


Now I know I need to install multibeast to install more kernels but here is where my pc knowledge becomes useless and me knowing nothing about macs...  I'm so confused on where to get these kernels because I can't find a straight answer of what kernel to use and HOW TO INSTALL IT.


Seeing that my video card is not working i'll need a correct kernel for that and my cpu. Also I read about a motherboard DSDT but im afraid I can't find one for my motherboard so once again Im confused on what kernels to install to get my system working.


So, good news is I can get the installation going and boot... bad news is I have no idea about the kernels to get the system to run smooth.


If anyone can help me I would gladly appreciate the help... I'm such a novice about hackintosh and would love to get this working.

Share this post

Link to post
Share on other sites

6 answers to this question

  • 0
So I've made some progress in my trial and errors... but in the end I have new problems.
I've fixed my video problem having read that I have a gtx 660ti that I should install the OSX with GraphicsEnabler=No. That gave me my multiple displays + 1920x1080 resolution, plus the vram correctly showed 2gbs. I managed to fix the wavy/choppy however now all my text is BLURRY! I've read on the forums that I must apply the quadro nvidia update however I must update to OSX 10.9.2 atleast... I tried installing the combo update but got a java error in the end telling me I was updating in the wrong order... so I went along with updating to 10.9.4. This is where my problems exist is I'm not being able to boot back up after upgrading to 10.9.4 but if I don't update I can't update my video card so I'm at a dilemma....
Also to state my CPU still says 4.01ghz uknown.... is it supposed to be like this? I just want to make sure so I dont get any cpu crashes or its not working fully... It does show the correct cores and ghz but I'm wondering if being called unknown will make more problems arise? I have a amdfx 8350.
Here are my steps so far.
1) Make bootable Niresh OSX for 10.9.0
2) Format HDD to Mac OSX Extended (journaled)
3) Install OSX with GraphicsEnabler Unchecked
4) Boot with -x -v (I can boot without them but one time in my trial and error it froze randomly... so better safe then sorry to boot with kernel flags)
5) reboot
6) Install AMD 10.9.x v2.3 kernel via terminal
sudo -s
type in password
mount -uw /
cp mach_kernel /mach_kernel.old
cp /Users/myname/Desktop/mach_kernel /mach_kernel
7) Install extensions, Sandbox; System; Applematch; Fakesmc via Kext Wizard
8) Repair permissions/kexts via Kext wizard
9) Backup Extensions & kernel via terminal
cp -r /System/Library/Extensions /System/Library/Extensions.backup
cp -r /mach_kernel /mach_kernel.backup
(note I changed the original backup kernel to backup.old just incase i needed it)
10) Reboot to make sure new kernel works along with kexts (slow bootup, stuck at greyscreen for longer then usual, but it booted up fine with no kernel flags)
11) Download and install 10.9.4 combo update and restart
12) Through the Niresh bootable 10.9.0 usb,, I enter the terminal and replace kernel + extensions with the backup
(tried through niresh USB boot Terminal)
cd /volumes/MAC OSX/System/Library
cp -r /volumes/MAC OSX/System/Library/Extensions.backup /volumes/MAC OSX/System/Library/Extensions
cp -r /volumes/MAC OSX/mach_kernel.backup /volumes/MAC OSX/mach_kernel
(normal niresh boot on osx hdd)
cp -r /System/Library/Extensions.backup /System/Library/Extensions
cp -r /mach_kernel.backup /mach_kernel
chown 0:0 /mach_kernel
chmod 755 /mach_kernel
13) reboot data/stack error not permitted.... protections were read-write
14) repair permissions via disk utility on niresh usb boot
15) reboot data/stack error not permitted.... protections were read-write
I can't get past this. I've backup my kexts and replaced them yet I'm still getting this error? I hope im being detailed enough so perhaps someplace I am making an error?

Share this post

Link to post
Share on other sites
  • 0

@Dillon DeRosa according to my knowledge amd hackintosh kernels were released for 10.9.3 so you better update to it

Recommended steps

Backup Graphics Extensions while Installing

After Successful boot

Reinstall Backuped Kexts

Update to 10.9.3 

do not restart replace kernel 

then install this package


Then GraphicsEnabler=Yes will probably trigger your graphics

Share this post

Link to post
Share on other sites
  • 0

I'm following your steps as we speak, and will get back to you with results.


One thing quickly your step I quote,

"Reinstall Backuped Kexts"


I assume that your inferring to the Backup GRaphics Extensions I checked off during installation? If so how do I go about reinstalling the backuped ones?

Share this post

Link to post
Share on other sites
  • 0
1) Install Niresh 10.9.0 usb bootable to formatted hdd
whilst installing I uncheck GraphicsEnabler=Yes and checked Backup Graphics Extensions
2) After successful boot with kernal flag -x, -v I reinstalled the Backuped kexts via Kext Wizard
3) Backuped kext files and kernel
4) Updated to 10.9.3
5) Did not restart, replaced kernel with AMD v2.3 kernel
(I did not install the kext files with it because you didnt say to, so I chose not to at the time)
6) I then restarted the update because even though you said install the package I could not because my system was still being seen as 10.9.0
7) Upon boot I got instant restarts... which I assume  were the kernel
8) I used the backup (old) kernel and I got past the instant restarts but a new probem occured.
flow_driver_kctl_disconnect (0): disconnecting group 1
com.apple.launchd    1    com.apple.ColersyncXPCAgent    158    Stoping job...
com.apple.launchd    1    com.apple.ColersyncXPCAgent    158    Sent job SIGKILL.
Resetting IOCatalogue
now I then tried installing my backup kexts no good same problem... I tried going back to the AMD v2.3 kernel and installing the system+sandbbox+applematch kexts buut yet this problem still exists.
I read perhaps it was my FAKESMC so I installed the newest FAKESMC from tonymacx86 downloads and after using FAKESMC with the old kernel and old kexts I still get the same problem.
Any suggestions?

Share this post

Link to post
Share on other sites
  • 0

Does no one have any other ideas? I'm trying to be as descriptive as possible so someone can notice a mistake or fix someplace?????

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now