• 0

Laptop Internal Display Not Working
1 1




I've managed to successfully install Niresh 10.9.0 on my Sony VAIO VPC-CW29FX laptop, but right after the Apple logo (after loading the Nvidia kexts), my internal screen shuts off, and the graphics drivers switch the display output to the HDMI port. When I go into System PreferencesDisplays and click Detect, it doesn't detect the internal screen. 


I've done numerous things to get it to work. I've tried the usual boot switches (GraphicsEnabler=off/on, PCIRootUID=1, etc.), but to no avail. One thing I did try and had moderate success at was the guide Niresh posted specifically for this issue. After backing up the kext files, I was able to boot with the internal display working correctly. The only problem is that qe/ci was disabled. I tried reinstalling the defaul kexts, but as soon as I rebooted, my internal display stopped working again. 


My System Specs - 


CPU - Intel Core i3 350M

GPU - Nvidia Geforce 310M 256MB

Mobo Chipset - Intel HM 55 Chipset

RAM - 6GB DDR3 PC3-10600

WLAN - Atheros AR9285

Ethernet - Marvell Yukon 88E8057
Audio - Realtek something (not sure right now, at work, but I can look it up later if needed)
Is it possible to modify the kext, so it's forced to display out via the internal monitor? If not, is there another way to make it work?

Share this post

Link to post
Share on other sites

1 answer to this question

  • 0

Whoops, I just realized I posted this in the wrong section. I don't know how to move it, so I'll post in the correct section, and delete this one.


Edit: Never mind, there doesn't appear to be a way to delete anything you post.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1