• 0

USB stopped working after 10.9.4 update (8440P)
1 1

Question

Hi,

I have a fully working HP Elitebook 8440P,

Nvidea Graphics, trackpad, batterty status, its all working fine.

So was usb... untill i installed the 10.9.0 -> 10.9.4 update.

 

My usb stick light goes off after the niresh boot screen. The stick, and the wifi dongle just don't work.

 

For now the solution is:  remove the IOUSBMassStorageClass.kext

When i remove this class, my usb stick light keeps on, the storage is not mounted... no wonder... and my wifi usb dongle works.

 

Can anyone tell me how to have usb working... including mass storage? If i need to provide more info, logs or whatever.. please let me know.

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Update: 

 

If i boot without kernel Cache, usb is working fine..

 

What's the next step in reloving this problem, rebuild the kernel cache? Or something else? Remove some kexts? 

Share this post


Link to post
Share on other sites
  • 0

I have found the solution for this problem. (Thanx for helping ;) )

1. Remove AppleHPET.kext

2. In Terminal

sudo rm -r /System/Library/Caches/com.apple.kext.caches

3. Use kext wizzard to rebuild cache / repair permissions

4. Reboot

 

It should work now.

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1