• 0

HELP: Asus P5K (with P5KR bios) and Yosemite: ethernet won't work
2 2

Question

Hi guys! I've installed OS X Yosemite with MacPawn USB Key. After installation I've installed OS X Yosemite Chameleon V3 ('cause Clover won't work) selecting boot loader, VoodooHDA and FakeSMC (as I've done with Mavericks). Everything works, except ethernet. I know this problem because my mobo with Mavericks an ML needs AttansichL1eEthernet.kext (that is the same for P5K and P5Q). I've tried to install the same one that I've used with previous OS Xs but it won't work, so I look for others packages/kext on the web and tried them with the same result: won't work.
Previously, when i tried to install the same kext with Clover boot loader, the OS not start (must boot from USB key), but the ethernet work.
I think that may be a parameter of Chameleon, but can't find a solution. 
Is there someone who can help me?

post-41824-0-60269500-1415820568_thumb.p

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Solved adding kext-dev-mode=1 in org.chameleon.boot.plist (to let OS see uncertified kext) using MultiBeast.

Now every things seems to work.

Share this post


Link to post
Share on other sites
  • 0

Did you try to load the kext you used to use in Mavericks AFTER the system has already started?

 

Also - in System report -> Networking - is your Ethernet adapter listed?

Share this post


Link to post
Share on other sites
  • 0

Thanks for the answer.

Yes, I've done. The kext is not included in any installer.

The ethernet isn't listed in System Report -> Networking

I can't understand why during multiples installations I've tried, only one time it works (few days ago). That time, the boot loader (Clover) won't work, so I decide to re-install with Chameleon, and now is the ethernet that won't work.

If I boot from other disks (with Mountain Lion or Maverikcs and Chameleon) the ethernet works fine.

Share this post


Link to post
Share on other sites
  • 0

Ciao x IloveLeopard penso tu sia italiano vista la foto scusa sto installando yosemite su una p5k asus ma non riesco a fargli vedere gli hard disk sata solo quelli usb

che kext devo usare come risolvo

grazie Nik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
2 2