• 0

Intel HD4000/ Lenovo G500s
3 3


Hello, i have a problem with my Graphics Card.

I don't have full graphics support of my Intel HD4000.

I have a Lenovo G500s.


Everything is working fine except Wi-Fi and graphics.

Wi-Fi i don't care i always use cable :P

But my graphics i want to have it working correctly.


My specs are:


Lenovo G500s


Intel Core i7 3612QM 2.10GHz

8GB DDR3 1600Mhz RAM


Nvidia GeForce GT 720M 2GB (i know this one is not gonna work... )

Intel HD Graphics 4000 resolution 1366x768x32



here is some information in my System information field:


Intel HD Graphics 4000:


  Chipsetmodel: Intel HD Graphics 4000

  Type: GPU

  Bus: Ingebouwd

  VRAM (total): 64 MB shared systemmemory

  Fabrikant: Intel (0x8086)

  Apparaatcode: 0x0166

  Revisiecode: 0x0009

  Info kernelextensie: Geen Kext geladen



  Resolution: 1366 x 768

  Pixeldiepte: 32-bits Color (ARGB8888)

  Hoofdbeeldscherm: Ja

  Synchrone weergave: Uit

  Online: Ja


and another one:



  Type: GPU

  Bus: PCIe

  Breedte PCIe-baan: x8

  Fabrikant: NVIDIA (0x10de)

  Apparaatcode: 0x1140

  Revisiecode: 0x00a1

  Info kernelextensie: Geen Kext geladen


This is my org.chameleon.boot.plist configuration


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>
<key>Kernel Flags</key>
<string>"Graphics Mode"="1366x768x32"</string>
<key>Graphics Mode</key>
If someone can help me!



Share this post

Link to post
Share on other sites

2 answers to this question

  • 0

Try GE=No and inject intelcaprifb=0-11 

Share this post

Link to post
Share on other sites
  • 0

Hi alexxRSD, I have the same model of laptop Lenovo G500s but the specs are different, Core i3 3110m, Intel HD 4000 graphics, Intel Centrino wilreless-N 135, Lan qualcomm atheros ar8172/8176/8178, how did you mange the get the LAN working? and are you using vanilla install? or Niresh Distro?


plz let me know as I am also trying to install.


thank you

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
3 3