• 0

1 1


Life is complicated.

I want to install OS X (>=10.8.5) on Dell PowerEdge 1950. This is  a nice machine with PERC 5i SAS controller and it was running 1.x.x. bios with 5.1.4 raid firmware. The controller is not recognized by the standard OS X distributions but there is one nice guy (http://www.insanelymac.com/forum/topic/285197-driver-for-lsi-megaraid-sas-family/) who wrote a driver for it. The dell booted very well right to the installation setup screen with 10.9 (AMD) and 10.10 Niresh usb distributions and I managed to inject the SAS kext. Unfortunatelly it could not initiate the controler and ended with the FW error so the obvious move was to upgrade the RAID FW to the latest version. I did it and dit it also for the bios as this is what was recommended by Dell. After this nothing was the same. The booting ends up for both .9 and .10 with the same k. panic: "can't perform kext scan" but here goes some observations:

- it is not instant, it clearly reads the /System/Library/Extension (at least for .10) so it looks like after a kext gets injected something gets *beep*

- .9 boots well to the installation screen if:

    i) it boots from optical usb drive

    ii) it boots from a thumbdrive but an optical drive with .9 is present (in this case the OD blinks 2 times only during the whole installation process)

I have to say, I am pretty OS X illiterate but it seems to me something interferes with the USB drive during the boot time. Now, I can live with 10.9 but I don't know how to inject the SAS kext. Take a note that this is not (u)efi system. For the 10.10 I intuitively placed the kext into the /System/Library/Extension and it was read. 10.9 has it as mkext and before I spend next few hours trying to put the SAS kext to this mkext I would like to ask you about your opinion on what's actually is going on after the bios/fw was upgraded, whether something can be done to overcome this usb "can't perform kext scan" problem and what is generally the best way to inject this SAS kext for non efi system if this had to be 10.9.

Share this post

Link to post
Share on other sites

0 answers to this question

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1