• 0

Erratic Results On FIRST Yosemite Zone install using Niresh USB
1 1

Question

So I had little luck with Mavericks, and decided to abandon it and move to Yosemite instead. My machine is Inspiron 1720 laptop with 1.5 GHz Core 2 Duo and NVidia GeForce 8400M GS 128 MB card.

 

Since the Niresh Yosemite Zone DMG is larger than what could fit on single layer DVD (and I do not have dual layer DVDs which could be my issue), I decided to use Transmac to burn the image (while trial not expired) and give it a whirl.

 

I was actually able to get to "Select your language screen". The funny thing is I got in once, then thought, let me do it again so I remember the exact boot options I used. Then I got different results. Sometimes it would hang, sometimes it would give kernel panic. Each time different error. And all the time I'm thinking "I must have used some other combination of options". After 4 hours, I have hit on the winning combination. And I am sad to report, this combination works 10 percent of the time. That means 1 / 10 times you will get the "select your language screen". Don't ask me why, but I'm definitely not smoking anything.

 

If anyone has the same laptop and wants to give it a whirl I would really appreciate it. Here are the options I used. I made sure looked at Option menu since Niresh seems to have slightly different names for options (e.g. PciRoot instead of PCIRootUID, not that it mattered in this case). Without further ado.

 

GenerateCStates=Yes

GeneratePStates=Yes

GraphicsEnabler=Yes

"Graphics Mode"=1440x900x32

UseKernelCache=Yes

Max_valid_dma_addr=1024

Darkwake=0

USBBusFix=Yes

EHCIacquire=Yes

 

Some info. The last two options USBBusFix=Yes and EHCIacquire=Yes are not always necessary. Then sometimes even if you use them it does not make difference. The problem is for some reason installer in memory is not able to access the install USB stick  and either gives AppleUSBEHCI timeouts, or "cannot access disk0s1 greek latin". It is most frustrating. After so much time I know above combination is right combination WHEN IT WORKS !!!

 

One final note. On boot screen before specifying options, hit F10 a few times. This is supposed to refresh devices accessible to BIOS. Sometimes makes a difference. Also try changing port USB installer is plugged in. I have no clue why/what is happening. However I KNOW it just is.

 

So what I'm going to do now is purchase another HD. The 1720 has place for two HDs. I'm going to dual boot and put on separate HDs. I think that's better so I don't have to worry about frying Windows install and not have a laptop. Needless to say, when I'm ready to try again, I expect to try same boot options 10 times before I will get lucky. Once I'm able to install (hopefully) I'll then figure out how to get peripherals working.

 

Best.

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Yikes! I just saw Yosemite requires 4GB RAM. The alignment of the planets must have been all messed up when I was born. Can't catch a break. Now I have to buy some RAM too.

Share this post


Link to post
Share on other sites
  • 0

So I learnt boot flags were case sensitive. What ?!?!?! Who knew. Anyway to cut a long story short. I'm further along now. It loaded a boat load of things and I'm not stuck at a repeating line...
 
 
USBF:  XXX.YYY   AppleUSBEHCI::Found a transaction past the completion deadline on bus 0xfd, timing out! (Addr: 2, EP: 2)
 
I thought USBBusFix=Yes was supposed to fix such problems. Anyone have any advice for me? I've pasted my Boot.plist below. Dunno why I'm not allowed to just attach it.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>ForceHPET</key>
    <string>Yes</string>
    <key>ForceWake</key>
    <string>Yes</string>
    <key>Instant Menu</key>
    <string>Yes</string>
    <key>EthernetBuiltIn</key>
    <string>Yes</string>
    <key>GenerateCStates</key>
    <string>Yes</string>
    <key>GeneratePStates</key>
    <string>Yes</string>
    <key>Graphics Mode</key>
    <string>1440x900x32</string>
    <key>GraphicsEnabler</key>
    <string>Yes</string>
    <key>Kernel Flags</key>
    <string>root-dmg=file:///BaseSystem.dmg max_valid_dma_addr=1024 -v darkwake=0 kext-dev-mode=1 dmar=0 force64 ahcidisk=1 debug=8</string>
    <key>SystemType</key>
    <string>2</string>
    <key>UseKernelCache</key>
    <string>No</string>
    <key>Rescan</key>
    <string>Yes</string>
    <key>SMBIOSdefaults</key>
    <string>No</string>
    <key>Wake</key>
    <string>Yes</string>
</dict>
</plist>

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1