• 0

Laptop with Haswell Processor Reboot Issue + Kernel Panic
1 1

Question

I really need help with Yosemite Zone. I have a brand new laptop, and here are my problems.

- when I install and it is successful and I boot from my drive the apple logo shows up and then it reboots. I think this is due to haswell and I know that there's a kernel thing you can do in terminal but I'm not sure what to substitute what for what. I'm obviously doing it wrong.

-why does my flash drive need to be plugged in to boot my drive? If the flash drive is not plugged in, it doesn't run. And my pc says "insert boot media"

Laptop Specs

Intel i7 4510U

nVidia GeForce 840M

8GB of RAM

1TB hard drive

Any help much appreciated !!!!!!!!

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

I did the Kernel copy successfully and the kernel loads in Chameleon but now im stuck at Debugger not configured hanging on a Black screen and other text about boot=0 .. Help

Share this post


Link to post
Share on other sites
  • 0

@Connor Wood

cpus=1 may fix the kernel problem use the haswell kernel

to fix boot0 boot with the Installer USB

open terminal

type

diskutil list

check for the disk and device id of the OS X Installed Partition

that would probably be disk0s2 (Double check it)

then execute the following command

diskutil unmount /dev/disk0s2
dd if=/usr/standalone/i386/boot1h2 of=/dev/disk0s2

The upcoming 10.10.1 Image will best suit your Lap 

If you want to use the USB to Boot the Installed Partition add the kernel flag -F

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1