• 0

Mac on Lenovo G505s laptop
1 1


Greetings all!

I 've been trying to install Mac (through virtual box) on my laptop last 3 days spending about 4-5 hours per day :/

Well my goal is to run Xcode and learn programming with Swift to create iOS apps!

I was able to instal Mac Snow Leopard in virtualbox(using -x -v cpus=1 busratio=20 colors=32) and boot with flag: amd -x

After entering in Mac OS I had no App Store... I downloaded the last Xcode from apples website and I got an error telling my it isn't supported by my Mac version! I tried to update my Mac software and I did but after restarting and trying to boot again it wouldn't boot. I tried using any boot flag but it would give me a kernel error...

I need to install the last version Yosemite 10.10.1 which I downloaded but can't install!

I am totally noob in virtualbox stuff, in Linux too...

Can anyone help me step by step?

What flags should I use before the install, what drivers should I check in the costumize section while installing?

Do I need Multibeast? Is there a version for Ubuntu? How do I install it?

I have a Lenovo laptop!

Model: G505s

AMD A8 5550m APU 2.1GHz (quad core)

Ram: 8 GB DDR3 SDRAM 1600MHz

AMD Radeon HD 8750m 2GB DDR3 VRAM

1TB SATA 5400 rpm

Thanks in advance!

Share this post

Link to post
Share on other sites

2 answers to this question

  • 0

I tried booting with flags: /amd -v -x -f npci=0x2000 dart=0

However, I Stuck:MissingBluetooth Controller Transport 
Then i tried flags: /amd -v -x -s -f npci=0x2000 dart=0

BUT, when i type:

mount -uw /
cd /System/Library/Extensions
mkdir intel_back
mv AppleIntelHD* AppleIntelF* intel_back/
touch ../ExtensionsReboot -v


I get: disk2s2: device is write locked

Any help???

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1