• 0

Installation fails on Dell 5521
1 1




I would like to start developing iOS apps, so I'm trying to install OS X on my Dell Inspiron 5521 laptop since I can't afford to buy a new Mac.


I successfully installed Mavericks Zone 10.9.0 following this tutorial (no ethernet, wifi though). But Xcode 6 requires 10.9.4 or later. I tried updating to 10.9.5 with the combo update but OS X didn't boot after the update. So now I'm trying to install Yosemite Zone.


Dell Inspiron 15R 5521 Specs:

CPU: Intel® Core i5-3337U, 1.8 GHz


Graphic Card: Intel HD 4000, AMD Radeon HD 8730M

Motherboard Chipset: Intel PCH HM76

WLAN: Intel Centrino Wireless-N 2230

Ethernet: Realtek PCIe RTL 8105E

Audio Card: Realtek ALC-3221 HD


Here's what I did exactly.

I restored the downloaded Yosemite Zone image to a 16Gb usb flash drive using TransMac.

Here's how my BIOS settings look like (Mavericks successfully installed with these):




Booted the installer with -x flag (intsaller wouldn't boot without it).

Erase the partition I want to install to (Mac OS Extended (Journaled) format)

Customize the install by selecting th following additional options:

- Batter percentage for laptops.

- Backup graphic kexts.

- Bootloader Flags>Chameleon Config>SMBIOS>Macbook Pro 8,1


Install starts, goes all the way to 99% then fails with th following message:

"The operation could not be completed. Undefined error: 0"


Can this be possibly fixed somehow? Any help would be appreciated.

Share this post

Link to post
Share on other sites

0 answers to this question

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
1 1