• 0

CPUs=1 lapic_native Kernel Panic on HP laptop EVEN with CPUs=1!
1 1

Question

Let me start off by saying that I am willing to pay for some extra help if necessary. I love Yosemite and I've been struggling with this for a couple weekends, so if someone does a great job of helping out I can definitely recognize that via PayPal.

 

I have an HP DV6t-6100 with Insyde f1.b BIOS, i7 2820QM, Intel HD 3000 graphics and a Radeon HD 6770m 2gb on 16gb RAM and a hybrid 1tb drive partitioned 872gb Windows 7 / 128gb OS X Yosemite (hopefully).

 

I also have a 1920x1080 resolution screen that I don't care about getting working correctly, I just want to at least install.

 

I currently am attempting a Unibeast boot (so if I understand correctly, Chimera/Chameleon).

Previously, I've gotten as far as to run the installer in Yosemite Zone and even had a bootable Yosemite with -x and CPUs=1. I would go back to Yosemite Zone(at least I knew it could work) but for the life of me I cannot get the installer to run again. I can't get the bootloader to boot past the forward slash symbol in the upper left corner, and I don't know which version I had that was running. I've tried 3 out that I've found to each have different file sizes from various torrent networks and google searched - none of them work.

I get the bootloader to run - I select the USB drive of my four options to boot into, and using the boot flags -v, and CPUs=1 I get this screen here: post-160747-0-43692300-1421882697_thumb.

 

Notice that I have a lapic_kernel panic, on an HP laptop, which is typical. But look at my boot flags!! I have CPUs=1 set. I normally use -x as well, but I forgot here and it creates the same message regardless. I have a quad core 

 

 

It's common knowledge that HP Laptops have local APIC issues, well documented, and there is already a KernelPatcher.dylib fix for the issue(shouts out to donovan6000? I think). Supposedly you can use CPUs=1 as a short term fix for the issue. Obviously this isn't the case for me. Regardless of the fact that CPUs=1 didn't resolve the issue in my case,  I tried to use KernelPatcher.dylib, installed it in the Extra/modules folder using TransMac, and after I did that I got even less far in the bootloader process.

 

I don't care about working audio, working high resolution graphics, or anything else. If I can get to barely crawl through the boot and install process and get to a functioning Finder window I will be 100% happy. I can do the rest of the playing around with kext files stuff later, right now I just want it to boot.

 

Aside from the KernelPatcher.dylib I threw into Extra/modules (and then took out) I am using a completely virgin copy of Unibeast on a 64gb SanDisk USB drive.  

 

My Unibeast options: 

Yosemite 10.10.1 downloaded from Mac App Store on a real copy of Yosemite

Laptop Support On

Legacy USB On (didn't think I would need this one but without it I can't seem to load Chimera)

 

I don't have a DSDT file, and I'm not sure if I need one. I've looked at tonymacs DSDT section and they have HP ProBook but that's the closest thing I could find - didn't seem like quite a good fit. Was I wrong?

 

My motherboard, as typical of Insyde f1.b, is locked. It is using BIOS.

The options I have from memory are..

Virtualization(enabled)

action keys(enabled) changes Fx keys to require holding fn+Fx key, don't think this matters

switchable graphics fixed/dynamic(set to fixed.) this controls how the dual graphics switch, all the guides I've read have said to stick with Fixed so I haven't experimented too much out side of this setting.

fan always on(disabled) I think this lets the fan turn off if the CPU is cool enough. Don't think this matters, but my fan doesn't turn off during bootloader anyways lol

 

My hard drive is a fusion 20gb flash 980gb HDD. I don't know how this correlates to the bootloader - I've tried dropssdt=yes a couple times but it doesn't seem to do anything different. But like I said I did get Yosemite Zone running ONCE but I cannot(and believe me I have tried) get it to run again. I am definitely doing something wrong. I'd like to stick with Unibeast if possible, but I'm open to whatever, I'm even going to buy a second USB stick in a couple days here to test out two easily.

 

 

SO right now KernelPatcher.dylib is not installed, but it can be in a second. LET ME KNOW if there is ANY more information I can provide, I will be happy too. I tried to put everything I could think of in here. I've seen videos and posts of people with my same model of laptop, DV6t-6100, running Yosemite(more commonly mavericks) showing off that they have like 99% of the laptop working, so I know it's possible, I just don't know how they got there. I would be ecstatic if I could get this working tonight. Any help is so, so appreciated.

Share this post


Link to post
Share on other sites

0 answers to this question

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1