• 0

Problem with install on AMD PC (please help)
0

Question

Hi! I've tried installing 10.9.0 on my PC, these are my specs:

Motherboard: Gigabyte A75M-DS2

CPU: AMD Athlon II x4 641 (Socket FM1)

VGA: AMD Radeon HD7770

RAM: 4GB 1300Mhz(~)

HDD: 750GB Samsung SATA

 

BIOS config: AHCI enabled, HPET enabled(no 64bit option, just enable/disable)

 

Successfully reached Niresh start screen, tried these boot flags:

 

amd -v | Returns: RTC: Only single RAM bank (128 bytes), then: SMC: smcinithelper ERROR, then: panic [...] Kernel trap at [...]

amdfx -v | Returns: SMC: successfully init, then: warning: invalid kernel ip, won't attempt to handle trap, then: panic [...] Kernel trap at [...]

amd64 -v | Returns: 1024x768px blank black screen

 

Then i've tried applying one more bootflag: cpus=1 (Niresh suggested for someone else) Nothing changed, everything stuck at the same point

 

amd -v & amdfx -v > Last line of code where stuck: System uptime in nanoseconds

 

I've attached how it looks like, First image with amdfx -v | Second image with amd -v

 

Please help! What am i missing?

Posted ImagePosted Image

 

Share this post


Link to post
Share on other sites

11 answers to this question

  • 0

Post your BIOS settings and I will see if I can help you.

Hi! Here you go:

 

Advenced BIOS Features section:

-Load Line Control: Auto

-AMD C6 Support: Disabled

-Virtualization: Enabled

-AMD k8 Cool&Quiet: disabled

-C-state Pmin: Auto

-EFI CD/DVD Boot Option: NON-EFI

-First Boot Device: USB-FDD

-HDD SMART: Disabled

-Away Mode: Disabled

-FullScreen LOGO: Enabled

-Init display first: PEG(PCI, not onchip)

 

Integrated Peripherals section:

-OnChip SATA: Enabled

-OnChip SATA Type: AHCI

-Onboard LAN: enabled-Onboard LAN bootrom: disabled

-(blablabla, audio, usb3.0,usb legacy,usb storage,usb controllers enabled)

 

Power Management Setup Section:

-Soft-Off by Power button: Instant-Off

-USB Wake Up from S3: Enabled

-Modem Ring Resume: Disabled

-PME Event Wake Up: enabled

-HPET Support: enabled

-power on by mouse: disabled

-power on by keyboard: disabled

-AC back function: soft-off

-Power-On by Alarm: disabled

-ErP Support: disabled

Share this post


Link to post
Share on other sites
  • 0

Hey Man

Check the post

and disable all that is disabled in the pics shown. Thanks a lot to @

Share this post


Link to post
Share on other sites
  • 0

Hey Man

Check the post

and disable all that is disabled in the pics shown. Thanks a lot to @

I'll try, but the motherboards are nowhere near eachother, i don't think i'll manage to get it working with these settings

Share this post


Link to post
Share on other sites
  • 0

Hi! Here you go:

 

Advenced BIOS Features section:

-Load Line Control: Auto

-AMD C6 Support: Disabled

-Virtualization: Enabled ***DISABLE***

-AMD k8 Cool&Quiet: disabled

-C-state Pmin: Auto ***DISABLE***

-EFI CD/DVD Boot Option: NON-EFI 

-First Boot Device: USB-FDD

-HDD SMART: Disabled

-Away Mode: Disabled

-FullScreen LOGO: Enabled

-Init display first: PEG(PCI, not onchip)

 

Integrated Peripherals section:

-OnChip SATA: Enabled

-OnChip SATA Type: AHCI

-Onboard LAN: enabled-Onboard LAN bootrom: disabled

-(blablabla, audio, usb3.0,usb legacy,usb storage,usb controllers enabled) *** If there is any setting in here to do with EHCI, diable it.***

 

Power Management Setup Section:

-Soft-Off by Power button: Instant-Off

-USB Wake Up from S3: Enabled

-Modem Ring Resume: Disabled

-PME Event Wake Up: enabled

-HPET Support: enabled

-power on by mouse: disabled

-power on by keyboard: disabled

-AC back function: soft-off

-Power-On by Alarm: disabled

-ErP Support: disabled

 

 

Try those settings as I described, use amd64 -v and see what happens :) Note: if you still get a black screen, add GraphicsEnabler=No to that line.

Share this post


Link to post
Share on other sites
  • 0

Try those settings as I described, use amd64 -v and see what happens :) Note: if you still get a black screen, add GraphicsEnabler=No to that line.

Thanks for the advice, everything is set as you suggested, still pitch black screen, GraphicsEnabler=No didn't help either

Share this post


Link to post
Share on other sites
  • 0

Thanks for the advice, everything is set as you suggested, still pitch black screen, GraphicsEnabler=No didn't help either

 2 more suggestions - Disable HPET, and turn the Init Display first to Auto. I'll keep researching.

Share this post


Link to post
Share on other sites
  • 0

Excuse Me are You Facing Error of BlackScreen After Installing?

 

If it is after reinstall with the package backup all graphics extensions selected

Share this post


Link to post
Share on other sites
  • 0

 2 more suggestions - Disable HPET, and turn the Init Display first to Auto. I'll keep researching.

Hi! There's no AUTO mode in Init Display First, there are 3 options: PCI, OnBoard, PEG (tried them all, not working). HPET is disabled now, still nothing sadly. But thanks for the help, i hope we'll be able to solve this.

 

Excuse Me are You Facing Error of BlackScreen After Installing?

 

If it is after reinstall with the package backup all graphics extensions selected

No, i can't get to the OSX installer, i reach the darwin interface, type the flags (tried a lot of them), now i'm using: amd64 -v, it tries to load and then black screen

 

 

I've recorded the process on video so the last lines i get before the black screen is:

ACPI Table not found DSDT.ami

ACPI Table not found SSDT.amiNot an Intel platform. Restart fix is not applied !!!

LoadDrivers [...Extensions.mkext]

Read HFS+ [...Extensions.mkext] 4096 bytes

Read HFS+ [...Extensions.mkext] 15174552 bytes

 

and then boom, black screen

Share this post


Link to post
Share on other sites
  • 0

It has nothing to do with boot flags. There are plenty of people getting this error and no can seem to get it working as my self I have checked numerous of post and people said you need a patched (AMDA4,A6) Kernel to get over the Processor, Because its your processor causing the panic

1 person likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
0