• 0

HP Elitebook 8540p Displayport and VGA Not working for External Monitor
1 1

Question

Hi Guys, I've been learning a lot over the last few days, on what to do (and what not to do) in setting up Osx, After a failed attempt at installing a Yosemite distro by someone else, I downloaded Niresh's Mavericks 10.9 and honestly thought it wouldn't be as easy as a straight forward install, everything worked out of the box, except........ External Displays, and I'm not whining, you've done an amazing job with this release Niresh, HP laptops were not made for what we are trying to achieve here haha.

 

The issue I'm having is getting the Displayport and/or VGA to work so I can connect an external monitor, I am not sure if we can do this on the NVS 5100m, I see a lot of support out there for the geforce models and have tried just about everything to get it to work, updated Charmeleon, Installed the new quadro drivers, installed the CUDA drivers, tried GraphicsEnabler=Yes/No, all with no results which is frustrating to say the least, whats funny is when I remove the D/P plug my laptop screen flickers, as if it was trying to enable it but somethings stopping it, It works fine under windows, and doesn't flicker, I'm  not very clued up with apple and this is the first week I've ever attempted to make a hakintosh, so is there anything I'm missing here, or any sort of solution anybody has found for this, I'd be pretty stoked if any of you guys have.

 

Oh and after my upgrade to Mavericks 10.9.5 my USB and IDT seem to be fighting with each other, after removing the VoodooHDA kext the USB worked again, weird huh? I'll look into it further when I've got the time, at the moment I can use my external card, if you've got any info on that I'd be happy also.

 

Cheers guys - Jamie

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Right, Im an idiot, I sorted it out so if anybody ever tries to install osx on one of these laptops with the NVS 5100m card use GraphicsEnabler=Yes, find your NVCAP and add the NVCAP string to your charmeleon bootloader. Boom! You will have external Display, (Displayport Only, you will need a Displayport to DVI-D or VGA Cable). 

 

Add this

 

        <key>NVCAP_0a2c</key>
        <string>04000000000003007C0000000000000A00000000</string>

Share this post


Link to post
Share on other sites
  • 0

Update.... got the sound working, just used Niresh's Audio fix. It stopped working after the update to 10.9.5. Usb 2 working but 3 not yet will look into it. Got dual boot to windows 7 working now too. Also after the recent security update from apple my apple store won't login, if anybody knows of a fix for that let me know, Its a recent update so I'm not sure if anybody has picked up on it yet, so heres a heads up It may kill your ability to use apple store. Also the security update removes the ability to use NVIDIA drivers.... bugger wish I could rollback now. Still no external display, I'm going to go through my kexts and see if theres anyway to soft enable them.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1