• 0

Hackintosh on Virtualbox (Linux host)
1 1

Question

I'm trying to install on VirtualBox using the Yosemite iso from this site. I followed this howto: http://www.macbreaker.com/2015/01/virtualbox-yosemite-zone.html. The VM crashes as soon as the grey splash screen comes up. Here's the virtualbox log: https://bpaste.net/show/353728833a6a. I also tried the mavericks iso and I get the same error. I tried on VMware and I get an error about the CPU being disabled by the guest. On QEMU I don't get any errors but it hangs right after the splash is shown. I also downloaded a Mountain Lion vmware image from somewhere else and it gives me the same result. I tried different VM settings and boot options and at one point it seemed to boot but it never loaded a GUI, just a terminal that showed syslogd messages.

 

My virtualbox version is 4.3.26.

QEMU: Tried 2.2.0 and 2.3.0

VMware Workstation version 10.0.3.1895310

Linux kernel version: 4.0.1 on Gentoo

CPU: AMD A4-1250 APU with Radeon HD Graphics

Video: Advanced Micro Devices, Inc. [AMD/ATI] Kabini [Radeon HD 8210]

RAM: 4GB (2 for the VM)

Network: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter

Share this post


Link to post
Share on other sites

4 answers to this question

  • 0

Hello,

I have inform at some threads about success with VirtualBox Yosemite.

I am using VirtualBox Yosemite up to 10.10.2.  For installation I follow: http://www.macbreaker.com/2014/05/os-x-mavericks-in-virtualbox-with-niresh.html

Some details is impotent from:http://www.hackintosh.zone/forums/topic/5064-virtualbox-yosemite-install-stuck-at-2-minutes-left/page-12

For me only stuck at shotdown is a problem.

Good luck
 
 

Share this post


Link to post
Share on other sites
  • 0

Thanks for the reply. That's pretty much the same as the howto I was following, it has more stuff but I never got that far.

 

I saw another post where somebody mentioned problems with virtualbox 4.3.x so I decided to try 4.2.x but I had to downgrade my kernel to 3.18.13 in order to compile the virtualbox 4.2.x modules. After booting the new kernel I decided to try once more with virtualbox 4.3.26 and to my surprise it booted without problem.

 

I suspect it's not related to the new kernel but since I remember seeing a bluetooth message just before it crashed a few times it may be that I misconfigured the new kernel and the bluetooth driver is not working. I'm supposed to compile the bluetooth driver as a kernel module but I compiled it built-in and since I don't have the firmware for it on my initrd the driver fails to load. It's installing right now. After it's done I will rebuild my kernel with bluetooth support to confirm if that was the problem. Thanks.

Share this post


Link to post
Share on other sites
  • 0

Hello

Only inform that I updated my VirtualBox Hackintosh to 10.10.4 without any problem.

Best regards to all

Share this post


Link to post
Share on other sites
  • 0

Hello

Only inform that I updated my VirtualBox Hackintosh to 10.10.5 without any problem.

Best regards to all

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1