• 0

How to automate (auto-select) Niresh Yosemite booting sequence ?
1 1

Question

Can somebody aim me to where I can get the info on how to automate the booting sequence once Niresh Yosemite 10.10.1 has been installed?

Currently whenever a reboot occurs I must press enter after selecting the correct OS X partition. I'd like to specify a default partition and get it started after X secs (just like Windows...).

Can this be done? Admitedly I'm new to all this but I really did search around but couldn't find anything especially considering that Niresh package tightly knit I wouldn't want to mess the package balance installing stuff that would conflict with it.

- OS X 10.10.3

- CPU ( Intel Core i7 920)

- Graphic Card by exact name (nVidia GeForce GT260 in SLI)

- MotherBoard ASUS P6T DELUXE V2 (Intel LGA1366 Platform / X58 chipset)

- Ethernet (integrated in ASUS P6T DELUXE V2)

- "Sound" Card (ADI AD2000b )

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

Is this safe for in my case? :

youtube.com/watch?v=yiOrgz16BNE :

- OS X 10.10.3

- CPU ( Intel Core i7 920)

- Graphic Card by exact name (nVidia GeForce GT260 in SLI)

- MotherBoard ASUS P6T DELUXE V2 (Intel LGA1366 Platform / X58 chipset)

- Ethernet (integrated in ASUS P6T DELUXE V2)

- "Sound" Card (ADI AD2000b )

Share this post


Link to post
Share on other sites
  • 0

Ok I've figured out with the help of the video! So for the other newbies like me... :

 

* As in the video get the booting OS X partition/drive to show up on your desktop and open it

OR

Get to your OS X booting drive through Finder.

* Go in the Extra folder.

* Double click on the org.chameleon.Boot.plist file.

* Add the following just above </dict>:

<key>Timeout</key><string>3</string>
<key>Default Partition</key>
<string>hd(0,2)</string>
 
In my case my file looks like so:
 
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
     <key>EthernetBuiltIn</key>
     <string>y</string>
     <key>Graphics Mode</key>
     <string>1024x768x32</string>
     <key>GraphicsEnabler</key>
     <string>y</string>
     <key>Kernel Flags</key>
     <string>debug=8 ahcidisk=1 dart=0</string>


     <key>Timeout</key>
     <string>3</string>
     <key>Default Partition</key>
     <string>hd(0,2)</string>
</dict>
</plist>

Notice hd(0,2)  in <string>hd(0,2)</string> matches what I can see in the boot menu when I boot prior to modifying this file so I'd suggest that you make sure to take a note of the correct info to be typed in there first to be safe and not sorry.

Share this post


Link to post
Share on other sites
  • 0

Interesting, but unsuccessful for me at my 10.10.3 Hackintosh at MSI gs60.

I have to press Enter to start booting after I done insertion in org.chameleon.Boot.plist

Any comment, please.

Share this post


Link to post
Share on other sites
  • 0

Interesting, but unsuccessful for me at my 10.10.3 Hackintosh at MSI gs60.

I have to press Enter to start booting after I done insertion in org.chameleon.Boot.plist

Any comment, please.

 

 

Maybe the problem is with the hard drive partition identification.

Can you send a screen capture / photo of your standard booting menu?

Maybe you need to change "hd(0,2)" for something else.

Share this post


Link to post
Share on other sites
  • 0

Maybe the problem is with the hard drive partition identification.

Can you send a screen capture / photo of your standard booting menu?

Maybe you need to change "hd(0,2)" for something else.

Thank for attantion to my problem.

Find below picture of my booting screen and my plist file.

Please, any suggestion.

Alexandres-Mac-Pro:~ ran$ cat /Extra/org.chameleon.Boot.plist

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">

<plist version="1.0">

<dict>

    <key>EthernetBuiltIn</key>

    <string>y</string>

    <key>Graphics Mode</key>

    <string>1024x768x32</string>

    <key>GraphicsEnabler</key>

    <string>y</string>

    <key>Kernel Flags</key>

    <string>debug=8 ahcidisk=1 dart=0 npci=0x2000 nv_disable=1</string>

    <key>Timeout</key>

    <string>3</string>

    <key>Default Partition</key>

    <string>hd(0,2)</string>

</dict>

</plist>

Alexandres-Mac-Pro:~ ran$

Share this post


Link to post
Share on other sites
  • 0

Sorry for repeating. My picture is not inserted in previouse message.

Find picture of my booting screen here:https://drive.google.com/file/d/0B-rRgKAzYyoBaktHcDZtQktaUEU/view?usp=sharing

and my plist file below.

Please, any suggestion.

Alexandres-Mac-Pro:~ ran$ cat /Extra/org.chameleon.Boot.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>EthernetBuiltIn</key>
    <string>y</string>
    <key>Graphics Mode</key>
    <string>1024x768x32</string>
    <key>GraphicsEnabler</key>
    <string>y</string>
    <key>Kernel Flags</key>
    <string>debug=8 ahcidisk=1 dart=0 npci=0x2000 nv_disable=1</string>
    <key>Timeout</key>
    <string>3</string>
    <key>Default Partition</key>
    <string>hd(0,2)</string>
</dict>
</plist>
Alexandres-Mac-Pro:~ ran$

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1