ATI Radeon HD 5670 on Mavericks
3 3

23 posts in this topic

Hey Guys, 

I installed 10.9 on my Hackintosh and it works, but I have a problem with my graphics. 

I just can boot with the flag : GraphicsEnabler = No

Then it just shows me a 3MB Graphics Card

When I don't type that flag, it just shows the Apple Logo and the running circle an doesn't boot

 

Here a screenshot of my Hackintosh : 

 

http://imgur.com/xBBjnOI

Share this post


Link to post
Share on other sites

I tried to inject the Graphics with Clover, but he still gave me 5MB Graphics and a wrong screen resolution,

 

at first he gave me 1024x768 , now he gives me 1280x1024

My needed screen resolution is 1440x900

 

Posted Image

Share this post


Link to post
Share on other sites

I have this issue too. Tried to inject my graphics card with Clover but I still get the same amount of VRAM and I don't know what to do too. I can only change the resolution. I think I changed it with Clover Configurator, you can find it in Downloads section, as far as I know.

Share this post


Link to post
Share on other sites

but the clover configurator works when you installed clover on your mac partition , but i have clover on a usb stick

Share this post


Link to post
Share on other sites

Are you sure you install the right kexts for your graphic card?

Share this post


Link to post
Share on other sites

i just chose the ati graphics kext when i installed mavericks, i haven't installed the kext from QuitX yet

 

 

---EDIT---

 

I looked in the folder System/Library/Extensions and there weren't any ATI kexts installed

Share this post


Link to post
Share on other sites

i installed the kext with kext wizard now, but it didn't work , i found my vendor and device id in the kext as you can see here

 

Posted Image

Share this post


Link to post
Share on other sites

When you get to Clover bootloader, go to Options --> Graphics Injector --> and check Load VBios and InjectATI. See if it's working.

Also boot with -v, so you can see the booting log. Right before getting to login screen you should see a line like:

AMDxxxxxGraphicsController: * Device in slot: Slot-1 * 

If you get to login screen after this line, it might be working, I don't know, because from my experience after I get that line, my PC is restarting. If I don't get that it's all good but the video card it's still not working.

Share this post


Link to post
Share on other sites

I booted it with these things

At first it said : Controller: ATI SB600 (vendor id:1002, device id: 4383)

but it shows many issues later as you can see here :

Posted Image

Share this post


Link to post
Share on other sites

Remove AMDRadeonAccelerator.kext.

 

Do you get to the log in screen when you're using that flags?

Share this post


Link to post
Share on other sites

i'll try it when i am on my computerand yes it still boots to the bootscreen---EDIT---I deleted the AMDRadeonAccelerator.kext from S/L/E and booted with the flag 'GraphicsEnabler=Yes' and I turned off the GraphicsInjector and VBIOS in Clover, but it still shows me 5MB graphics

Share this post


Link to post
Share on other sites

---UPDATE---

 

I reinstalled Mavericks today and now it finds my graphics card and it works now.

Thanks for the support !!

 

Posted Image

1 person likes this

Share this post


Link to post
Share on other sites

try to reinstall it, don't change anything at the Graphics option in the installation , that was my problem hahaha

 

but now I have a problem with my sound :(

 

--UPDATE-- 

 

fixed sound now , and I found some graphic bugs , it shows too much red

 

rlEzn5i.jpg

Share this post


Link to post
Share on other sites

I think theres a post in the 10.9 section that someone had same issue with red icons.you should look for the post i think he solve the same issue and posted how he did it

Share this post


Link to post
Share on other sites

thanks @, I found a launchpad refresher and now it shows my icons right 

 

RrglgJW.png

Share this post


Link to post
Share on other sites

thanks @, I found a launchpad refresher and now it shows my icons right

RrglgJW.png

You welcome! And im glad you solve the issue. :)

Share this post


Link to post
Share on other sites

Hi, sorry for my english. I have the kext to ATI Radeon HD 5670 and my hackintosh recognize it. But, i have a problem and i need your help. I need the acelerator kext to HD5670 or something like that. because the video "cut" stop an go as like audio. Could be possible?

Thanks a lot to do my dream Hackintosh possible

Share this post


Link to post
Share on other sites

Kind of late to the party but..

I have read a lot of stuff about installing Mavericks on my PC but I guess I am not bright enough yet to grasp the Graphics part..

Is there somewhere or can someone give me a step by step on how to inject these Kexts please?

I can only get into safe mode ,can i get in there and do something ???

 

Motherboard: MSI P55-GD65 LGA 1156 

CPU: Core i7 860 Processor 860@ 2.80 GHz

Memory: 12 GB DDR3

Graphic card: ATI RAdeon HD5670

Mavericks 10.9

 

 

Share this post


Link to post
Share on other sites
On 9/16/2014, 7:06:21, billyinhudsonfl said:

Kind of late to the party but..

I have read a lot of stuff about installing Mavericks on my PC but I guess I am not bright enough yet to grasp the Graphics part..

Is there somewhere or can someone give me a step by step on how to inject these Kexts please?

I can only get into safe mode ,can i get in there and do something ???

 

Motherboard: MSI P55-GD65 LGA 1156 

CPU: Core i7 860 Processor 860@ 2.80 GHz

Memory: 12 GB DDR3

Graphic card: ATI RAdeon HD5670

Mavericks 10.9

 

 

 

On 9/18/2014, 11:57:46, Pavlos Daskalakis said:

Hi where i can find kext file for this video card????please?????

Hi, I can installed My HIS 5670 without any errors just follow this step http://www.macgazine.net/2015/03/how-to-enable-ati-radeon-hd-5670-on-os.html

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
3 3