• 0

HP Pavilion Dv6 Kernel Panic
2 2

Question

Hi!,
I just installed Mavericks on my desktop and then I tried to install it on my notebook.
I tried almost every combination of bootflags, but every time it ends with kernel panic.icon_crazy.gif

kp.thumb.jpg.445d5abefa7a5ca22e1ff1592cc

My specs:
HP Pavilion Dv6-6c20ec

AMD A4-3330MX APU with Radeon(tm) HD Graphics
Radeon HD 6480G]
Advanced Micro Devices, Inc. [AMD/ATI] Whistler [Radeon HD 6630M/6650M/6750M/7670M/7690M]


I can´t find any solution...Has anyone got a fix for it?beachball.gif

Share this post


Link to post
Share on other sites

6 answers to this question

  • 0

I got almost same problem, but i installed it succesfully but can't boot it. Installed it succesfully using
/amd cpus=1 -v, did you try this?

Now i have been trying every combination to get it working, but example using:
npci=0x2000 cpus=1 GraphicsEnabler=Yes -x -v, i get "Still waiting root device" and
ncpi=0x2000 cpus=1 GraphicsEnabler=Yes -v, without -x, iget one time "Still waiting root device" and after that kernel panic

2015-11-22_14.28.21.thumb.jpg.30e2767b1b

I got almost same pc specs:

Hp pavilion dv9500:
- AMD turion64 x2
- PhoenixBIOS F.34
- Nvidia GeForce 8400M GS

I have one harddrive and its parititoned to 2 section, i got windows vista in section 1 and OS X installed in section 2.

I hope we get these laptops working :)
 

Share this post


Link to post
Share on other sites
  • 0

I got almost same problem, but i installed it succesfully but can't boot it. Installed it succesfully using
/amd cpus=1 -v, did you try this?

Now i have been trying every combination to get it working, but example using:
npci=0x2000 cpus=1 GraphicsEnabler=Yes -x -v, i get "Still waiting root device" and
ncpi=0x2000 cpus=1 GraphicsEnabler=Yes -v, without -x, iget one time "Still waiting root device" and after that kernel panic

I got maverick suddenly working!

I installed maverick again, but this time i modified installation. example, changed cpus=1 so i dont need to write it everytime. I'm not sure what did i change there but after installation i booted mac, and get same "Still waiting root device" error. Then i just put my laptop cover off (PC was still on) and started playing with my main desktop. Took about 2-3hours i was hearing some talking and weird noises at laptop, and opened it and it was at language choosing screen! Finished installation and tadaa, now im using OS X Mavericks at my pavilion dv6500 laptop. :)

You can try this same thing too, if u get same error.

Share this post


Link to post
Share on other sites
  • 0

I got maverick suddenly working!

I installed maverick again, but this time i modified installation. example, changed cpus=1 so i dont need to write it everytime. I'm not sure what did i change there but after installation i booted mac, and get same "Still waiting root device" error. Then i just put my laptop cover off (PC was still on) and started playing with my main desktop. Took about 2-3hours i was hearing some talking and weird noises at laptop, and opened it and it was at language choosing screen! Finished installation and tadaa, now im using OS X Mavericks at my pavilion dv6500 laptop. :)

You can try this same thing too, if u get same error.

That´s good news!

But I can´t even install Mavericks...I´ve got this kernel panic after 5-10 seconds when I start installation with boot flags.

I´ve tried almost every boot-flags combination, but almost every time installation ends with this kernel panic :( . If not I´ve got black screen a nothing happens. I tried different bootloader for AMD. But it´s the same. I´m really desperate. 

I´ve tried to install yosemite before. I was able to install it, but graphics was awfull. And there is no graphics kext for my graphic card.

What boot-flags did you use for install?  ncpi=0x2000 cpus=1 GraphicsEnabler=Yes -v just these?

Enjoy your Hackintosh! :)

and sorry 4 my bad eng. :o

Share this post


Link to post
Share on other sites
  • 0
 I tried different bootloader for AMD.

 

Hi, what bootloader are you using? I did bootable USB using Niresh 12495 OS X 10.8 USB. It's using Chameleon bootloader.

What boot-flags did you use for install?  ncpi=0x2000 cpus=1 GraphicsEnabler=Yes -v just these?

 

I used in installation /amd cpus=1 -v boot-flags only. I getted in installation without cpus=1, but then it freezed in language selection.

/amd is important in niresh osx, if u'r using amd processor.

did you also tested safemode "-x" or "-f"?

Enjoy your Hackintosh! :)

 

Thanks, but now i need to wait everytime 2h until i can use mavericks :D. Always getting that same "Still waiting root device" error. Have to figure out howto get rid of that.

Edited by Hebnekki

Share this post


Link to post
Share on other sites
  • 0

Now when i look closly ur kernel panic, it says: "bsd process name corresponding to current thread kernel_task", so i think you have to change kernel, example use some of these:

There are Several Kernels Included
Amd Users Must Boot With
amd -v
amd64 -v
amdfx -v
Atom Users : atom -v
hp laptop users: hp -v
for users with instant reboot (Haswell): xpcm-free -v
ivy bridge: ivy -v
AMD Users Must Only Use Chameleon as Boot-Loader

(find these at http://www.hackintosh.zone/file/75-niresh-mavericks-109-with-amd-intel-usb-iso/, first one worked with me)

Share this post


Link to post
Share on other sites
  • 0

I think so, but I used every kernel and nothing changed.

It´s weird that I could install OSX yosemite, but when trying mavericks I get kernel panic :/

I also tried Mountain lion but instalation got stuck after few secs when loading some kexts.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
2 2