• 0

[SOLVED] El Capitan - problem with sound
1 1

Question

El Capitan - problem with sound

Hello,
I have successfully installed OS X El Capitan (10.11.4) from AppStore today.
I am using Clover bootloader.

After installation, video was working OOB, ethernet after installing kext, but I cannot get audio working.
My MB has Realtek ALC662 chip (Intel High Definition Audio)

At first time, I tried to use VoodooHDA 2.8.8, but as all versions before, sound is skipping every second. (Listen to attached audio "VoodooHDA-lag"... Recorded with iPad)
I tried to change settings in VoodooHDA pref panel, (check, uncheck "Use SSE2"), changing audio frequency in "Audio/MIDI setup" (between 44100, 48000 and 96000), but nothing changes.
I also tried to patch nodes, to get all ports. I got all 3 of them, and got sound on all speakers, but like before, it is skipping.

After that, I tried to use Native AppleHDA with Clover option "KextsToPatch" I found somewhere on net.
I applied this patches:

- Patch against assertions (Find: U291bmQgYXNzZXJ0aW9uIA == , Replace: AAAAAAAAAAAAAAAAAAAAAA == )
- ALC662-Fix (Find: hBnUEQ == , Replace: YgbsEA == )
- Zeroing 10ec0885 codec (Find: hQjsEA== , Replace: AAAAAA==)
- Zeroing 11d41983 codec (Find: gxnUEQ , Replace: AAAAAA)

After applying these patches, instead of 6, I got no more "Sound assertion in ..." errors at verbose boot), and got 2 of total 3 ports recognized in "System Report -> Audio" (see screenshot named "Audio" attached) but I got no Output and Input devices in "System Preferences->Sound" (see screenshot named "Audio2" attached).
Of course, there is NO sound.

In Clover I tried to set "Inject" to layout 0, 1, 2, 3, 5, 12 and 662. But none of them works, and I always get same situation.

What am I doing wrong?

Audio.tiff

Audio2.tiff

VoodooHDA-lag.mp3

-----------------
My PC Configuration is:

CPU: Intel Celeron J1900 QuadCore 1.99GHz
MB: ASRock Q1900M (Intel Bay-TrailD Chipset)
GPU: Gigabyte GeForce 210 (1GB DDR3)
Audio: Realtek ALC662 codec (Intel High Definition Audio)

 

Share this post


Link to post
Share on other sites

2 answers to this question

  • 0

Apparently, VoodooHDA lagged, because Clover detected incorrect Bus Speed.
Instead of 83000 KHz, I set it to 65970 KHz, and now it is working perfectly :)

Share this post


Link to post
Share on other sites
  • 0
On 05/05/2016 at 4:03 PM, duksi1993 said:

Apparently, VoodooHDA lagged, because Clover detected incorrect Bus Speed.
Instead of 83000 KHz, I set it to 65970 KHz, and now it is working perfectly :)

Hi duksi,

I'm having the same problem.. How did you change the KHz? Can you help me? Thxxx.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1