Startup Brightness Fix 1.1
1 1

By Deepak
(1)

About This File

Choose startup Brightness level:

You can choose startup brightness level by editing the "brightnessFix.pilst" file from the folder zip. Open the plist file in any text editors and change the value at the entry "ProgramArguments" for the last line of this to your desired brightness value at boot. Valid Brightness values are between 0.0, 0.1,0.2 ...... 1.0

9661588459_33cb0631e8_o.png

Installation:

  1. Download the attached BrightnessFix zip file
  2. Copy this file to Desktop and Extract the zip file (Note: if you don't copy the file to Desktop then my script won't work)
  3. Run the Script "Install" inside the BrightnessFix folder and enter password to give root access for the script

Uninstallation:

Follow the steps of Installation but use the script "Uninstall" at the end.

All Credits Goes to EmlyDinesh


What's New in Version 1.1

Released

  • with a bug fix (failed to wake screen) and optimizations.

1 person likes this

  • Download this file


  • User Feedback

    Create an account or sign in to leave a review

    You need to be a member in order to leave a review

    Create an account

    Sign up for a new account in our community. It's easy!


    Register a new account

    Sign in

    Already have an account? Sign in here.


    Sign In Now

    Deepak

    • 5
      

    Share this review


    Link to review
    • Similar Content

      • By ranitdatta
        Weird Post Installation Problems and Glitches
        I'm having numerous problems after installing macOS Sierra Zone. I created a bootable drive using the dmg file, and installation went smoothly with boot-args: npci=0x3000 and kcsuffix=amd1. 
        The problems I'm facing is: The icons on the menu bar (the finder bar) don't show up. The apple logo on the extreme left is missing and all the icons are distorted smudge of colours. 
        And the graphics is not working. Desktop tearing is occurring and the 'About this mac' shows graphics card as 'AMD Radeon 4330M 4 MB'. My laptop doesn't have 4330M, the GPU is 7460G and the discrete graphics card is 7670M. The hackintosh detects the 7670M, but the 4330M is set as the primary display. 
        I have tried using 'Inject ATI' in clover, 'LoadVBios' and 'PatchVBios', I have tried modifying the 'info.plist' in AMDradeon7000controller.kext and everything I could find.
        The screen tearing is unbearable. Please help! 
        Thank you!
        P.S.: My system is AMD APU A8-4500M, with dual Graphics: 7640G+7670M. Hard Drive 1 TB SATA, 8GB RAM.
        Direct Link: https://cl.ly/0l3v37283F3I/Errors - Copy.jpg
      • By Prototype~
        HELP ON INTEL HD 4000(Lenovo G500s)
        Hello,
        I have successfully installed Sierra on my laptop
        but main issue is Graphics,my laptop Runs on intel hd 4000 and nVidia GT 720m
        I have installed nVidia Drivers but cannot change default OS X drivers and Intel HD not working(in setup, graphics was working)
        I tried ig-platfom id:0x01660003,0x01660009 and boot args:IGPEnabler=Yes/No GraphicsEnabler=Yes/No
        but not success yet! can anyone help me on this please!
      • By domjohnson
        Scrambled web video, Yosemite Zone
        Hi,
        Apologies if this has been asked and answered (fingers crossed huh!) but I've searched and can't find anything relating to just this.
        By and large, graphics work completely fine for me, I have full resolution and its generally clear except for a couple of things: on YouTube - or any other web-based video website, the video comes out scrambled with loads of black lines. Video playing on VLC, however, works completely fine. Also the TonyMac website is really difficult to read as I get random red and yellow bars that move around, and the first couple of lines of text on each forum post are really thick, so characters lose their shape. Finally, some previews in Finder have that strange coloration with bits of red and purple - but not all of them. 
         
        I'm running a self-built PC with an AMD Athlon II X4 620 processor, Gigabyte MA770T-UD3P mobo, and an Asus Nvidia GT-710 graphics card (had the same problem on a GT-210 which I had in before). Booting with nvda_drv=1 GraphicsEnabler=No (doesn't boot when this is yes) npci=0x2000.
      • By EiDay
        Strange problem with Graphics in Sierra
        Hello, Few days ago I'd installed macOS Sierra on my PC, and now I have very big problem with graphics. Here is the video of my problem:https://www.youtube.com/watch?v=t6T4w2qHNCk  So:  1. My main(HDMI) screen doesn't work, I have to use my second VGA screen.  2. When I'm logging in, graphics is glitching and flashing.  3. I can't watch youtube video in fullscreen without flicking.    Any solutions? I'm using GTX 650     And I have a nvidia web drivers or something like that.  I can change default to Nvidia and it works, but I don't see any change after reboot.   I'm sorry for wrong forum category, but I can't find Sierra Support Center. :/
      • By chesco96
        Need help! instalation freezes in black screen!
        I boot up to the installation from my pendrive, then i choose the bootflags (tried many) and when i press enter, it freezes into a black screen. I tried the graphics enabler and the hp ones, these boot to a hackintosh image and freeze there. Please help!
        My laptop: Hp envy as001, intel i5 6260u, 6gb ram, 1tb hd, intel iris 540 graphics (integrated)
        thanks
    • Popular Contributors