Fix Still Waiting for Root Device
0

By Niresh
(4)

1 Screenshot


  • Download this file


  • User Feedback

    Create an account or sign in to leave a review

    You need to be a member in order to leave a review

    Create an account

    Sign up for a new account in our community. It's easy!


    Register a new account

    Sign in

    Already have an account? Sign in here.


    Sign In Now

    Niresh

    • 4
      

    Share this review


    Link to review
    Guest

    • 5
      

    Share this review


    Link to review
    Guest

    • 5
      

    Share this review


    Link to review
    Guest

    • 5
      

    Share this review


    Link to review
    • Similar Content

      • By whitespace
        Still waiting for root device ... again
        Hi,
        this is another question concerning "still waiting for root device". Like many others I feel like I read every tutorial or hint in every forum.
        I try to boot the yosemite installer from my pen drive, always getting stuck on "still waiting for root device". 
        the pen drive: Kingston data traveler 8GB, created with TransMac, only used with usb 2 ports
        cpu: AMD Athlon II X2 250 3Ghz
        board: ASRock N68-VS3 FX
        chipset: Geforce 7025, southbridge: nforce 630a
        bios: AMI P1.8
        I use the following boot flags: \amd64 -v npci=0x2000 pcirootuid=0 USBBusFix=Yes
         
        I get stuck here (Screenshot):
        https://cl.ly/0J2C1m2Y1l2A
        Thanks in advance
      • By eduardopastorfer
        I can install and use Mac OS X Mavericks.
        To install Mac OS X Mavericks utiliso these flags boot "/ amd -v -x -f NPC =0x2000 PCIRootUID=1" and there is no error, but in the installation of yosemite i have the bug still for root device.
        i checked this post; https://www.hackintosh.computer/59/hackintosh-still-waiting-for-root-device/
        My pc;
        PU: AMD A10-7870K 4.1Ghz (lack edition)
        GPU: AMD Shappire r9 380 Nitro Dual-x oc 4gb
        Motherboard: Ggabyte GA-F2A88X-DH3
        RAM: x2 G.Skill Ripjaws X DDR3 1866 PC3-14900 16GB 2x8GB CL9 (total 32gb)
        Audio: Codec Realtek ALC892
         

      • By Samuel Tulach
        El Capitan - Dell Vostro 3750 USB Problems
        Hi, I now have on my Dell Vostro installed Niresh Yosemite, but I want to install the El Capitan on the Dell Vostro 3750 (i7), but I have problems with USB. When I want to install El Capitan there are problems with the USB and then "Still waiting for root device".
        There is the video(s): https://drive.google.com/drive/folders/0B57KhqwPWwcIYnJtN05IZ1ZzWDA?usp=sharing
        There is the good spect of Dell Vosto 3750 (but for i3): http://www.cnet.com/products/dell-vostro-3750-17-3-core-i3-2310m-windows-7-home-premium-64-bit-2-gb-ram-250-gb-hdd-series/specs/
        For installation in video I use UniBeast USB in uEFI mode, but I tested vanilla installation and same problem.
        Attached images is from Yosemite.
        Please help and sorry for english!
         




      • By edux404
         Hello!
         
         I downloaded the Mavericks DMG and exported it to the USB flash drive using ROSA Image Writer (win32diskimage dind't work for me). So far so good. Restarted, booted from USB, entered the amd64 -v boot flag and it boots, everything loads up untill the message "AppleNForceSerialATA: found 0 entries" appears, followed by the still waiting for root device message. Restarted and booted to Windows. Did the fix Niresh suggested with the BootDiskUtility. Formated my other flash drive, deleted boot, replaced with the fixed one, renamed it to boot, went to Extra > Library > Extensions (I think thats the path) and replaced the kernels. Booted from this flash drive, everything fine. A "press any key to continue" prompt appears. However, if I press a key, it just reboots my computer, no matter what bootflags I use.
         Any further help is appreciated.
         
          --// My specifications --
           ASUS M4N68T-M LE
        NForce 630a Chipset
        AMD Phenom II X4 955 BE
        nVidia GT630
         
         Regards,
          Eduardo.
      • By YakubovEdem
        i downloaded  Niresh Mac OS X Mavericks 10.9 with AMD & Intel USB 10.9 https://www.hackintosh.zone/file/75-niresh-mavericks-for-intel-and-amd/
        than write that on USB flash drive (16 gb) 
         
        selected IDE " AHCI " in BIOS 
        starting install with flags amd64 USBBusFix=Yes -v 

        and have error "still waiting for root device" 

        Conf my computer: 
         
        AMD Athlone x64 5200+
        Biostar 8100 m2g+
        GeForce 630 2gb
         
        What i do wrong, help me pls!
    • Popular Contributors