OSINSTALL.POSTSCRIPT.PKG - Hackintosh Sierra - Hackintosh Zone Jump to content

Question

OSINSTALL.POSTSCRIPT.PKG

I have tried to install sierra multiple times now and it comes right to the last second of the install and i get the error "an error occurred while running scripts from the package OSInstall.postscript.pkg" 

Specs 

Msi 970 mobo 

AmdFX 8350 cpu

Gigabyte 1050TI Gpu

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

I have the same error but after rebooting i booted sierra and it works perfectly except for my graphics card(msi radeon r9 380 4gb).

Sorry for my english.

My pc specs:

Cpu: Amd FX 8320 @ 4.5Ghz

Mobo: Asrock 970 Extreme 4

Grpahics Card: Msi Radeon r9 380 4GB Gaming OC

Ram: Goodram Play 24Gb 1866mhz

Case: Cooler Master Haf XB Evo Lan Box

Cpu Cooler: Silentium PC Fera 2

Share this post


Link to post
Share on other sites
  • 0

Looks like an AMD-specific problem. The script mentioned fails to copy the kernel over. See the log excerpt below.

Oct 10 15:03:58 iMac OSInstaller[519]: PackageKit: Executing script "./postinstall" in /Volumes/Macintosh HD/.PKInstallSandboxManager/7DF6571B-78AE-49FC-8521-B29AE1D3A044.activeSandbox/Scripts/Hackintosh.Zone.Post-Script.p8OIb0
Oct 10 15:04:02 iMac OSInstaller[519]: ./postinstall: Clover bootloader detected
Oct 10 15:04:02 iMac OSInstaller[519]: ./postinstall: Installing AMD Kernel
Oct 10 15:04:02 iMac OSInstaller[519]: ./postinstall: cp: /System/Library/Kernels/kernel.amd: No such file or directory
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall: Error: kernel filename invalid
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall: usage: kextcache -prelinked-kernel <filename> [options] [--] [kext or directory]
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall:        kextcache -system-prelinked-kernel
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall:        kextcache [options] -prelinked-kernel
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall:        kextcache -invalidate <volume> 
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall:        kextcache -update-volume <volume> [options]
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall:        kextcache -system-caches [options]
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall: use kextcache -help for an explanation of each option
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall: Child process /usr/sbin/kextcache[3477] exited with status 64.
Oct 10 15:04:20 iMac OSInstaller[519]: ./postinstall: Error 107 rebuilding /System/Library/PrelinkedKernels/prelinkedkernel
Oct 10 15:04:20 iMac OSInstaller[519]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “OSInstall.postscript.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=./OSInstall.postscript.pkg -- file:///System/Installation/Packages/Hackintosh-Zone.mpkg#Distribution, PKInstallPackageIdentifier=Hackintosh.Zone.Post-Script, NSLocalizedDescription=An error occurred while running scripts from the package “OSInstall.postscript.pkg”.} {
	    NSFilePath = "./postinstall";
	    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cOSInstall.postscript.pkg\U201d.";
	    NSURL = "./OSInstall.postscript.pkg -- file:///System/Installation/Packages/Hackintosh-Zone.mpkg#Distribution";
	    PKInstallPackageIdentifier = "Hackintosh.Zone.Post-Script";
	}
Oct 10 15:04:20 iMac OSInstaller[519]: OSIInstallElement <OSIInstallElement: 0x7fcf43e94530> errored out:Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “OSInstall.postscript.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=./OSInstall.postscript.pkg -- file:///System/Installation/Packages/Hackintosh-Zone.mpkg#Distribution, PKInstallPackageIdentifier=Hackintosh.Zone.Post-Script, NSLocalizedDescription=An error occurred while running scripts from the package “OSInstall.postscript.pkg”.}
Oct 10 15:04:20 iMac OSInstaller[519]: ------- Install Failed -------

 

Share this post


Link to post
Share on other sites
  • 0

Hello , first sorry for my bad english because i’m french. I have solve this error with transmac on windows, i put the kernel.amd (/System/Library/Kernels/untiteldfolder)

 in /System/Library/Kernels on the USB installer and it work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $62.87 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • hello, I ask your community help as I installed Niresh Hackintosh Yosemite on a laptop asus x55c. all working except the dedicated INTELHD3000 video card. I have the video card id in the kext intelhd3000.kext and appleintelframebuffer. please just miss the acceleration to get a perfect hackintosh.
    • i have a Lenovo ideapad Y700 that won't boot to Mac OSX. its a Intel Core i7-6700HQ cpu @ 2.60GHz. 16 GB Ram with intel hd 530 Graphics and Nvidia Geforce GTX 960M. i got: uptime in nanoseconds error. the uptime i got on my machine is 2084132230. not the same everytime  
    • I previously installed yosemite on my pc. It worked well. But I can only boot the yosemite by cliking F10 advanced boot option and have to select my Hard drive. It didn/t boot automatically. So I just mounted the EFI folder and replaced the files from the original EFI I got from a link. Probelm started. So I planned to install Yosemite again. Keyboard not worked. So I boot back windows 10 and replace everything. But when I try to install yosemite again, sill I'm facing the probelm. Keyboard not working at selecting Yosemite zone screen. Keyboard is well functioning at BIOS screen, advanced boot option screen, even in my windows 10. But it freeze at the below screen. I tried everything, changed my Boot mode to UEFI and Legacy, reset CMOS by removing CMOS battery, restarted minimum 50 times, Changed my keyboard from USB to PS2, changed my USB keyboard port to every port. Please help me to solve this.   My System Config :   Intet i3-2120 CPU@3.30GHz 1 TB Hard drive 8 GB Ram 2GB GT610 graphic card Keyboard freeze at this screen.
    • Yes , I'm Jeff and I'm new around here. I was wondering what it takes to get a ISO file around here?  By the way I love your web site.  Hope to hear from you soon. Thanks.
    • I am fairly new to the idea of creating hackintoshes but I would love to dual boot Windows 10 and Mac OS Sierra on this machine listed below, will it be possible? Thanks in advance   Case CORSAIR OBSIDIAN SERIES™ 750D FULL TOWER CASE Processor (CPU) Intel® Core™i7 Ten Core Processor Extreme i7-6950X (3.0GHz) 25MB Cache Motherboard ASUS® RAMPAGE V EDITION 10: E-ATX, USB 3.1, SATA 6 GB/s Memory (RAM) 32GB HyperX PREDATOR DDR4 3200MHz X.M.P (4 x 8GB) Graphics Card   Asus Republic Of Gamers Strix NVIDIA GTX 1080 1st Hard Disk 480GB BiWIN 2.5" SSD, SATA 6 Gb/s (upto 564MB/sR | 513MB/sW) 2nd Hard Disk 6TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 128MB CACHE DVD/BLU-RAY Drive 16x BLU-RAY WRITER DRIVE, 16x DVD ±R/±RW & SOFTWARE Power Supply CORSAIR 1000W RMx SERIES™ MODULAR 80 PLUS® GOLD, ULTRA QUIET Power Cable 1 x 1 Metre UK Power Cable (Kettle Lead) Processor Cooling Corsair H100i V2 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans Thermal Paste ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND Extra Case Fans 2x 120mm Apache Black Quiet Fan (fitted to extract from rear/roof)     Sound Card ONBOARD 8 CHANNEL (7.1) HIGH DEF AUDIO (AS STANDARD) Wireless/Wired Networking 10/100/1000 GIGABIT LAN PORT (Wi-Fi NOT INCLUDED) USB Options MIN. 2 x USB 3.0 & 6 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS Operating System Genuine Windows 10 Professional 64 Bit - inc DVD & Licence Operating System Language United Kingdom - English Language DVD Recovery Media Windows 10 (64-bit) Professional DVD with paper sleeve Office Software NO OFFICE SOFTWARE Anti-Virus NO ANTI-VIRUS SOFTWARE Browser Google Chrome™ Warranty 3 Year Silver Warranty (1 Year Collect & Return, 1 Year Parts, 3 Year Labour) Delivery STANDARD INSURED DELIVERY TO UK MAINLAND (MON-FRI) Build Time Standard Build - Approximately 7 to 9 working days
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,539

    Latest File
    By rembrandt63

    352    0

×