Need help Radeon HD 6470m/6760m - macOS Sierra Zone - Hackintosh Zone Jump to content

Question

Need help Radeon HD 6470m/6760m

I have a HP Elitebook 8560p. The device id says 6760 (0x67601002). I can't get it to work with GPU acceleration in Sierra. Pasted is a AMD Framebuffer dump. I need help patching the kexts, and my config.plist to enable GPU & openCL in Sierra. IF it also works in Mavericks, I would appreciate help. I will donate to the cause if you can modify these kext, my config pllist, and whatever else to get my GPU working in sierra. 

Config.plist

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Graphics</key>
    <dict>
        <key>DualLink</key>
        <integer>1</integer>
        <key>FBName</key>
        <string>Elodea</string>
        <key>Inject</key>
        <dict>
            <key>Intel</key>
            <false/>
            <key>ATI</key>
            <true/>
            <key>NVidia</key>
            <false/>
        </dict>
        <key>LoadVBios</key>
        <true/>
        <key>InjectEDID</key>
        <true/>
        <key>VRAM</key>
        <integer>1024</integer>
        <key>VideoPorts</key>
        <integer>5</integer>
    </dict>
    <key>SMBIOS</key>
    <dict>
        <key>BoardType</key>
        <integer>10</integer>
        <key>ChassisType</key>
        <integer>8</integer>
        <key>BiosReleaseDate</key>
        <string>10/14/11</string>
        <key>Version</key>
        <string>1.0</string>
        <key>SerialNumber</key>
        <string>C02JNQGYDF8X</string>
        <key>Manufacturer</key>
        <string>Apple Inc.</string>
        <key>BoardManufacturer</key>
        <string>Apple Inc.</string>
        <key>ChassisAssetTag</key>
        <string>MacBook-Aluminum</string>
        <key>BiosVendor</key>
        <string>Apple Inc.</string>
        <key>ChassisManufacturer</key>
        <string>Apple Inc.</string>
        <key>BiosVersion</key>
        <string>MBP81.88Z.0047.B24.1110141131</string>
        <key>Board-ID</key>
        <string>Mac-94245A3940C91C80</string>
        <key>Family</key>
        <string>MacBook Pro</string>
        <key>ProductName</key>
        <string>MacBookPro8,2</string>
        <key>BoardSerialNumber</key>
        <string>C0214084217LH</string>
        <key>Mobile</key>
        <true/>
        <key>Trust</key>
        <true/>
    </dict>
    <key>RtVariables</key>
    <dict>
        <key>CsrActiveConfig</key>
        <string>0x67</string>
        <key>BooterConfig</key>
        <string>0x28</string>
    </dict>
    <key>Boot</key>
    <dict>
        <key>Arguments</key>
        <string>kext-dev-mode=1 dart=0 rootless=0</string>
        <key>Legacy</key>
        <string>LegacyBiosDefault</string>
        <key>Log</key>
        <false/>
        <key>NeverHibernate</key>
        <true/>
        <key>Timeout</key>
        <integer>5</integer>
        <key>XMPDetection</key>
        <string>Yes</string>
        <key>Secure</key>
        <false/>
    </dict>
    <key>ACPI</key>
    <dict>
        <key>DSDT</key>
        <dict>
            <key>Debug</key>
            <false/>
            <key>ReuseFFFF</key>
            <false/>
            <key>DropOEM_DSM</key>
            <false/>
        </dict>
        <key>DropTables</key>
        <array>
            <dict>
                <key>Signature</key>
                <string>DMAR</string>
            </dict>
            <dict>
                <key>Signature</key>
                <string>MCFG</string>
            </dict>
        </array>
        <key>SSDT</key>
        <dict>
            <key>DropOem</key>
            <true/>
            <key>Generate</key>
            <dict>
                <key>PStates</key>
                <false/>
                <key>CStates</key>
                <false/>
            </dict>
        </dict>
    </dict>
    <key>KernelAndKextPatches</key>
    <dict>
        <key>ATIConnectorsController</key>
        <string>6000</string>
        <key>ATIConnectorsData</key>
        <string>0200000000010000090100001204030300040000040300000001000010000505000400000403000000010000110201010004000000010000000910002103020200040000000100000009100022050404</string>
        <key>ATIConnectorsPatch</key>
        <string>0200000040000000090100001001010500040000040300000001000011020204000400000403000000010000210303020004000004030000000100001204040310000000100000000001000000000001</string>
        <key>AppleRTC</key>
        <true/>
        <key>AsusAICPUPM</key>
        <true/>
        <key>KextsToPatch</key>
        <array>
            <dict>
                <key>Name</key>
                <string>IOAHCIBlockStorage</string>
                <key>Find</key>
                <data>
                QVBQTEUgU1NE
                </data>
                <key>Replace</key>
                <data>
                AAAAAAAAAAAA
                </data>
                <key>Comment</key>
                <string>Enable Trim on SSD</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AirPortBrcm4360</string>
                <key>Find</key>
                <data>
                TWFjLTJFNkZBQjk2NTY2RkU1OEM=
                </data>
                <key>Replace</key>
                <data>
                TWFjLTk0MjQ1QTM5NDBDOTFDODA=
                </data>
                <key>Comment</key>
                <string>Broadcom 43224 whitelist</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AirPortBrcm4360</string>
                <key>Find</key>
                <data>
                QYP8/3QsSA==
                </data>
                <key>Replace</key>
                <data>
                ZscGVVPrKw==
                </data>
                <key>Comment</key>
                <string>Broadcom 5Ghz US</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                9oDUAAAAgHU6
                </data>
                <key>Replace</key>
                <data>
                9oDUAAAAgOs6
                </data>
                <key>Comment</key>
                <string>USB 3.0 Disable Intel USB3 controller check 10.9</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                9oDUAAAAgHU0
                </data>
                <key>Replace</key>
                <data>
                9oDUAAAAgOs0
                </data>
                <key>Comment</key>
                <string>USB 3.0 Disable Intel USB3 controller check 10.10</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                Zj0AAQ==
                </data>
                <key>Replace</key>
                <data>
                Zj0AAA==
                </data>
                <key>Comment</key>
                <string>USB 3.0 Disable XHCI 1.0 check 10.9</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                QbzHAgDgPQABAAA=
                </data>
                <key>Replace</key>
                <data>
                QbzHAgDgPQAAAAA=
                </data>
                <key>Comment</key>
                <string>USB 3.0 Disable XHCI 1.0 check 10.10</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                gUkIAABAAA==
                </data>
                <key>Replace</key>
                <data>
                gUkIAAAAAA==
                </data>
                <key>Comment</key>
                <string>USB 3.0 Patch MSI or pin interrupts #1</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                QcdHCAAAQAA=
                </data>
                <key>Replace</key>
                <data>
                QcdHCAAAAAA=
                </data>
                <key>Comment</key>
                <string>USB 3.0 Patch MSI or pin interrupts #2</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleUSBXHCI</string>
                <key>Find</key>
                <data>
                dU1Ii7voAQAA
                </data>
                <key>Replace</key>
                <data>
                601Ii7voAQAA
                </data>
                <key>Comment</key>
                <string>USB 3.0 Enable PCI power management</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleHDA</string>
                <key>Find</key>
                <data>
                gxnUEQ==
                </data>
                <key>Replace</key>
                <data>
                AAAAAA==
                </data>
                <key>Comment</key>
                <string>AppleHDA Patch 10.11</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleHDA</string>
                <key>Find</key>
                <data>
                hBnUEQ==
                </data>
                <key>Replace</key>
                <data>
                AAAAAA==
                </data>
                <key>Comment</key>
                <string>IDT 7605</string>
            </dict>
            <dict>
                <key>Name</key>
                <string>AppleHDA</string>
                <key>Find</key>
                <data>
                ixnUEQ==
                </data>
                <key>Replace</key>
                <data>
                BXYdEQ==
                </data>
                <key>Comment</key>
                <string>IDT 7605</string>
            </dict>
        </array>
    </dict>
    <key>GUI</key>
    <dict>
        <key>Theme</key>
        <string>Yosemite</string>
        <key>Mouse</key>
        <dict>
            <key>Enabled</key>
            <false/>
        </dict>
        <key>Scan</key>
        <dict>
            <key>Entries</key>
            <true/>
            <key>Tool</key>
            <true/>
            <key>Legacy</key>
            <false/>
        </dict>
        <key>Custom</key>
        <dict>
            <key>Entries</key>
            <array>
                <dict>
                    <key>FullTitle</key>
                    <string>UEFI Internal</string>
                    <key>Hidden</key>
                    <string>Always</string>
                    <key>Disabled</key>
                    <false/>
                    <key>Type</key>
                    <string>Other</string>
                </dict>
            </array>
        </dict>
    </dict>
    <key>Devices</key>
    <dict>
        <key>USB</key>
        <dict>
            <key>Inject</key>
            <false/>
            <key>FixOwnership</key>
            <false/>
            <key>AddClockID</key>
            <false/>
        </dict>
    </dict>
    <key>SystemParameters</key>
    <dict>
        <key>InjectKexts</key>
        <string>Detect</string>
    </dict>
    </dict>
    </plist>
 

AMD 6000 kext

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>BuildMachineOSBuild</key>
    <string>13F17</string>
    <key>CFBundleDevelopmentRegion</key>
    <string>English</string>
    <key>CFBundleExecutable</key>
    <string>AMD6000Controller</string>
    <key>CFBundleGetInfoString</key>
    <string>AMD6000Controller 1.24.38 14566</string>
    <key>CFBundleIdentifier</key>
    <string>com.apple.kext.AMD6000Controller</string>
    <key>CFBundleInfoDictionaryVersion</key>
    <string>6.0</string>
    <key>CFBundleName</key>
    <string>Radeon HD 6000 Controller</string>
    <key>CFBundlePackageType</key>
    <string>KEXT</string>
    <key>CFBundleShortVersionString</key>
    <string>1.24.38</string>
    <key>CFBundleSignature</key>
    <string>????</string>
    <key>CFBundleVersion</key>
    <string>1.2.4</string>
    <key>DTCompiler</key>
    <string>com.apple.compilers.llvm.clang.1_0</string>
    <key>DTPlatformBuild</key>
    <string>5A2053</string>
    <key>DTPlatformVersion</key>
    <string>GM</string>
    <key>DTSDKBuild</key>
    <string>13F17</string>
    <key>DTSDKName</key>
    <string></string>
    <key>DTXcode</key>
    <string>0501</string>
    <key>DTXcodeBuild</key>
    <string>5A2053</string>
    <key>IOKitPersonalities</key>
    <dict>
        <key>Controller</key>
        <dict>
            <key>ATY,Gibba</key>
            <dict>
                <key>aty_config</key>
                <dict>
                    <key>CFG_NO_HDCP</key>
                    <true/>
                    <key>CFG_NO_PP</key>
                    <false/>
                </dict>
            </dict>
            <key>ATY,Lotus</key>
            <dict>
                <key>aty_config</key>
                <dict>
                    <key>CFG_GEN_FLAGS</key>
                    <integer>1</integer>
                    <key>CFG_USE_STUTTER</key>
                    <true/>
                </dict>
            </dict>
            <key>ATY,Muskgrass</key>
            <dict>
                <key>aty_config</key>
                <dict>
                    <key>CFG_GEN_FLAGS</key>
                    <integer>1</integer>
                    <key>CFG_USE_STUTTER</key>
                    <true/>
                </dict>
            </dict>
            <key>CFBundleIdentifier</key>
            <string>com.apple.kext.AMD6000Controller</string>
            <key>IOClass</key>
            <string>AMD6000Controller</string>
            <key>IOMatchCategory</key>
            <string>IOFramebuffer</string>
            <key>IOName</key>
            <string>AMD6000Controller</string>
            <key>IOPCIMatch</key>
            <string>0x64701002 0x67601002 0x67681002 0x67701002 0x67791002 0x67601002 0x676010020x67611002 0x67501002 0x67581002 0x67591002 0x67401002 0x67411002 0x67451002 0x67381002 0x67391002 0x67201002 0x67221002 0x67181002 0x67191002 0x68401002 0x68411002 0x67041002</string>
            <key>IOProbeScore</key>
            <integer>65050</integer>
            <key>IOProviderClass</key>
            <string>IOPCIDevice</string>
            <key>aty_config</key>
            <dict>
                <key>CFG_CAA</key>
                <integer>0</integer>
                <key>CFG_CAIL_CAPS</key>
                <integer>0</integer>
                <key>CFG_FB_LIMIT</key>
                <integer>0</integer>
                <key>CFG_GEN_FLAGS</key>
                <integer>0</integer>
                <key>CFG_GRPH_CONTROL_DIS</key>
                <integer>40964</integer>
                <key>CFG_INTERNAL_1080P</key>
                <true/>
                <key>CFG_INT_SSPC</key>
                <integer>25</integer>
                <key>CFG_NO_HDCP</key>
                <false/>
                <key>CFG_NO_PP</key>
                <false/>
                <key>CFG_SURFACE_INFO_DIS</key>
                <integer>1703936</integer>
                <key>CFG_USE_FBC</key>
                <false/>
                <key>CFG_USE_STUTTER</key>
                <false/>
                <key>DALReadDelayStutterOff</key>
                <integer>4</integer>
                <key>DALUseUrgencyWaterMarkOffset</key>
                <integer>0</integer>
            </dict>
            <key>aty_properties</key>
            <dict>
                <key>PP_ActivitySamplingInterval</key>
                <integer>1000</integer>
                <key>PP_DisablePowerContainment</key>
                <integer>0</integer>
                <key>PP_HighSamplingInterval</key>
                <integer>200000</integer>
                <key>PP_MCLKStutterModeThreshold</key>
                <integer>30000</integer>
                <key>PP_R600ActivityHysteresis</key>
                <integer>5</integer>
                <key>PP_R600LoweringHighPercentage</key>
                <integer>25</integer>
                <key>PP_R600LoweringMediumPercentage</key>
                <integer>10</integer>
                <key>PP_R600RaisingLowPercentage</key>
                <integer>10</integer>
                <key>PP_R600RaisingMediumPercentage</key>
                <integer>25</integer>
                <key>PP_R600VotingRightsClients</key>
                <integer>12583475</integer>
                <key>PP_UserMaxClockForMultiDisplays</key>
                <integer>1</integer>
            </dict>
        </dict>
    </dict>
    <key>OSBundleLibraries</key>
    <dict>
        <key>com.apple.iokit.IOACPIFamily</key>
        <string>1.2</string>
        <key>com.apple.iokit.IOGraphicsFamily</key>
        <string>1.3</string>
        <key>com.apple.iokit.IOPCIFamily</key>
        <string>1.2</string>
        <key>com.apple.kext.AMDSupport</key>
        <string>1.2.4</string>
        <key>com.apple.kpi.bsd</key>
        <string>8.0.0</string>
        <key>com.apple.kpi.iokit</key>
        <string>8.0.0</string>
        <key>com.apple.kpi.libkern</key>
        <string>8.0.0</string>
        <key>com.apple.kpi.mach</key>
        <string>8.0.0</string>
    </dict>
    <key>OSBundleRequired</key>
    <string>Safe Boot</string>
</dict>
</plist>

Here's the ROM from the video card: 

PCI ID: 1002:6760

 

ATI Connectors Data:

Hydrilla (5)

LVDS, ????, DP, ????, DP

020000000001000009010000120403030004000004030000

000100001102010100040000000100000009100021030202

000400000001000000091000220505040004000004030000

000100001000040500040000040300000001000012040401

000400000403000000010000220505020008000004020000

 

 

ATI Connectors Patch:

LVDS, DP, DP, VGA, DP

020000000001000009010000000000001000000100000000

000400000403000000010000000000001204010300000000

000400000403000000010000000000001102020400000000

100000001000000000010000000000000010030800000000

000400000403000000010000000000002103040200000000

 

Warning: You may need to change the enc of LVDS to 01 to avoid screen mess

 

      

Framebuffer of Graphics Card (of I need “normal setting” or “ high resolution” ?

 

LDVS Normal:

 

0x0040

txmit # 10

enc# 00

sensid# 01

 

LDVS High

 

0x01000

txmit # 10

enc# 00

sensid# 01

 

DP (1) Normal

 

0x0604

txmit # 11

enc# 02

sensid# 04

 

DP (1) High

 

0x0604

txmit # 11

enc# 02

sensid# 04

 

DP (2) Normal

 

0x0604

txmit # 21

enc# 03

sensid# 02

 

DP (2) High

 

0x0304

txmit # 21

enc# 03

sensid# 02

 

DP (3) Normal

 

0x0604

txmit # 12

enc# 04

sensid# 03

 

DP (3) High

 

0x0304

txmit # 12

enc# 04

sensid# 03

 

VGA

0x0010

00

10

08


 

Share this post


Link to post
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
    • I have faced that problem to however does not  help with my current situation. ... I deleted other partitions and created Jhfs+ on the MBR no problems at all Still remains. Can NOT install on MBR natively as suggested ..... I have no reason to make this up    Any suggestions to get this working would be good. 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×