[SOLVED!] No bless setting for primary boot program was found. [SOLVED!] No bless setting for primary boot program was found. - Hackintosh Sierra - Hackintosh Jump to content

[SOLVED!] No bless setting for primary boot program was found.

Recommended Posts

Posted (edited)


IF ANYBODY ELSE IS HAVING THIS PROBLEM: simply change the bootloader to Chameleon instead of clover. If you want to have the bootloader on an EFI boot, install Chameleon EFI. (REQUIRES GUID SCHEME HARD DRIVE) if you are on legacy install Chameleon standard (Also works on MBR and GUID)

You can do all this in the "Customize" section when you select the hard drive to install macOS to. 

Go to Customize>Bootloader Uncheck Clover>Chameleon> Check Standard or EFI.




Hello all. I just ran into a problem on my AMD E1-522 1.4 GHz machine with 4 GB RAM (3.44 Usable). I did everything correctly, wiped the drive, made it Mac OS Extended, and then I got an error at the very start of the installation (at 16 minutes remaining):

"No bless setting for a primary boot was found."

I need help ASAP on this issue. I tried SierraAMD (from amd-osx) but it was too damn slow, even just to load the installer. And everything is much more faster with Niresh's distros. I successfully installed Yosemite, but it was buggy as hell so gave up on that. 

Thank you!

Edited by JoshFailingHackintosh

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting April 2018

    Please donate to support the community.
    We appreciate all donations!


    $31.08 of $100.00 goal reached.
    Donate Now