Audio is glitching / shuttering in Mavericks - Hackintosh Mavericks - Hackintosh Zone Jump to content
Sign in to follow this  
Aditya Prabhakar

Audio is glitching / shuttering in Mavericks

Recommended Posts

i installed mavericks on my AMD[1090T] -Gigabyte[motherboard - 990-FXA-UD7 ] but there is a big problem with Audio which is giving glitches or shutter type sound whenever i try to play anything with any player . i have already tried tried many thing . like updating VoodooHDA or AppleHDA but all in vain... Is there anyone who can help me in this ???  I'm fed up of this problem .....

Share this post


Link to post
Share on other sites
Guest karamelo

Set busratio to the right value on boot...

Share this post


Link to post
Share on other sites

Open terminal and copy and paste or type this in

 

 

yes > /dev/null

 

 

Then press enter. 

 

Minimize terminal do not, I repeat DO NOT close terminal or you stop the command and have Audio. This command  is better then moving the mouse around at all times. Let me know if this helps or if you tried this before. 

Share this post


Link to post
Share on other sites

I tested on 2 Asus Motherboards thought it might be worth a try on yours. Too bad sorry I couldn't help. 

 

Might be an issue with your Motherboards Audio card. Maybe an upgrade is in order. 

Share this post


Link to post
Share on other sites

i have solved this problem ..  by setting the exact bus ratio and after that giving that command including " sudo yes > /dev/null " thanks to you all...

but i want set that command in start-up by making a small program for this.. i tried but .. i'm not able to get privilege access to that .. can anyone help in this...??

 

 

These Lines are by Niresh:

Do not use "sudo yes > /dev/null"

This is a wrong concept here, cause all that the yes command do is use processor exclusively (100%) you can simply check from activity monitor and its not needed here. 

Edited by Niresh
Wrong Concept

Share this post


Link to post
Share on other sites

@ There you go! I created a script for you and you can download it from here: https://mega.co.nz/#!IN5HjQQS!vy9SNtu5S6l0Q8JaSLPsm6-j6mu6-pO7yGiNXsQfApI

It's an app that you have to put in the startup option. To set it in startup go to "System Preferences" and then go to "Users and Groups" then select your Mac account and go to "Login items", click on the "+" and select the script that you downloaded and then you should be ready to go! The only thing is that everytime that you boot the pc you need to insert your password in order to run the script but it isn't a big problem. Hope that this helped you, maybe give a like to this post and let me know if it works.  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $40.92 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • @Niresh i forgot to say that that error was given because i have a Samsung M2 NVMe 960pro. I tried to remove it and it kinda worked but with a lot of bugs even during the installation. I can't remember everything clearly now cause it's been like 4 months ago
    • Thanks. I Have One Ethernet And One Wifi. Here Is The Terminal Log :  iMac:~ marcus$ lspci -nn 00:00.0 Class [0600]: Device [8086:190f] (rev 07) 00:01.0 Class [0604]: Device [8086:1901] (rev 07) 00:08.0 Class [0880]: Device [8086:1911] 00:14.0 Class [0c03]: Device [8086:a12f] (rev 31) 00:14.2 Class [1180]: Device [8086:a131] (rev 31) 00:16.0 Class [0780]: Device [8086:a13a] (rev 31) 00:17.0 Class [0106]: Device [8086:a102] (rev 31) 00:1c.0 Class [0604]: Device [8086:a110] (rev f1) 00:1c.2 Class [0604]: Device [8086:a112] (rev f1) 00:1d.0 Class [0604]: Device [8086:a118] (rev f1) 00:1d.2 Class [0604]: Device [8086:a11a] (rev f1) 00:1d.3 Class [0604]: Device [8086:a11b] (rev f1) 00:1f.0 Class [0601]: Device [8086:a145] (rev 31) 00:1f.2 Class [0580]: Device [8086:a121] (rev 31) 00:1f.3 Class [0403]: Device [8086:a170] (rev 31) 00:1f.4 Class [0c05]: Device [8086:a123] (rev 31) 01:00.0 Class [0300]: Device [10de:1c82] (rev a1) 01:00.1 Class [0403]: Device [10de:0fb9] (rev a1) 03:00.0 Class [0c03]: Device [1b21:1242] 05:00.0 Class [0604]: Device [1b21:1080] (rev 03) 07:00.0 Class [0200]: Device [10ec:8168] (rev 15)
    • How many network adapters do you have? Like WiFi or Ethernet? Post output of lspci -nn command
    • Unfortunately i dont have any Option to disable my Grahpic Adapter. Can i disable it in an other way? Like any Boot Flags?   EDIT: I did just an Update for my BIOS but it didn't add any Options to disable my Graphics Adapter
    • This issue is called Discrete Graphics issue of High Sierra, To bypass this you have to disable either Intel HD Graphics 630 or Nvidia GeForce GTX 1060 from BIOS, Check into your BIOS to see if you have any options to disable Graphics, Then try booting Keep me updated
  • Download Statistics

    • Files
      845
    • Comments
      2,130
    • Reviews
      2,555

    Latest File
    By 8osm3rka

    21    0

×