Please Help!: Ethernet Won't Work - Hackintosh Mavericks - Hackintosh Zone Jump to content
  • 0
Enigmatic Affliction

Please Help!: Ethernet Won't Work


After spending many days I was finally able to get Mavericks to work on my computer. As far as I can tell everything works fine except the internet. When I go into the network utility it says internal ethernet, but it shows that it's not working. Then I go into the network settings and try to make a new connection, but I can't select ethernet as an option. I looked up my driver information and it says my computer uses the Atheros driver, so I installed the Antheros kext on my computer via Multi Beast, but it won't work. I even tried installing different network kexts, but no matter what I do I can't get the internet to work. I've been working on this for many hours today and I just want the internet to work, so I can download Skype and a few other programs. Here are my computer specs if that helps.


Gateway DX4380-UR308

AMD A8 5500 quad core processor

AMD Radeon HD 7560D graphics

8 GB Memory


I'd be EXTREMELY grateful to anyone who is able to help me fix this. I'm so close to getting OS X on my computer. If I can just fix this network issue I'll be set.

Share this post

Link to post
Share on other sites

16 answers to this question

Recommended Posts

  • 0

Yes I did and that didn't fix it, but I actually found out my computer uses realtek, not Atheros. I installed the realtek kext and that didn't do anything. Then I found a different realtek kext and that kind of fixed it. I say kind of because I still can't get internet, but it shows ethernet in the network settings now, but it keeps on connecting and disconnecting. Like it will connect for 1 second and then disconnect. It keeps doing this.

Share this post

Link to post
Share on other sites
  • 0

I was looking to Kext for the RealTek RTL8211

Finally found something but don't seems to work so well!!


Thanks for help

Share this post

Link to post
Share on other sites
  • 0

It was the Kext I tryed!


As soon as I try to go to my network (connect to my NAS for instance), I see folders but after double click I don't have any window to give my credentials and window close. Finder seems to freeze ...


May be it's not related to the NIC?


I also have Safari who is sooooo sloooooww ...

Share this post

Link to post
Share on other sites
  • 0
Guest InfamousSynergy

Try booting in safe mode, (-x). Go into multibeast and select you network driver and apply the patch. If it still doesn't work, googl for a 3rd party one use the one suggested above by KhatPhat and install it using kext wizard. You could always try a USB to Ethernet adapter or a wifi dongle as a last resort but bar trying out different Kexts, I'm not really sure as to how you go about fixing that issue...

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals


    Please donate to support the community.
    We appreciate all donations!

    $80.78 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hi, everyone, thanks for your time.
      I'm trying to fresh install macOS 10.13.1 (Build 17B48). I'm trying to do this by free myself from multibeast and by put kexts in EFI/CLOVER/kexts/10.3 and set a good config.plist.

      I have this famous issue in verbose mode and can't boot.
      IOConsoleUsers: time(0) 0->0, lin 0, llk 1,
      IOConsoleUsers: gIOScreenLockState 3, hs 0, bs 0, now 0, sm 0x0
        It's looks like your own issue.

      Every time, i can boot the first time. I start my post-install by install the web drivers automatically served by Nvidia. And never be able to boot again…
      I didn't found any plist option that permit to boot over this issue…
      help… !

      My list of kexts and my config.plist is joined.
      Thanks for your time…

      Here are my list of used kexts kexts/10.13 folder : NvidiaGraphicsFixup.kext    v 1.1.3 AppleALC.kext
      AtherosE2200Ethernet.kext    v 1.2.0
      FakePCIID_XHCIMux.kext        v 2.2.1
      FakePCIID.kext            v 1.3.9
      FakeSMC_ACPISensors.kext    v 6.25-333-g05e0f4be.1759
      FakeSMC_CPUSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC_GPUSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC_LPCSensors.kext        v 6.25-333-g05e0f4be.1759
      FakeSMC.kext            v 6.25-333-g05e0f4be.1759
      HDMIAudio.kext            v 1.0
      IntelMausiEthernet.kext        v 2.3.0
      Lilu.kext            v 1.2.0
      Shiki.kext            v 2.0.5
      USBInjectAll.kext        0.6.2 Driver64UEFI folder apfs.efi

      Gigabyte GA-Z170X-Gaming 5 | i7-6700(not K) | GTX980ti - OS on SSD.
    • Hi everyone, i got acer Aspire Icore 3 Laptop, and i've trie many installs, however, none of those worked on this laptop, even typing -x -v, never get the install menu, some of the run until the screen flash and reboot's again and again,, Anyone can give me a tip, i would try Yosemite, cause i got MacBook 5.1 can't upgrade to sierra/High Sierra ( well i can with a patch, but can't get the sierra installer ) i've put all the laptop specs on the screenshot.  i think all is components are compatible with mac,, above. Thanks in advance.file:///Users/Memphis/Downloads/Acer specs.png  
    • i am trying to install yosemite on a asus m2n sli deluxe chipset NVIDIA amd Athlon 64 X2 5600+ ATI Radeon HD 4800   and still i am stuck at pci configuration begin or console error. i tried several kernels and graphic cards with no results   i found some kext (no pci ea) now i come to the screen with language. and then it freezes   I’ve tried several thing but i am stuck is there anyone that can help
    • I've created install media with MacPawn as well as with Unibeast from High Sierra AppStore DMG ; The USB disk creation went smoothly, but when I try to boot from these disks all I get is a blinking cursor on top left of the screen, nothing else ... My Mac / Hackintosh : Asus P5Q Intel Core 2 Quad CPU Q8300 @ 2.50 GHz 8,00 GB RAM AMD Radeon HD 6450 Legacy IDE / ATA : 200 GB SATA : 320GB SSD : Kingston 120GB
    • Please install Niresh Yosemite now, at the first boot after installation i have full resolution with the intel hd 3000. after repairing permissions etc etc, i do not have any more acceleration at the new reboot. Sometimes by booting pennete I have acceleration graphic, starting from hard disk n. Ah, I got the Chameleon bootloader
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By rembrandt63

    418    0