Panic: A kext releasing a(n) OSArray has corrupted the registry. - Hackintosh Mavericks - Hackintosh Zone Jump to content

Panic: A kext releasing a(n) OSArray has corrupted the registry.

Recommended Posts

I built the Niresh 10.9.0 boot USB image and booted from it. I have tried multiple flags but I always end up with this panic before the installer loads:

panic(cpu 4 caller 0xffffff80006443ca): "A kext releasing a(n) OSArray has corrupted the reigstry. "@/usr/local/src/xnu-2422.1.72/libkern/c++/OSObject.cpp:218

Now earlier in the boot I noticed some suspect messages

ACPI Table not found: DSDT.aml
No DSDT found, using 0 as uid value.
Using PCI-Root-UID value: 0

Do I need to patch the Niresh image with a custom DSDT file for my board or does that come after installation is complete. Is this error message possibly related to my missing DSDT file?


System Specs:


Processor: Intel Core i7 2600K
Graphics: GeForce GTX 580
Memory: 8GB DDR3 (1333MHz, Corsair CML8GX3M2A1600C9)
Mainboard: Intel DP67BG
800W Corsair PSU



Share this post

Link to post
Share on other sites

Same error too. Same board too, DP35DP and Q6600. But I have panic on cpu 1. Can't install the mavericks.

  • Like 1

Share this post

Link to post
Share on other sites

I was checking and found this: org.tgwbd.driver.ElliottForceLegacyRTC is the cause of the kext releasing osarray ha corrupted the registry. Anyway to solve this?

  • Like 1

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!

    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I booted from the USB, selected "Yosemite zone", but this brings me back to the original problem. It is freezing on the hackintosh logo. Is there any way to solve this.
    • Well, the pkg is beginning to install High Sierra on my SSD, but then stops with the error code "could not be installed on this computer" 
    • I followed your tutorials which seems to be 1000% easy as its usually around the same as TonyMac, except your installs requires less to do and youve done most of the work too the package which makes it installing for us very easy. Now, the pic below shows a whole bunch of errors and I dont know why. Ive searched these forums and just like the title here, there is none which is odd, because from your tutorials, this shouldnt happen and it seems no one else is running into this problem, HOWEVER, if they did post something like this, Im 1, looking for the fix on high sierra, not sierra or tammy or roger or lutherin, 2 they need to check their titles again because its not helping anyone. I will say I did try installing Sierra Hackintish Zone version and it works all the way up to right after it installs, it tells me "it cannot be installed on this computer", SO....sigh, idk       So, to conclude, I do appreciate the devs here and much respect. Thanks for doing this. But guys, please help a bruh out and tell me how to fix this. Im using windows 10 as my main so do not tell me to go to do nothing on a mac, its the whole point of me coming here is to hackintosh. I do follow instructions fairly           well consider I teach Programming to the Military. My god bless this post soul too tbh <3       
    • Hello, I want to know what I have to do to install Kexts, use clover configurator, install bootloader, change resolution and how to use multibeast according to my hardware. I'm new to this mac configuration process. For now my hackintosh is pure, with no driver installed wifi, ethernet, graphics etc .. Sometimes when I start hackinstosh gives the Kernel Panic and stops loading on the apple screen, but I reboot and load normally. And also after a few minutes using the macOS it freezes the screen. I used the Hackintosh Zone Niresh Sierra because it was the only one that successfully installed on my notebook. My hardware is: Notebook Samsung Expert x23 Intel HD Graphics 5500 I5-5200U Processor Nvidia Geforce 910M 2GB 8 GB RAM HDD 1TB Bluetooth
  • Download Statistics

    • Files
    • Comments
    • Reviews

    Latest File
    By 8osm3rka

    27    0