How To Set Nvidia Card As Default Instead Of Hd3000 ? Help - OS X Mountain Lion 10.8.5 - Hackintosh Zone Jump to content
  • 0
Ondra Misák

How To Set Nvidia Card As Default Instead Of Hd3000 ? Help

Question

Someone please advise me how to set Nvidia Geforce 520m as the default and only Graphics card? I would like to replace the Intel Intel HD3000 with Nvidia 520m. I went through a couple's topic but I could not find anything. I tried to install KEXT (this) but still nothing. I think that you need to set some Nvidia graphics card ID, which would be fed. I really do not know. Does anyone have any experience with this?

 

Notebook specs:

  • [*]Processor: Intel Core i3 2310M (2,1 GHz) [*]Chipset: Intel HM55 [*]RAM: 4 GB DDR3 1066 MHz [*]Graphics Card: Intel HD3000 and NVIDIA GeForce GT520M (1024 MB)

 

Mac os X install (Drivers and config):

Posted Image

Posted Image

Posted Image

Posted Image

 

 

 

 

About mac:

Posted Image

Posted Image

 

 

 

 

 Nvidia graphics card ID (one of the methods)

0x104010de&0xffc0ffff1040 = "NVIDIA GeForce GT 520"1050 = "NVIDIA GeForce GT 520M "1056 = "NVIDIA NVS 4200M"1057 = "NVIDIA NVS 4200M "

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0

I have only AppleIntelIVBVA.bundle in my Extension folder.

 

I wanted to take the information from this list:

 

- AppleIntelHD3000Graphics.kext

- AppleIntelHD3000GraphicsGA.plugin
- AppleIntelHD3000GraphicsGLDriver.bundle
- AppleIntelHD3000GraphicsVADriver.bundle
- AppleIntelHD4000Graphics.kext
- AppleIntelHD4000GraphicsGA.plugin
- AppleIntelHD4000GraphicsGLDriver.bundle
- AppleIntelHD4000GraphicsVADriver.bundle
- AppleIntelHDGraphics.kext
- AppleIntelHDGraphicsFB.kext
- AppleIntelHDGraphicsGA.plugin
- AppleIntelHDGraphicsGLDriver.bundle
- AppleIntelHDGraphicsVADriver.bundle
- AppleIntelIVBVA.bundle
- AppleIntelSNBGraphicsFB.kext
- AppleIntelSNBVA.bundle

 

but only one file is located in my Hackintosh... What next?

Share this post


Link to post
Share on other sites
  • 0
Gatekeeper    19

No, this is Optimus, the Nvidia will never work in OSX, only your HD3000 will work, you must deactivate the  Nvidia in Bios , then your HD3000 will work.

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
nanerasingh    3

I also face same thing with my.

i select nvidia move extension and boots ok,it detected intel hd 4000 with 64 mb shared.but my video and launchpad is so laggy,safari dont works well.i think intel drivers not install properly.see attached picture.

please help me to work grpahics with full accleration.

 

Niresh please help.

I want anyone of intel hd 4000 or nvidia gt 620m to be work perfect.or both can work together

or if you can (please) provide me a kext with easy step.i dont know too much about mac.

post-44-0-32523400-1386901784_thumb.jpg

post-44-0-49218000-1386901802_thumb.jpg

Share this post


Link to post
Share on other sites
  • 0
Deepak    1,701

try MACBOOK PRO 8,1 SMBIOS to enable hd3000 latest version of Chameleon bootloader ...

Share this post


Link to post
Share on other sites
  • 0
nexuscan    0

guys, I have Asus a53sc model laptop with same specs.

 

Intel HD 3000 working well with QA and transparency windows and menu bar.

 

But I cannot load nvidia graphic card. Geforce GT 520 MX

 

can you help me about that. I just wanna use also nvidia.

 

ps: there is no option in bios change video card.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×