secondary HDD to run alongside install HDD for data - Hackintosh Mavericks - Hackintosh Zone Jump to content
Sign in to follow this  
Jamie White

secondary HDD to run alongside install HDD for data

Recommended Posts

Hi does anyone know how to setup another hard drive to store data and apps so i can keep my osx hdd free of clutter and speed it up, such as when you install an app it installs onto the secondary hard drive or download something from safari it automatically goes to that HDD i know how to do it on windows but not osx :(

Anyone help?

Share this post


Link to post
Share on other sites

Yes you can use a extra harddrive and formated as mac and use it for data and other stuff.

1-You can connect a extra hard drive to the motherboard

And at the diskutility formated as mac partition

And name it DATA or FILES or what ever name you

Prefer .and just use it for data/backups/music/movies/Etc..

2-You can format or resize the Hard drive you have mac installed on

And resize it to the size you want or need for extra files.

Also if you use a torrent downloader or browsers.set them to

Download and put the downloaded files to the extra drive.

Because most all the time they are just goin to download the

Files straight where the Os is Install at.

One easy way also: JUST BUY OR USE A EXTERNAL HARD DRIVE.and you it for Data :)

  • Like 1

Share this post


Link to post
Share on other sites

yeah i guess thats the only way i know it seems an obvious question haha!! but like what about apps and that as i got my OS on a 40gb hdd and space is rapidly dropping :s

Share this post


Link to post
Share on other sites

40Gb i Think is Too Little For you to Resize..if You plan to get movies/torrents/Music/etc

I think you need a bigger Hard drive.

  • Like 1

Share this post


Link to post
Share on other sites

I dont get what is your prob actually? You can't mount your HDD? Or permission is only "read"? If the permission is the problem then use Tuxera ntfs mounter for MAC (its free for 15 days, enough to save/write)then get a temp HDD from friend, save your data on that. Format as your exFat (very good if you mess with many OS)  and copy all your data from borrowed HDD to this exFat HDD ;)

Share this post


Link to post
Share on other sites

No what it is is i want to use one hard drive as the os drive and a secondary drive for all apps, music, downloads and documents like you can on windows set it so app files install to a secondary harddrive to keep my install drive free and clean from clutter

Share this post


Link to post
Share on other sites

Hmm I replied anyway for the prob. If its NTFS, mount is as writable using tuxera and backup all impo data you want. Once you did it, format it to HFS+ then use Disk Utility to extend your original OSX HDD.

Or if you just want to save your apps in another HDD, its simple in OSX as they don't install but self package. They don't especially need to be in application folder (except for some which need additional conf files). You can start any app you want from backup HDD.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • So I tried to install Mac OS X Sierra on my computer with the following specs :   - Intel Core i5 650 3.20GHZ - 12GB RAM DDR3 - 2 HDD (.1TB , 250GB ) - Nvidia Geforce 210 1GB VRAM DDR3   Everything was cool at first the installation went smoothly with no problems, after setting up everything I noticed that the graphics card has been detected by the systems but there is no acceleration and the resolution is 1024x768, I couldn’t change it   I tried a lot of kext drivers from multiple websites but no success, last kext crashes my os, I start getting black screen after the login page, and the computer restart it self immediately, so I decided to mess with the clover options to find if I can enable the graphics card from there, and WALLAA, the magic happened, I went to clover options then > Graphics Injector Menu > I checked : InjectNvidia option, and I checked : Use NVIDIA WEB Drivers   Note : I already installed Nvidia web drivers previously so you do that too before trying this method   After the restart it took longer then the usual to boot up, but once it got to the login page I noticed that the acceleration is working perfectly and the graphics has no bugs like before.   So until now everything is working fine and I’m enjoying my experience with Mac Sierra  
    • HI, I have the same issue. I have integrated Intel HD4000 and nVidia 620m. I tried with IGPEnabler, GraphicsEnabler and nv_disabled bootflags but none of them helped, it just got me additional kernel panic "AppleUSBHostPort: :disconnect: persistant enumeration failures". I also don't have option to turn off any of my graphic cards in BIOS.  Is there any solution to this issue?
    • ya no documentation ..and iam so confused to ..can some one make tutorial
    • Desktop Specs 
      Mob-: MSI X99a Godlike Gaming (MS-7883) (supports Legacy+UEFI)
      CPU- Intel 5820k (Haswell E)
      Graphics- MSI 980ti
      Ram- Avexir ddr4 8x4gb also, i have attempted using: OsxAptioFix2Drv-free2000.efi At the moment i typically get stalled with: Only single RAM bank (128 bytes) and some times I am getting: Couldn't allocate runtime area.
      Any advice would be greatly appreciated as im scratching my head wondering what the problem is - currently going to reformat the usb and start a new.
    • getting error (iobluetoothhcicontroller) (searchfortransporteventtimeouthandler) (missing bluetooth controler) apple loading bar stuck in middle if i boot normally. So i tried these  boot flags npci=0x2000 -v npci=0x3000 -v  -x-v PCIRootUID=1 -v PCIRootUID=0 -v still same error ?? Stuck in loading bar any solution?? thanks Acer Aspire 5733 (pew71) 

      Core i5 m560 @ 2.67 Ghz
      Intel HD Graphics
      Atheros AR5B125 Wifi
      Broadcom Net Link
      Realtek HD Audio
  • Download Statistics

    • Files
      848
    • Comments
      2,135
    • Reviews
      2,568

    Latest File
    By Vale1831

    1    0

×