My SATA drives disappears and OS X says "Ejecting error" - Hackintosh Mavericks - Hackintosh Zone Jump to content

Recommended Posts

Hi everyone !

 

I have a strange problem. I've just installed Niresh 10.9 on my AMD Athlon 64 x2 2.0 Ghz 2 GB DDR2 RAM. I have 2 SATA drives, one of 80 GB for OS X and another one of 500 GB for Windows 8.1 / Data / Time Machine. Everythings works fine but for an unknown reason, sometimes the second 500 GB drive suddendly disappear from my desktop saying Ejecting Error, try to disconnect the drive by…etc, just as if it was an USB external drive.

 

System Profiler detects it as a SATA drive, the icons aren't yellow, there's just like any normal drive and most of time, I can read/write on them without problems. I did a Time Machine backup without issues.

 

First I thought that it was a Kext conflict between SuperVIAATA.kext and IOAHCIBlockStorageInjector.kext or AHCI_3rdPartySata.kext but I tried to remove the two last of them and be able to boot fine (Removing SuperVIAATA.kext result as "still waiting for root device"). But the problem persist and I can't figure why !

 

The drive works fine on Windows and shows no errors, SMART state is reported as capable and OK and the 80 GB hosting OS X works fine as well.

 

My desktop is a HP dc5750 with the latest BIOS (configure in Native IDE mode - no AHCI available) and beside this very anoying problem under OS X, it works fine.

 

Any ideas ?

 

post-15330-0-57508400-1395508181_thumb.j

Share this post


Link to post
Share on other sites

If it can help, The SATA drive which disappears is a Seagate ST500DM002-1BD142. Another strange thing is that the Seagate disappears but the SATA drive (Western Digital WDC WD800JD-75MSA3)  where OS X is installed remains… for a few minutes until it shows KP due to IOATAFamily IOBlockStorage.

Share this post


Link to post
Share on other sites

I would like to know more.

 

1. How many partitions are in dat faulty SATA, with size.

 

2. How could you use time machine backup on a Win OS maintained HDD?

 

3. Are you using any 3rd party NTFS mounter for reading/writing data from NTFS?

 

4. Did you do any naming/labelling to drives in that HDD recently?

 

5. Did you try repair permission (OSX) or chkdks (Win) to that drive jusr before fault occurred ?

 

Last, what is the exact problem are you facing? Your OSX cant mount your SATA HDD?

Share this post


Link to post
Share on other sites

Hello !

 

1 SATA 80 GB hosting OS X (1 MBR partition) & 1 SATA 500 GB (1 NTFS partition MBR for Win 8.1 146 GB + 1 NTFS partition MBR for System Reserved 349 MB + 1 NTFS partition MBR for Data 196 GB and 1 HFS+ Mac OS X Extended MBR for Time Machine 158 GB)

 

I use Paragon NTFS 10.0 for Windows to see Mac partitions in Windows but I'm not using Time Machine on Windows, it's just a partition for him. I managed Time Machine backup by booting on the USB Nirech stick and use Time Machine restore.

 

On my first install, I used Tuxera NTFS for managing NTFS partition in OS X but I suspected that it may be the cause of the issue so I disinstalled it but the problem still occurs. When I did a clean fresh re-install of Niresh, I took care not installing it, just to be sure. But still the same.

 

I didn't rename/relabel my drives since the very beginning. I prepared my partitions with an ubuntu-live-CD and I formated them using Disk Utility for OS X & Time Machine and Windows 8.1 installer for NTFS partitions. (i've already did it on a lot of other Hackintosh and it always worked fine)

 

i repaired permissions a lots of times (Full disk and S/L/E and cache during the installation of my own kexts for Graphics and Networking. I ran CHDISKS a countless times in Windows, I even check both HDDs with Seagate and WesternDigital tools for Win and they didn't find any errors. Firmwares are up-to-date and SMART reporting is OK.

 

My exact problem is : I boot normally in OS X, I can see all my drives and partitions, I can read/write to all of them but after a while, all my second SATA drives partitions disappears and OS X says that an error occured while ejecting the disk (just like an USB stick unproperly ejected). My first HDD (hosting OS X) keeps working for a moment and then, OS X freeze. No KP, no nothing, it just freeze.

 

So it's not an hardware issue since Windows has no problems with both drives, it' a software issue and I think there's something wrong with the kexts that manage SATA drives. It appears that it's SuperVIAATA.kext that is mounting the drives and removing it from S/L/E cause a "wait for root device".

 

I can send you my logs and IOReg tree if it can help (too big for an attchment)

 

Thanks :-)

Share this post


Link to post
Share on other sites

Well, that is what I was guessing too, never repair permission on MBR HDD from OSX. It not only corrupts the whole FAT also does strange things. One more thing `i would like to add, no matter you format a partition as HFS+ but if windows is installed on this HDD, the whole disk gets MBR technology and causes problem(my own experience, may seniors wont agree). If you have a time machine backup (before this fault occurred will be better) then boot into windows, run chkdsk /f /r on each drive (C drive will need a boot time scan). Let it finish for each drive. Format your OSX 80 GB as HFS+, restore using time machine.

 

It might help.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I booted from the USB, selected "Yosemite zone", but this brings me back to the original problem. It is freezing on the hackintosh logo. Is there any way to solve this.
    • Well, the pkg is beginning to install High Sierra on my SSD, but then stops with the error code "could not be installed on this computer" 
    • I followed your tutorials which seems to be 1000% easy as its usually around the same as TonyMac, except your installs requires less to do and youve done most of the work too the package which makes it installing for us very easy. Now, the pic below shows a whole bunch of errors and I dont know why. Ive searched these forums and just like the title here, there is none which is odd, because from your tutorials, this shouldnt happen and it seems no one else is running into this problem, HOWEVER, if they did post something like this, Im 1, looking for the fix on high sierra, not sierra or tammy or roger or lutherin, 2 they need to check their titles again because its not helping anyone. I will say I did try installing Sierra Hackintish Zone version and it works all the way up to right after it installs, it tells me "it cannot be installed on this computer", SO....sigh, idk       So, to conclude, I do appreciate the devs here and much respect. Thanks for doing this. But guys, please help a bruh out and tell me how to fix this. Im using windows 10 as my main so do not tell me to go to do nothing on a mac, its the whole point of me coming here is to hackintosh. I do follow instructions fairly           well consider I teach Programming to the Military. My god bless this post and.....my soul too tbh <3       
    • Hello, I want to know what I have to do to install Kexts, use clover configurator, install bootloader, change resolution and how to use multibeast according to my hardware. I'm new to this mac configuration process. For now my hackintosh is pure, with no driver installed wifi, ethernet, graphics etc .. Sometimes when I start hackinstosh gives the Kernel Panic and stops loading on the apple screen, but I reboot and load normally. And also after a few minutes using the macOS it freezes the screen. I used the Hackintosh Zone Niresh Sierra because it was the only one that successfully installed on my notebook. My hardware is: Notebook Samsung Expert x23 Intel HD Graphics 5500 I5-5200U Processor Nvidia Geforce 910M 2GB 8 GB RAM HDD 1TB Bluetooth
  • Download Statistics

    • Files
      844
    • Comments
      2,012
    • Reviews
      2,512

    Latest File
    By 8osm3rka

    27    0

×