Help! My OSX Mavericks are not fully functional - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
slovius

Help! My OSX Mavericks are not fully functional

Question

slovius    2

I have successfully install OSX mavericks on my asus laptop..but now it seems that my OSX is not fully functional I am not sure which kexts to install to make it work properly. I don't want to install those kexts anyhow as I am afraid that it will cause the OSX to crash (it took me a long time to install it with a lot of work) so below are my specs and really thanks a lot for the advice from u guys (the pros)

Asus N56VZ (Laptop)

Intel® Core™ i7 3630QM Processor

Intel® HM76 Chipset

Windows 8 64 bit

DDR3 1600 MHz SDRAM 16GB

NVIDIA® GeForce® GT 650M with 4GB DDR3 VRAM

2.5" SATA

750GB 5400 RPM

Blu-Ray DVD Combo

Super-Multi DVD

Blue-ray reader

3 -in-1 card reader ( SD/ MS/ MS Pro/ MMC)

Integrated 802.11 b/g/n

Built-in Bluetoothâ„¢ V4.0 (Optional)

10/100/1000 Base T

Built-in Speakers And Microphone

Bang & Olufsen ICEpower®

Built-in Azalia compliant Audio chip

Creative Audigy HD

Asus N series external sub-woofer support

Share this post


Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 0
Devonic    129

@slovius

Graphics - Should work natively (GraphicsEnabler=Yes / No)

Sound - Use the VoodooHDA Package

wifi (AR 9485) - Not supported :( Try to replace withe AR 9285 )

Card Reader - Not working (only SD Card with patched AppleStorageDrivers kext)

  • Like 1

Share this post


Link to post
Share on other sites
  • 0
slovius    2

Ok Besides that how do I do dual boot? And also my bluetooth always have this problem that it can't detect keyboard but my keyboard is working how do I solve the bluetooth issue?..and u mention changing the wifi card from AR9485 to AR9285 is that possible for laptop?

Share this post


Link to post
Share on other sites
  • 0

Yes it is possible, But you need to be careful.

Dual boot is simple, just install windows as you do on an empty drive.

If you dont boot into Chameleon after Windows then boot using OSX USB-Installer and select OSX HDD.

Re-install chameleon.

Share this post


Link to post
Share on other sites
  • 0
slovius    2

i manage to do the dual boot thanks a lot for the info. my bluetooth still doesn't work what kext do i need to install for it to work? i come across this linkhttp://www.tonymacx86.com/mavericks-laptop-support/114657-osx-mavericks-asus-g750jx-installation-guide.html it mention that this guy manage to do some configuration to the  AirPortBrcm4360.kext and he got his wifi working, so i was wondering is there a chance that i could do some config as well to allow my wifi to work? :) 

Share this post


Link to post
Share on other sites
  • 0

I am closing this thread since your actual prob has been solved. Rest create a new thread for bluetooth. One advice for bluetooth is boot into Windows, turn bluetooth Off and on (visible). Let it be on (visible) and reboot into OSX.

 

Its a dirty game played Windows where it just turn off the hardware for other OSes. Even sound card and wifi card gets turned off by Windows is common.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
    • Im trying to install MacOSierra on Alienware 15 r2,  512ssd nvme 951 and 120gb intel sataIII samsung, i6820 hk 980m, intel 530. Ofter many attempts i solved a lot of erros during the installation, and finnaly i found out that macOs does not suport SSD. I created a patch for my ssds but now, i have this error: ACPI ERROR; and last: AppleNVMe Assert failed;  2 SSD: // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
      {
          External(_SB.PCI0.PEG0, DeviceObj)
          Method(_SB.PCI0.PEG0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
          External(_SB.PCI0.SAT0, DeviceObj)
          Method(_SB.PCI0.SAT0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
      }
      //EOF   I did the patch in virtual machine as they instructed. but still nothing.
    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×