Device problems after OS 10.9 Niresh install on my HP Pavillion Eliite m9517c - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
Lairi Love Whyte

Device problems after OS 10.9 Niresh install on my HP Pavillion Eliite m9517c

Question

Greetings!

 

My first successful install of 10.9 needs a few tweaks. I have followed you this far and  I am very impressed with the outcome. There are still some things that I don't get and would be very appreciative if you could point me in the right direction. PROBLEM: After install, my webcam, mic, bluetooth and Audio are not present. The display is present but not at any great potential. My iCloud is not functioning (I read it might do that). If anyone can help me with these (kexts) or enlighten me on how I can do it for myself, I would be so very thankful. :)

 

PC: HP Pavillion Elite m9517c

CPU:  Phenom 9550 Quad (MAC say its a 2.2ghz quad-core Intel Xenon

CHIPSET: GeForce 9100

MOTHERBOARD: Pegatron M2N78-LA

GRAPHICS: Geforce 9300 GE (256mb)

Audio: Alc 888c chipset HD

 

I hope I gave enough info...Thank you in advanced!

Share this post


Link to post
Share on other sites

7 answers to this question

Recommended Posts

  • 0

Start with easier one and one by one.

 

Try VooDooHDA (google it) for sound.

 

If it works then You should move to second prob.

Share this post


Link to post
Share on other sites
  • 0

Thank you Aman, for your response! I have Audio and my external drive has shown up. I cant get to enable qe/ci. Ive read how to edit kext but all seems to be vague at how to obtain a kext and write device ID & vendor ID and string without going into terminal.

Share this post


Link to post
Share on other sites
  • 0
Tom Smith    0

I have a similar setup as you.  I have a 

 

PC:  HP Pavilion Elite HPE-210f

CPU:  AMD Phenom II X4 945

Chipset:  AMD 785G

Motherboard:  H-RS880-uATX (Aloe) turns out the manufacturer is Foxconn

Graphics:  Nvidia GTX 560 Ti

Audio:  integrated Realtec ALC888S

 

I have two monitors hooked up to the graphics card.  My primary via HDMI and my smaller secondary via DVI port (with an adapter that turns it into DB9, old monitor).  I read that there would probably be issues with the HDMI port so I disconnected it and installed Niresh 10.9 with my secondary monitor on DVI.  I installed with just "amd64 -v" as my boot flags.  It took me a few installs to try some things out, but this seemed to work best.  I didn't mess with anything in the Customize menu during disk setup.  Once the OS loaded and permissions finished up I was able to reboot.  I was able to get back to the OS is I booted into safe mode using -x, but everything was slow including startup.  I finally narrowed it down to just typing in "GraphicsEnabler=Yes -v" and everything booted up and I had working ethernet, Audio, video.  Mac store and iMessage works.  I haven't gotten iCloud to connect yet.  

 

So maybe if you try something similar to what I did you will find success.  

 

I do have one other problem if anyone can help me.  When I plug my primary monitor into the HDMI port it makes my second monitor (which I installed with) turn off and the HDMI video doesn't get to my second monitor.  Any idea why that is?  Maybe there is something I need to do in OS that I am ignorant of or maybe it is a setup issue.  Or maybe I have to reset video resolution.  I don't need Audio thru HDMI, just video and both monitors will have different resolutions.

 

My org.chameleon.Boot.plist looks like this:

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Credits</key>
<string>www.hackintosh.zone</string>
<key>EthernetBuiltIn</key>
<string>y</string>
<key>GraphicsEnabler</key>
<string>y</string>
<key>Kernel Flags</key>
<string>npci=0x2000 dart=0</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>y</string>
</dict>
</plist>

Share this post


Link to post
Share on other sites
  • 0

Thanks Tom & Aman, yes i will try to mimic your procedure. I get a message at boot that my Nvidia 'ID Device"-"Vendor ID" rom can't be loaded. In my system report Graphics/dispays Device does not show kext loaded. I don't think I made the kext correctly. 

 

Tom, Do your bluetooh, webcam function as well?

Share this post


Link to post
Share on other sites
  • 0
Tom Smith    0

I don't have bluetooth or webcam built into my machine.  

 

I tried to get my dual monitor going on my GeForce GTX 560 Ti so I thought I could run multi beast to start that process.  Everytime I run multi beast it breaks my machine into not booting anymore.  So I must be setting something up wrong in it. I was able to go back into windows and edit by chameleon.plist back to original and copy back my original kext files and it then boots properly.  I'm not sure why multi beast breaks my machine.  I think it has something to do with the kext files because I tried just changing my chameleon.plist back to original and it wouldn't boot until I copied over my original kexts.  

 

So I still don't have dual monitor figured out yet.  

 

Which kext file are you trying to update for the device id?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×