Gave up on updating to 10.9.2 - Hackintosh Mavericks - Hackintosh Zone Jump to content

Question

Hello there!

 

Below are my PC Specs:

 

Intel Core i5-4670k CPU @ 3.8GHz

AsRock Z87M Pro4 Motherboard

2x 4GB DDR3 1333MHz A-Data

NVidia GeForce GTX 650Ti Boost OC (MSI Twin Frozr)

128GB SSD Intel 520 series

2x1TB WD Black 7200rpm 64MB Cache

 

Now, Just to state the obvious - with the exception of:

 - My mic volume being extremely low

 - The need to add a kernel flag to achieve autoboot

 

The machine works absolutely perfect right out of the box. Everything is buttery smooth and NICE! Never had any issues until I tried updating.

 

This is what happened:

 

1. I updated from the Mac AppStore => System failure.

 

2. Reinstalled. Updated from the Mac AppStore > Followed the guide Devonic wrote > System failure. Totally unable to boot into OSX.

 

3. Reinstalled. Updated from the Mac AppStore > Followed another guide somewhere on the web (Don't remember which one really) => System Failure. Totally unable to boot into OSX.

 

4. Reinstalled. Did NOT do ANY updates whatsoever => Machine works perfectly well!

 

I would just like to point out a few things to avoid some non-neeeded questions:

 

Q: Why do write this?

A: I promised Deepak I would, after exchanging a few messages and spamming the guide.

 

Q: Did you try booting with -x -s -f -F -v xpcm-free etc.

A: Yes. I tried every kernel flag in various combinations in between. No result whatsoever.

 

Q: What do you mean "Unable to boot into OSX"

A: Machine reboots. That's it. No errors, no nothing. Just a boot-loop.

 

Q: Did you try patching some files?

A: Yes. I re-wrote a lot of files! I even tried copying my entire "Extensions" folder and re-writing it after the update. Doesn't work! I tried the "SlowBootFix" thing, the "NoNcpi=" archive, etc. It just doesn't work on my machine.

 

Q: Did you try using a different bootloader?

A: Yes! I did try using Clover and Chameleon. No difference whatsoever.

 

Any more questions I will be more than glad to answer. I don't think I'll be attempting a system update anytime soon though. I don't feel like reinstalling AGAIN. I'm sick of backing things up. If there were an option to rollback a system update from the installer itself - maybe....

 

Cheers!
litttlegreen

Share this post


Link to post
Share on other sites

5 answers to this question

Recommended Posts

  • 0

Ok seems you are famlier with how to backup a .kext and inject it back with -s mode (Devonic's guide just replace the .kext in my suggestion).

 

Boot into you working OSX.

 

Create a TimeMachineBackup as my procedure is not a solution in each case.

 

Backup 2 kext from S/L/E named AppleIntelCPUPower*.kext (must be 2 kexts)

 

Download combo update 10.9.2 (google it)

 

Now install the update and reboot with -v -s

 

And follow guide to copy backup kext into you updated Mavericks. (Dont forget to fix permissions)

 

Now reboot with -v -f

Share this post


Link to post
Share on other sites
  • 0

I'll try it in the weekend. I simply don't have time to reinstall should anything go wrong right now.

 

Thanks a lot for the tip, though! I've seen combo updates lying around, but never quite got their idea. Could you elaborate please?

 

Cheers!

Share this post


Link to post
Share on other sites
  • 0

@littlegreen As i can see, i have a pc configuration similar to yours. I have added a post in Devonic thread 

 

https://www.hackintosh.zone/forums/topic/1878-how-to-fix-mavericks-not-booting-after-the-1092-update/?p=10495

 

I have updated my pc succefully to 10.9.2

 

http://s2.postimg.org/l5lye3mmx/Schermata_2014_04_09_alle_14_08_58.png (This is the proof that i have updated)

Share this post


Link to post
Share on other sites
  • 0

When Apple releases a minor system version (e.g. 10.9.1 -> 10.9.2), they generally release the update in two forms:

1.A delta update containing all of the files that changed in the latest update, which therefore can only upgrade from the immediately previous version.

For example, in order to install the 10.9.2, your system must already be updated to 10.9.1.

2.A combo update containing all of the changes since the original release of that major version, and therefore can be used on anything from the same major version.

For example, the 10.9.2 combo update can update from either 10.9.0 or 10.9.1; it can even be reinstalled on a system that's already running 10.9.2.

Similarly, the 10.8.5 can be run on anything from 10.8.0 to 10.8.5.

(Note that for the first update to a major version, e.g. 10.9.1 or 10.8.1, there's no real distinction between delta and combo, so Apple only publishes a single update form.)

My vote goes to combos because of ease. Once downloaded then no need to look at pc and wiat for it to connect and download each time. It even eases further if you have 2-3 PCs or your just a experiment lunatic (like me) and mess with your system 12 times each hour  :rolleyes: 

Share this post


Link to post
Share on other sites
  • 0

I found a very simple solution to my problem. It's a kernel patch I found on a 3rd party website and it worked like a charm. I could re-link it, but won't post it since I don't have the OP consent. It was just a matter of copy/pasting a few lines of perl code. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $62.87 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I am fairly new to the idea of creating hackintoshes but I would love to dual boot Windows 10 and Mac OS Sierra on this machine listed below, will it be possible? Thanks in advance   Case CORSAIR OBSIDIAN SERIES™ 750D FULL TOWER CASE Processor (CPU) Intel® Core™i7 Ten Core Processor Extreme i7-6950X (3.0GHz) 25MB Cache Motherboard ASUS® RAMPAGE V EDITION 10: E-ATX, USB 3.1, SATA 6 GB/s Memory (RAM) 32GB HyperX PREDATOR DDR4 3200MHz X.M.P (4 x 8GB) Graphics Card   Asus Republic Of Gamers Strix NVIDIA GTX 1080 1st Hard Disk 480GB BiWIN 2.5" SSD, SATA 6 Gb/s (upto 564MB/sR | 513MB/sW) 2nd Hard Disk 6TB SATA-III 3.5" HDD, 6GB/s, 7200RPM, 128MB CACHE DVD/BLU-RAY Drive 16x BLU-RAY WRITER DRIVE, 16x DVD ±R/±RW & SOFTWARE Power Supply CORSAIR 1000W RMx SERIES™ MODULAR 80 PLUS® GOLD, ULTRA QUIET Power Cable 1 x 1 Metre UK Power Cable (Kettle Lead) Processor Cooling Corsair H100i V2 Hydro Cooler w/ PCS Liquid Series Ultra Quiet Fans Thermal Paste ARCTIC MX-4 EXTREME THERMAL CONDUCTIVITY COMPOUND Extra Case Fans 2x 120mm Apache Black Quiet Fan (fitted to extract from rear/roof)     Sound Card ONBOARD 8 CHANNEL (7.1) HIGH DEF AUDIO (AS STANDARD) Wireless/Wired Networking 10/100/1000 GIGABIT LAN PORT (Wi-Fi NOT INCLUDED) USB Options MIN. 2 x USB 3.0 & 6 x USB 2.0 PORTS @ BACK PANEL + MIN. 2 FRONT PORTS Operating System Genuine Windows 10 Professional 64 Bit - inc DVD & Licence Operating System Language United Kingdom - English Language DVD Recovery Media Windows 10 (64-bit) Professional DVD with paper sleeve Office Software NO OFFICE SOFTWARE Anti-Virus NO ANTI-VIRUS SOFTWARE Browser Google Chrome™ Warranty 3 Year Silver Warranty (1 Year Collect & Return, 1 Year Parts, 3 Year Labour) Delivery STANDARD INSURED DELIVERY TO UK MAINLAND (MON-FRI) Build Time Standard Build - Approximately 7 to 9 working days
    • hii i am using samsung laptop intel i3   M370   2.40 Ghz  nvidia geforce  M315  graphics when i boot from usb,  firstly show some code and after this show a dialog box . in this box , showing a phone and laptop, one by one. on the top of the screen, showing apple logo and "Language Chooser". i am not able go next step.   plz help me.
    • Hi guys, I installed the Hackintosh Sierra Zone image and most things work except my graphics. It detects as AMD R9 290X when I use FakeID 0x67B01002 on boot, however I only get 7MB of VRAM with no QE. My screen also tears as well. Hope someone can help me - Intel Core i5 2500K - AMD R9 290X 4GB - ASUS P8Z77-V LX
    • Hey guys, I'm looking into dual booting OSX Sierra or High Sierra on my ASUS Zenbook Pro UX501V. I use a lot of mac only software like sketch at uni and it would make my life a lot easier to just be able to boot into it instead of going to campus to use one of their Mac's. I'm currently running windows 10 and would prefer to not have to lose all my files or reinstall windows 10, however if this is unavoidable I would consider it. Specs are Processor    Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
      GPU    NVIDIA GeForce GTX 960m 4gb DDR5
      RAM    12GB DDR4
      BIOS Version/Date    American Megatrends Inc. N501VW.300, 9/05/2016
      BIOS Mode    UEFI Does anyone know of any guides? Or has done this before? Even a link to point me on my way. Looked into the clover bootloader and I'm under the impression that's the route I'll have to take. Thanks for any help you may have      
    • Hi everyone. Here are my specs MOBO :Gigabyte Z68 XP UD3 (1155) GPU : HD 6870 1gb CPU Intel i7 2600k (1155) 60gb SATA SSD   MOBO is using legacy Bios. This machine has served me well for years. I tripped a circuit breaker a few weeks ago and now it's stuck in a boot loop. I have setup a new bootable USB to reinstall but for some reason the boot loop is happening when I startup from this as well. I can manage to get to the desktop using the safe mode boot flag (-x) but after a few moments, the desktop freezes and the computer reboots. I used the 10.10.1 disc image to create the new USB stick I am not sure if this could be causing the boot problem in the USB. Should I have used the 10.10.0? At first I suspected a hardware issue but I left the computer on for two days at in the bios screen and it stayed on just fine. Hoping someone can give me a hand figuring out which boot flags can get me going again or how I can reinstall the OS. I really need to get past the freeze/reboot cycle I am in. I am almost ready to nuke this thing and install windows
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,538

    Latest File
    By rembrandt63

    328    0

×