Get Triple Monitors Working on 10.9 With XFX HD 7750 - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
flexage

Get Triple Monitors Working on 10.9 With XFX HD 7750

Question

flexage    0

Hey Guys!

 

I've managed to get Niresh's OSX 10.9 running on my ASUS M5A97 LE R2.0, AMD FX 8350, XFX HD 7750 System...

 

Works pretty well apart from the network adapter locks up every now and then when multiple downloads are running, and onboard sound was broken (no problem for me as I'm using an external USB M-Audio).

 

It even works well with 'Dual' 1080 Monitors and I seem to have full Graphics Acceleration.
(One monitor connected via an active Display-Port to DVI, and the other on DVI Output 1).

 

My Stable Config is:

GraphicsEnabler=No

NPCI=0x3000

 

The only real issue is that I have to disconnect my third monitor (plugged in to DVI Output 2) before power-on in order for the system to not lock up around 10 seconds after log on. I have tried several methods but have NEVER (well, nearly never) managed to get the third monitor to display anything other than black at all.

 

The configs I have tried are:

 

  1. GraphicsEnabler=Yes
     
  2. PCIRootUID=0
     
  3. NCPI=0x2000
     
  4. GraphicsEnabler=Yes
    NPCI=0x2000

But none of these have proved fruitful, they have all ended in the same way.... with only a black screen on the third monitor (the other two showed the desktop fine and had the translucent menu bar) and then the system would lock up around 10 seconds later. Apart from number 4.... after a lot of flickering and 'FBRotate' doing it's thing the system didn't lock up but the third monitor was powered on, but black. A quick check of the more info on about this mac showed that all three monitors were recognised and active, but no picture.... I did notice that when moving the mouse between 2 screens the cursor would disappear while it apparently was travelling across the black screen, and then it would finally appear on the other working monitor! Strange! :P

 

I have also tried the FBRotate on user login fix, but this didn't work.

 

I have tried the sleep fix, which showed some promise, by which I mean the system would wake from sleep and all 3 monitors would come on and show a desktop (not mirrored! yay!) but immediately either the mouse and keyboard wouldn't work or the system had locked up (I couldn't tell which).... plus, it seemed that my CPU cooler hadn't powered back up (I use a Corsair Hydro H80i) so I immediately hard-powered off to avoid burning out the CPU!

 

I have even tried 'hot-plugging' the third monitor into the free DVI port, sometimes I get nothing, sometimes I get the equivalent of analogue tv static).

 

As a last resort I also tried the kexts for the HD 7850 from: osx86.net/file/3687-amd-hd7850-maverick-kexts-1092/ - but OSX didn't even seem to recognise my card with those installed (I did check that the device ID 0x683f existed inside them first), no avail :'(

 

So does anybody have any ideas in getting triple monitors working on this card, or has had any luck with anything similar?

 

Sorry if this is information overload!

 

Thanks in advance for any and all replies ;)

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
    • Im trying to install MacOSierra on Alienware 15 r2,  512ssd nvme 951 and 120gb intel sataIII samsung, i6820 hk 980m, intel 530. Ofter many attempts i solved a lot of erros during the installation, and finnaly i found out that macOs does not suport SSD. I created a patch for my ssds but now, i have this error: ACPI ERROR; and last: AppleNVMe Assert failed;  2 SSD: // Inject bogus class-code for NVMe SSD to prevent IONVMeFamily.kext from loading
      DefinitionBlock("", "SSDT", 2, "hack", "NVMe-Pcc", 0)
      {
          External(_SB.PCI0.PEG0, DeviceObj)
          Method(_SB.PCI0.PEG0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
          External(_SB.PCI0.SAT0, DeviceObj)
          Method(_SB.PCI0.SAT0._DSM, 4)
          {
              If (!Arg2) { Return (Buffer() { 0x03 } ) }
              Return(Package()
              {
                  "class-code", Buffer() { 0xff, 0x08, 0x01, 0x00 },
                  "built-in", Buffer() { 0 },
              })
          }
      }
      //EOF   I did the patch in virtual machine as they instructed. but still nothing.
    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×