ALC892 not working properly (crackling sound) - Sound Kexts - Hackintosh Zone ALC892 not working properly (crackling sound) Jump to content
Martín Isla

ALC892 not working properly (crackling sound)

Recommended Posts

Hi!

I’m new to the forums. So, first of all: I’m Martín, from Argentina. 19 years old.
 
I installed Niresh’s distro like a month ago, and I couldn’t find a working kext for this ALC892 Audio card. I either get crackling sound or no sound at all. Some kexts work better than others, but no one is really ok.
 
Tried MultiBeast, Slytherin and many (MANY) kexts from this forums.
 
This is my PC:
 
-ASUS M4A88TD
-8 GB RAM DDR3
-AMD Phenom II x6
-AMD 6870 Sapphire (1 GB GDDR5)
 
I don’t use DSDT. 
 
This is my bootloader file in Extra folder.
 
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>npci</key>
<string>0x2000</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>

 

 

 
Everything else works perfectly.
 
I hope you can’t help me so I have the perfect Hack Pro.

Thanks for everything!

Share this post


Link to post
Share on other sites

Oh! This could be important. I noticed that (contrarily from my laptop) the lower the "Format" (sorry, I don't know the English word for this) in the MIDI configuration app, the more the sound crackles.

Share this post


Link to post
Share on other sites

Same problem with a GA z77 Wifi board. using nVidia 650 Ti boost, and an ASUS screen. I fixed the crackling Audio problem by uninstalling the VoodoHDA from the pref panel.

so now there is no sound, an improvement from the volume not working properly also, but, sound does not work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $53.73 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Hello everyone,  I'm trying to install High Sierra (with AMD support) on my AMD 4500m Lenovo G505s laptop. When booting from Clover in EFI with i get some really fast screen log then the pc reboots. Now, i know there isn't a way you could help me without some info/logs, unless i'm missing a major malfunction known on these kind of laptops, so, do you know a way i could prevent it from rebooting in order to at least understand what is causing this problem? Do you think even trying to put OSX on this laptop is worth it? Thank you.
    • Hello, i am trying to install High Sierra on my ASUS X75VB but i am getting multiple errors with the ACPI.
      I believe it is CPU related?

      Mainboard: HM76 (X75VB SOCKET 0)
      CPU: Intel Core i5 3320m (Not the original CPU of this laptop!)
      GPU: Intel HD Graphics 4000 & NVIDIA 2GB Geforce 740M
      RAM: DDR3 8GB
      Storage: 120GB SSD (SATA-2)

      I have used the DSDT.aml & SSDT.aml from the following resource:
       https://github.com/xxx10101xxx/ThinkPad-X230-macOS/tree/master/i5-3320M

      My config.plst can be found here:
      https://drive.google.com/open?id=1lK7ixY8fAvtIJv8gY6Gf-RQvKJBVcFLm

      Thanks in advance!
    • im already download 10.12 and 10.13 . when im trying install 10.12 . all works fine , like resolution already 1920x1080 , sound , network all fine .. but when im trying install 10.13. resolution wont 1080 , already install nvidia web drivers , but hopeless..

      using Nvidia GT630 , btw .
    • I have Yosemite Zone working on Virtualbox fine.  After downloading High Sierra Zone there is only a dmg and no ISO.  I tried converting the dmg with hdiutil but it goes to 8GB and I get "no bootable media" in Virtualbox.  Has anyone been able to do this yet? 
  • Download Statistics

    • Files
      849
    • Comments
      2,144
    • Reviews
      2,627

    Latest File
    By ka209

    116    0

×