ALC892 not working properly (crackling sound) - Sound Kexts - Hackintosh Zone Jump to content
Martín Isla

ALC892 not working properly (crackling sound)

Recommended Posts

Hi!

I’m new to the forums. So, first of all: I’m Martín, from Argentina. 19 years old.
 
I installed Niresh’s distro like a month ago, and I couldn’t find a working kext for this ALC892 Audio card. I either get crackling sound or no sound at all. Some kexts work better than others, but no one is really ok.
 
Tried MultiBeast, Slytherin and many (MANY) kexts from this forums.
 
This is my PC:
 
-ASUS M4A88TD
-8 GB RAM DDR3
-AMD Phenom II x6
-AMD 6870 Sapphire (1 GB GDDR5)
 
I don’t use DSDT. 
 
This is my bootloader file in Extra folder.
 
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>No</string>
<key>IGPEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>npci</key>
<string>0x2000</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>

 

 

 
Everything else works perfectly.
 
I hope you can’t help me so I have the perfect Hack Pro.

Thanks for everything!

Share this post


Link to post
Share on other sites

Oh! This could be important. I noticed that (contrarily from my laptop) the lower the "Format" (sorry, I don't know the English word for this) in the MIDI configuration app, the more the sound crackles.

Share this post


Link to post
Share on other sites

Same problem with a GA z77 Wifi board. using nVidia 650 Ti boost, and an ASUS screen. I fixed the crackling Audio problem by uninstalling the VoodoHDA from the pref panel.

so now there is no sound, an improvement from the volume not working properly also, but, sound does not work.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $49.70 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • I booted from the USB, selected "Yosemite zone", but this brings me back to the original problem. It is freezing on the hackintosh logo. Is there any way to solve this.
    • Well, the pkg is beginning to install High Sierra on my SSD, but then stops with the error code "could not be installed on this computer" 
    • I followed your tutorials which seems to be 1000% easy as its usually around the same as TonyMac, except your installs requires less to do and youve done most of the work too the package which makes it installing for us very easy. Now, the pic below shows a whole bunch of errors and I dont know why. Ive searched these forums and just like the title here, there is none which is odd, because from your tutorials, this shouldnt happen and it seems no one else is running into this problem, HOWEVER, if they did post something like this, Im 1, looking for the fix on high sierra, not sierra or tammy or roger or lutherin, 2 they need to check their titles again because its not helping anyone. I will say I did try installing Sierra Hackintish Zone version and it works all the way up to right after it installs, it tells me "it cannot be installed on this computer", SO....sigh, idk       So, to conclude, I do appreciate the devs here and much respect. Thanks for doing this. But guys, please help a bruh out and tell me how to fix this. Im using windows 10 as my main so do not tell me to go to do nothing on a mac, its the whole point of me coming here is to hackintosh. I do follow instructions fairly           well consider I teach Programming to the Military. My god bless this post and.....my soul too tbh <3       
    • Hello, I want to know what I have to do to install Kexts, use clover configurator, install bootloader, change resolution and how to use multibeast according to my hardware. I'm new to this mac configuration process. For now my hackintosh is pure, with no driver installed wifi, ethernet, graphics etc .. Sometimes when I start hackinstosh gives the Kernel Panic and stops loading on the apple screen, but I reboot and load normally. And also after a few minutes using the macOS it freezes the screen. I used the Hackintosh Zone Niresh Sierra because it was the only one that successfully installed on my notebook. My hardware is: Notebook Samsung Expert x23 Intel HD Graphics 5500 I5-5200U Processor Nvidia Geforce 910M 2GB 8 GB RAM HDD 1TB Bluetooth
  • Download Statistics

    • Files
      844
    • Comments
      2,012
    • Reviews
      2,512

    Latest File
    By 8osm3rka

    27    0

×