MSI Radeon HD 7770 Ghz edition - Graphics Kexts - Hackintosh Zone Jump to content
James Moore

MSI Radeon HD 7770 Ghz edition

Recommended Posts

James Moore    0

Hey guys. New to hackintoshing. I've had some experience with getting installs working in virtual box on other systems before but that's it.

I successfully got the Niresh mavericks 10.9 distro installed to my pc after some fiddling around with partition issues.

Now I'm having an issue booting to the os after install. I get a "memory allocation error! 0xdeadbeef, Size: 0x0, File: ati.c, Line: 1772" error.

I tried using -v -x and GraphicsEnabler=No, the latter killed the error but causes the os to reboot over and over after loading some initial files. I never actually get to the boot loader menu.

I also tried changing init display in bios to onchipvga which gets me to the boot loader but then reboots itself over and over even when using the same boot flags.

My specs are

Gigabyte GA-MA790GPT-UD3H

AMD Phenom II x4 965 black edition

6gb ram. It's gskill not sure model

MSI Radeon HD 7770 Ghz edition

I'm at a loss at this point on how to get this working properly. I have windows 7 ultimate on same pc different hdd and hfs+ drivers so I can use windows to modify files if need be. I can also take videos or screenshots with my iphone if I need to.

Any ideas on how I can get this running?

Share this post


Link to post
Share on other sites
James Moore    0

I have attached a photo of the beginning of verbose output. It looks like both my onboard video and my video card are recognized in the boot process. However once I get to "starting Darwin x86_x64" it displays the boot args and then reboots itself automatically. Now mind you this is all only showing if I use the onboard video as the init display in bios.

I can share what boot args shows. But I doubt it's helpful as it shows the flags used by bootloader and the flags I set. Also all this info is only displayed if I try booting to safe mode. Single user mode and normal boot fail earlier on, likely for same reasons.

I think Niresh auto installs chameleon bootloader. So I'm curious if trying a different one like clover may help. I'm also not sure if dsdt would be necessary in my case or some device id injection or something.

Any help would be appreciated. If any additional info is necessary let me know.

Share this post


Link to post
Share on other sites
James Moore    0

Hrmm picture never uploaded correctly from my phone. Oh well I found out completely disabling onboard graphics entirely allows me to reach boot loader with video card, however I still get the memory allocation error. If I use GraphicsEnabler=No then it will load darwin but never start it, it just reboots the pc at the end of the loading process. At this point I'm still at a loss because I'm not sure what I would need to do to get this working.

Share this post


Link to post
Share on other sites
James Moore    0

So I got everything working. I reinstalled a third time. But this time I set cpus=4 and I removed dart=0 and added pcirootuid=1.

I downloaded the radeon7000controller kexts on this site and installed them. Used GraphicsEnabler=No. However the radeonaccelerator kexts doesn't load at startup and errors out. I can still boot. But I noticed in safari I have glitchy graphics and artifacts. I also have no sound via hdmi. Anyone know what I need to do to fix these two things?

I also have issues with putting the computer to sleep and restarting. The pc will shutdown the os and run Mach reboot but hangs. On sleep the hard disk spins down but that's it. Screen goes black with just mouse cursor and pressing any key redisplays the login screen.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hey!  I successfully installed macOS Sierra with the Version SierraAMD v3 on my AMD Pc.  But after setting up the PostInstall via Terminal, the OS stops booting at this line : ioconsoleusers: gioscreenlockstate 3, hs 0, bs 0, now 0, sm 0x0 Any solutions?    My System Specs: Mainboard: Asrock 970 Pro3 r2.0 Processor: AMD FX-6300 Graphics: Sapphire Radeon RX460 4GB   Thanks!
    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×