Must always type GraphicsEnabler=No to boot, even though its in plist - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
cypherstream

Must always type GraphicsEnabler=No to boot, even though its in plist

Question

Hello.  I have everything working on a Dell t3400 except for sleep.  Its pretty fast and QE works on the NVIDIA Quadro FX 1700 dual dvi video card.  I have dual monitors working beautifully.

 

The only issue is that I cannot boot unless I type in GraphicsEnabler=No at boot every single time.  If I forget to type this, after the apple logo the monitors will go into "Power save mode" and then shut off.  It seems the computer freezes because none of the status led's change on the keyboard for instance scroll lock, caps lock, num lock... also ctrl+alt+del does not reboot.

 

Anyway I read that you can put the boot flags in between the dict section within org.chameleon.Boot.plist.  Well I did that and I have the following:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
	<key>Credits</key>
	<string>www.hackintosh.zone</string>
	<key>EthernetBuiltIn</key>
	<string>y</string>
	<key>GraphicsEnabler</key>
	<string>No</string>	
	<key>Kernel Flags</key>
	<string>npci=0x2000 dart=0</string>
	<key>Timeout</key>
	<string>2</string>
	<key>UseKernelCache</key>
	<string>y</string>
</dict>
</plist>

See right there is GraphicsEnabler and No.  But if I don't type anything at boot, I get a black screen.  If I type GraphicsEnabler=No at boot, it starts up beautifully with full graphics acceleration.

 

Any ideas how I can get this automated?

Share this post


Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0

I found a thread on another forum from tony mac x86 and someone there posted a dsdt and ssdt file for this model computer.  So I thought maybe this would help a lot, so I ran them through a program to convert them to the asl format and put it in extra.  However this caused the system to hang at boot.  Verbose mode shows it hangs on SMC: successfully initialized.  

 

So I booted off another hard drive with Niresh 10.9 and removed those two files.  So that's not a solution.  Also sometimes when I type GraphicsEnabler=No it still boots to black screen. I would say I have a 25% chance of the system booting if I type that, and a 0% chance of the system booting if I don't type anything.

Share this post


Link to post
Share on other sites
  • 0

On second thought, my boot to black screen issue is pretty random regardless of what boot args I type in.  Sometimes I thought I had it down pat by typing -v GraphicsEnabler=No GenerateCStates=Yes GeneratePStates=Yes PCIRootUID=0.  This would sometimes get me in.

 

Though most times I would get a black screen right after this line in verbose boot output:

ACPI_SMC_PlatformPlugin::registerLPCDriver - WARNING - LPC device initialization failed: C-state power management

 

Though last night I was able to boot it with just PCIRootUID=1 as a boot arg.

 

So its very hit or miss as to which boot arg to use.  I sometimes have to try to boot 3, 4 or 5 times but eventually it boots, and when it does, its quick and working well (though I had to disable sleep because it doesn't wake up).

 

Any ideas?

 

Dell precision workstation t3400

Intel Core2Duo

4GB RAM

128GB SSD (Mac boot)

64GB SSD (Windows 7 boot)

500GB 7200rpm (data and mac backup partitions)

Nvidia QuadroFX 1700 dual dvi

Broadcom gig nic onboard (broadcom driver works).

VoodooHDA works (loud pop sound at boot though).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Download Hackintosh

  • Files

  • Posts

    • Hi guys, managed to make a hackintosh and everything is going great (Wifi, cpu ECT)   But it's pretty damn slow, i tried one of my favorite lightweight games to test (The Ultimate Doom) and it could barely run THAT! This is my first time and i have no idea how to get my 8570 to work.. Probably should have read a bit, eh? Lol.   And no I don't plan on using my hackintosh for gaming, but god so slow..   Thanks, help would be very appreciated. Edit: It's the dedicated version btw, and in about my mac I see "Graphics Display 3 MB" maybe the issue?  
    • Trying to boot to the installer but I get instant reboot after the following: I am using the following flag (I tried a variation - I need USBBusFix=Yes otherwise it fails even earlier): All my USB devices turn off just before it reboots, so I'm guessing it loses connection to the USB install media - but I can't work out why it's disabling all the USB's. My motherboard is an AsRock Killer Fatal1ty 990FX.
    • Saludos!   Tengo el mismo error (RAM a 667mhz), con una placa base ASUS (y mi cpu es el fx 6300).   Lograste solucionarlo?
    • Hi guys. Well, this is my second day of troubles, I touched everything, I installed max like 5 times in the same day, trying to figure out things and well. My Mac it display my graphic card on the #About this Mac tab With 2047MB ( So I guess all is right ) I installed the latest nvida drivers and on clover I activated the NvidaWeb. The problem is the resolution. Max resolution allowed is 1280 x 1024 and 800 x 600. I used to boot with nvd_drv 1 with nvd dry 0, I used to boot with all that things, and without them.  BUT No way to fix the resolution. Someone knows what-s going wrong and how can I fix it? Bdw im using iMac14,2 and OS X Sierra 10.12.3 Im connecting to the screen with DVI adapter. ( Maybe that causes the problem ) But it shows Im running 2047 MB so... idk why I can't change resolution. Thanks! ================================= SOLVED EDIT: Hi guys, in Display Resolution, I just set it in "Default for display" and after that pressing "THE WINDOWS BUTTON KEY, IN MY CASE, IDK WHAT KEY IS THAT IN MAC KEYBOARD, I THINK THE CONTROL ONE OR IDK" PRESSING that key I selected Scaled, and it appears more options and resolutions. There is a video on youtube about that called "Mac OS X Display Resolution" If someone has the same trouble.
    • Hello , i have a big problem , help me please, i have installed properly Mac OS Sierra , but now i can’t boot Windows 10, when i click on a image , which has written for example boot Windows from legacy hd3 , it blocks on an image with the Apple sign on an hard disk image, and when i enter the bios i can’t see tue hard disk in boot options, how can i add Images? Pleaseeeee
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,534

×