AMD 5800k APU with HD 6850 2GB - SO PERFECT. - Mavericks - Hackintosh Zone Jump to content
julescools

AMD 5800k APU with HD 6850 2GB - SO PERFECT.

Recommended Posts

I approached my OS X 10.9 Mavericks installation with a lot of caution.  It sounds so damn complicated!  I guess quite a bit of any computer skill comes from direct experience and can't be taught but this setup was so incredibly easy.  SO many people have problematic issues with this or that, making a Macintosh out of PC hardware can clearly be a LOT of work.  I want to tell my tale of great fortune :)  I am a PC gamer who had a good deal of old hardware laying around, so one day I bought an AMD apu 5800k and an ASUS mobo for it, and with the extra components I had a great home theatre pc.  I had been looking at Hackintosh builds for quite a while, and once I discovered Niresh I was really encouraged to give it a try.  I will get into specifics with anyone interested IN THE COMMENTS, otherwise I think it's better to show specs as basic hardware components:

 

-AMD 5800k APU  -  install boot flag=  amdfx           :)   So why did I choose FX instructions?  Because the 5800k uses Bulldozer/Vishera type cores or units. 

-ASUS FM2+ mobo

-4 gb ram - 2 parts     -make sure you have working RAM chips, or system will crash no matter the OS

-500 gb WD hard drive (I tried a 1 TB HD, installation was good but when booting I got the error that affects 1 TB+ boot drives... don't use a 1TB or greater boot drive for reasons you really don't want to get into)

-Sapphire AMD HD 6850 2 GB gpu  ~ I find it hilarious that for PC gaming this sucker is old and useless, on a Mac it's top of the line for the next year at least.

 

So I follwed directions, after some research I decided on:   graphicsenabler=YES :)

 

When I first tried to boot it froze at account creation, so I rebooted and tried some advice from a friend and type in quickly (during the Niresh boot) :  -x -v

This enables safe mode / verbose mode.  The system booted to the Mavericks desktop.  The Niresh optimization system started and things worked themselves out (thank so SO much Niresh for this, man truly I have so much love for this kindness). 

 

Sound worked automatically with front and rear ports, spdif etc. identified in the sound control panel.  What was amazing is that once I restarted out of safe mode, the graphics card did Quartz Extreme and everything else perfectly. 

 

Here was my most pleasing "hack" - and one that I think a lot of you will appreciate :)  I have a TP link usb wireless card, and I downloaded the OS X 10.8 installer form their website from my PC and brought it by flash drive to the Hackintosh.  For whatever reason, it wouldn't let me install.  Everything in the installer was greyed out and set to "skip".

 

I went into hacker mode.  I used the (THANK YOU NIRESH AGAIN!!!) unpacking tools provided to make it work.  I knew it was the correct installer package, so I viewed "package contents" of each element, right clicking on each package, viewing contents, then with the "payload" file I right clicked and unarchived it, taking the .kext file onto my desktop (.kext files are extensions or drivers needed for hardware to work).  I then used the .kext installer tool included by Niresh in the local Applications folder and installed them together, then used my manually unpacked "Wireless Tool.app" on restart.  It fucking worked.  OMG.  I was so pleased.  How did I figure this out? I open the "uninstall" script in TextEdit and there it is, in reverse, all the files that would normally be installed and the directories they belong in.

 

So I restart and open my Wireless Tool.app, load up my access point bitch:  Now I'm online.

 

So I installed Steam and linked to my account, wow I was able to play graphically intensive games on my new "Mac Pro".  The AMD 5800k showed up as a Xeon 3.82ghz quad core in the system, pretty hilarious.  The 6850 goes beyond it's PC potential on a pc, it behaves so differently and wonderfully under OS X.  I understand now why Apple doesn't use "cutting edge" GPU's in their systems.  My gaming PC's  AMD r9 290 would do severe damage on an OS X system man lol.

 

I tried to load the new Tomb Raider title in Steam got an error - You need to update to 10.9.1... SHIT.  SHIIIIIT.  I sat there looking at forum posts about the nightmares associated with updating.  I eventually said fudge it, downloaded the so-called "Mac Pro 10.9.1 update" a link to the Apple updater file you can find through Google from tonymacx86.  Ran the update.......

 

Everything worked better.  Why am I so lucky.

 

I kid you not, boot times faster, better gaming performance.  Good deep breath.  Ok my new AMD Mac Pro is bad ass.  So  I had been reading up on using a PC bluetooth dongle to use the Apple Magic Mouse and PS3 controllers...  WTF!!!! I plugged it in and it worked right away.  Sweet.  In the bluetooth control panel I paired my Apple Magic Mouse and a PS3 controller.  At this point I was feeling like the luckiest Hackintosher ever.  It had been such a simple smooth setup.

 

With my 10.9.1 working perfectly, sound, you name it, everything still good, I crossed my fingers and launched Tomb Raider.  Boom.  Immediate bluetooth PS3 controller support, I put the graphics @ 1080p on High settings, gamed my heart out. 

 

I have had such a great Hackintosh experience, it was so easy.  Anyone needing guidance go on and comment.  AMD Hackintosh is not only possible, it's fucking awesome.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting

    Please donate to support the community.
    We appreciate all donations!



    $54.09 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Hi guys, I installed the Hackintosh Sierra Zone image and most things work except my graphics. It detects as AMD R9 290X when I use FakeID 0x67B01002 on boot, however I only get 7MB of VRAM with no QE. My screen also tears as well. Hope someone can help me - Intel Core i5 2500K - AMD R9 290X 4GB - ASUS P8Z77-V LX
    • Hey guys, I'm looking into dual booting OSX Sierra or High Sierra on my ASUS Zenbook Pro UX501V. I use a lot of mac only software like sketch at uni and it would make my life a lot easier to just be able to boot into it instead of going to campus to use one of their Mac's. I'm currently running windows 10 and would prefer to not have to lose all my files or reinstall windows 10, however if this is unavoidable I would consider it. Specs are Processor    Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
      GPU    NVIDIA GeForce GTX 960m 4gb DDR5
      RAM    12GB DDR4
      BIOS Version/Date    American Megatrends Inc. N501VW.300, 9/05/2016
      BIOS Mode    UEFI Does anyone know of any guides? Or has done this before? Even a link to point me on my way. Looked into the clover bootloader and I'm under the impression that's the route I'll have to take. Thanks for any help you may have      
    • Hi everyone. Here are my specs MOBO :Gigabyte Z68 XP UD3 (1155) GPU : HD 6870 1gb CPU Intel i7 2600k (1155) 60gb SATA SSD   MOBO is using legacy Bios. This machine has served me well for years. I tripped a circuit breaker a few weeks ago and now it's stuck in a boot loop. I have setup a new bootable USB to reinstall but for some reason the boot loop is happening when I startup from this as well. I can manage to get to the desktop using the safe mode boot flag (-x) but after a few moments, the desktop freezes and the computer reboots. I used the 10.10.1 disc image to create the new USB stick I am not sure if this could be causing the boot problem in the USB. Should I have used the 10.10.0? At first I suspected a hardware issue but I left the computer on for two days at in the bios screen and it stayed on just fine. Hoping someone can give me a hand figuring out which boot flags can get me going again or how I can reinstall the OS. I really need to get past the freeze/reboot cycle I am in. I am almost ready to nuke this thing and install windows
    • i also have this problem if you will finde the solution please inform me right away and thank you
    • I built a Hackintosh on a GIGABYTE GA-EP45-UD3P in 2010, and upgraded it to Sierra about 4 months ago. It's been working great until a few days ago.  The clock now is losing time, while the computer is on and running. I've been working on the computer all morning, and have had to bump it forward to the current time it 3-4x. Right now it says 9:40am, but it's really 9:47am.  I have "Set time and date automatically" set in settings and "Apple Americas/U.S. (time.apple.com.)" selected on the drop down. Deselecting it, and selecting it again, brings the clock back to the current time.  Is this a hardware issue or a software issue? Do I have to replace the CR2032 on the motherboard? If so - why? The computer is on, and running, why would it need that battery to maintain the time?       
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,538

    Latest File
    By rembrandt63

    316    0

×