ALC889 and HD 6870 issue. - Mavericks - Hackintosh Zone ALC889 and HD 6870 issue. Jump to content

Recommended Posts

Hello guys,

 

So, I successfully installed Mavericks 10.9.0 with default the costume settings because which they work great apart from 2 things.

 

First of all I would like to tell you what I have done until now regarding OS X:

1) The only thing I have installed is the AMD install Helper 1.1.1 using the Mavericks kernel inside which fixes some small issues.

2) I have set in org.chameleon.Boot.plist the GraphicsEnabler to no.

 

 

- The first and most important issue I would like to fix is the sound. My motherboard uses ALC889 codec and from what I read a lot of people have problems with it.

My current kexts I use are the default in Mavericks installation usb. My sound in shattered, laggy, shitty and I cannot hear anything to be honest, also when I play something I think that the performance of OS X is dropping a bit. I only have sound (or whatever is that I am hearing) in the green rear port.

What I have tried until now: 1) Slytherin and multibeast and some patched AppleHDA on top of the default kexts from the installation. 

                                             2) Slytherin and multibeast some patched AppleHDA on a clean install without any kext for sound. That had as a result to get "No output devices found" in System Preferences > Sound.

                                             3) Have tickled with settings in Audio HDMI setup with 1) and I get a lot of loud unbearable static. 

 

 

- My second problem is with my graphics card. After the AMD Install Helper 1.1.1 I have seen a lot of small but nice to see improvements and I also have ran some benchmarks. The graphics are not that bad, but are not that good either. In ultra settings except multisample I get around 30 FPS. For example I tried to play some games and instead of ultra settings graphics I have to use low.

What I have tied until now: 1) I have just tried some kexts from several sites/ forums and the result of those was OS X not booting, OS X loading infinitely. 

 

 

My System Specs are:

 

Motherboard: Gigabyte 990FXA-D3 (with ALC889 Audio codec)

CPU: AMD Phenom II 960T

GPU: XFX Radeon HD 6870 Black Edition (non-flashed, I do NOT know how to flash it and I have read that some people got great results without flashing the 6870, in older OS X versions at least)

The graphics card is connected to the screen via an HDMI cable, I do NOT know if that has something to do with the sound

SSD: Sandisk 128Gb Ultra Plus (AHCI)

 

 

@

 

Thank you all for the help in advance and I hope we help some other people too. 

Share this post


Link to post
Share on other sites

I found a solution for the sound.

1) Uninstall VoodooHDA kext, remove voodoo from System Preferences and Application. 

2) Shutdown your system, do not restart. (it is safer).

3) Install voodoo 2.7.3 (I did it from Multibeast).

4) Shutdown again and reopen.

5) If you don't have sound go to System Preferences > Sound > Sound Effect and select your port and > Output and select the same port.

(if you have static noise there are solutions in youtube or other sites)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting May 2018

    Please donate to support the community.
    We appreciate all donations!

    Thanks



    $148.22 of $100.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Posts

    • Affter install High Sierra Zone in: Gigabyte H110m / i3 7100 In first reboot working the graphics but no USB drivers / External USB disks i cant mount clover In the secod reboot have problem, the solution -disiablegfxfirmware ane boot whit config, but hace the same problems, dont see the usb drivers and can not mount uefi partition In other reboot see diferentes config, i try diferents, boot with config_uefi without flags, but when run the graphics dont works but i see the usb drivers and external disk and mount the uefi driver. how repair this? boot with config and fix everting or boot with config_uefi and fix graphics?   sorry my inglis is not god
    • Dear Guys,
      Im trying to install mac os x sierra in my dell laptop and ihave followed all the details and reached the installation part. But im getting error saying "An error occurred installing macOS.To use apple diagnostics to check your mac hardware"
      Guys please please help me with it.ithink im almost 90% close to installing mac os. my lap config as follows.the person who help me resolve will be my hero  Motherboard: INTEL i3 370M 2.40GHZ,0KRP5X CPU: DELL N4030 MODEL. Graphics: ATI Mobility Radeopn HD 5430 Motherboard:  
    • i did one but no hdmi or display port sound even if they are detected processor neither no wifi   and install a multiboot ? i triyed clover but didnt work    
    • Hey can some one help me with a problem https://ibb.co/jv8TRT this is my problem I hope you can help me guys
    • Hi
      I followed Nirav's High Sierra installation guide.
      My problem is that I am getting the below error at the install boot screen (osxAptioFix2Drv:Starting overrides for System\Library\CoreServices\boot.efi
      Using reloc block: no hibernate wake: no)


      what I should to do?

      my specs:
      Asus Rampage VI Extreme 
      intel Core i7 7800x
      Samsung 960 EVO SSD 250 
      Gigabyte GEFORCE GTX 1080 TI Gaming OC
      GSkill TridentZ DDR4 8x2 GB
  • Download Statistics

    • Files
      849
    • Comments
      2,144
    • Reviews
      2,627

    Latest File
    By ka209

    122    0

×