OS X Setup Loop - Hackintosh Mavericks - Hackintosh Zone Jump to content
HelloItsMe

OS X Setup Loop

Recommended Posts

I successfully installed Niresh's Mavericks on my PC, although I'm having to boot with npci=x2000 every time (I'll fix this).

However, when I get to the part of the OS setup where it asks me if I want to restore from a Time Machine backup, the setup seems to crash and restarts from the beginning. I've seen many guides on the internet on how to trick the OS into thinking that we've already set-up the system, namely with `touch /var/db/.AppleSetupDone`.

However this requires `passwd ##`, and I get an error this time, with `The daemon encountered an error processing the request`, so obviously  the `touch /var/db/.AppleSetupDone` command cannot run.

Two questions:

  1. Why is this setup loop happening?
  2. Why am I getting  `The daemon encountered an error processing the request` when attempting to fix the first problem?

Maybe some bug in Niresh's Mavericks?

Specs:

CPU: AMD FX4100 Quad Core @ 3.6GHZ

RAM: 4GB DDR3 1066MHZ

HDD (all SATA): 1x 128GB SSD, 1x 64GB SSD, 1x 640GB HDD, 1x 320GB HDD

GPU: Integrated (for now; my previous AMD HD 7700 broke)

Motherboard: Asrock N68C-GS FX [link: http://www.asrock.co...IA/N68C-GS FX/]

Share this post


Link to post
Share on other sites

@HelloItsMe The daemon touch the file & force you to bypass login loop

but i don't know the correct reason for the daemon crash unless i look at the console log

try to boot with OS X Installation DvD / USB the  open terminal

type 

touch /Volumes/Mac/var/db/.AppleSetupDone

in this case i assume that the volume where OS X installed as 'Mac' Replace with the appropriate one

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!



    $48.99 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • Well thanks guys for help or say no help any way i fix everything by installing  High sierra everything works including hdmi audio also. So admin/moderator can you close/move this post?
    • hello all, i wonder if somebody did sucssesfuly installed ati drivers on one of polaris gpu on 10.9 10.10. or 10.11 mac? i find yesterday on some russian forum that they did some bios mods on polaris gpus on siera and high siera but i dont understand process. also no luck for kext emulator on phenom 2 cpu for siera and high siera i got rx560 sapphire 2gb and i tryed install mac but on gpu it said 8mb and graphic is awfull. everithing else works exept spdif output for audio and gpu. i cannot install siera or high siera because of unsupported cpu sse4.1 or sse4.2 my specs are asus m5a97 r2 evo phenom II 955 black edition x4 @3.2 g stock ram 3x4gb ddr3 @ 1333 underclocked because of cpu limitations rx560 sapphire 2gb 60gb adata sp900 2x500 gb wd blue (1x 2.5" , 1x 3.5") all your comments are welcome thanks
    • guys please help me .....................im stucked at apple logo while installing im using hp laptop core i5 7200u 6gb ram amd radeon R5 M430
    • I have working audio, graphics and network on this 10.13  Now store has sent me "security update" which I believe is 10.13.3.  Has anyone done this via store? What do I need to do before I install it? I have issues loading EFI so have to always manually mount it (Clover configurator and EFI mounter both fail) but using terminal and command "open /efi" I am able to mount and make changes to my config.plist too.   
    • Hi guys, I try to install Mac OS X Yosemite on my computer, but... i get stuck at the logo (when i boot it) + i see a bar, who won't charge. Can you give me a solution?   Processor: Intel(R) Pentium(R) Dual  CPU  E2180  @ 2.00GHz (2 CPUs), ~2.0GHz Memory: 2048MB RAM    User DPI Setting: Using System DPI  System DPI Setting: 96 DPI (100 percent) Display Card name: NVIDIA GeForce 210  Manufacturer: NVIDIA Chip type: GeForce 210 DAC type: Integrated RAMDAC  
  • Download Statistics

    • Files
      848
    • Comments
      2,137
    • Reviews
      2,570

    Latest File
    By Vale1831

    14    0

×