HP Envy Ultrabook 4-1030us - OS X Maverick Zone Hackintosh 10.9.0 - Hackintosh Zone Jump to content
  • 0
Sign in to follow this  
ken

HP Envy Ultrabook 4-1030us

Question

ken    0

So I haven't really found much support out there on this laptop (Hp Envy 4 1030-us). Not only until recently have I ever been able to successfully get this laptop to run OSX I have tried in previous versions of OSX to get up and running and was never successful. 

 

Hardware:

 

  • i5 3317u
  • 16gb ram 1600mhz
  • Intel D 4000
  • 120gb ssd 
  • 32gb ssd mSATA

 

 

I have replaced my ram with 2x8gb sticks and also have replaced the original 500gb hdd with a 120gb ssd.

 

On the 120gb ssd I have windows 8.1 installed.

 

On the 32gb ssd I have OSX 10.9 Installed.

 

Though I am not able to boot via the 32gb mSATA ssd because it does not show up in the bios I am simply using it for now as a test area and using Chameleon on a USB to boot. 

 

Out of the box on Niresh 10.9  I am able to boot into the install menu by simply using /hp as directed by Niresh for HP laptops.

 

In the install menu I use disk utility to format into OS Extended (Journaled) and then press continue to continue with the installation. When you get to the point where you can select the drive you would like to use to install Mavericks on click the customize button. 

uncheck GraphicsEnabler

And check the two boxes below that.

Also find where the smbios is and click MacBook Pro 6,1

Do not click the battery percentage on the laptop will throw a kp (dont know why yet).

 

Go ahead and install.

 

Upon reboot, boot normal. Takes a second to get you to the menu to setup your acct. and etc. 

 

From this point there are a few issues i have noticed: 

 

  • Ethernet does not work, but RealtekR1000SL.kext will work. Install that and reboot.

​

  • Graphics show as just 64mb shared not HD4000. The fix is simple. Open Chameleon Wizard Check GraphicsEnabler=Yes, Check the Intel Capri and add 3. Save and Reboot. Your Graphics will now show as HD4000 with 64mb vram Wish we could adjust the vram and add more, any suggestions I am open. Safari acts flickery, but Chrome does not Which i prefer anyways. Dont know how to see if the HD4000 is truly working or not. any ideas?

 

  • The track pad works but works like crap. I haven't really messed with changing anything yet. Done a few things unsuccessfully but I almost always use a wireless moue since it is easier on my hands. This does need to get fixed.

 

  • Volume works alright but there is absolutely no way of adjusting it that i can find yet. I did have the device ID and will post it as soon as i can find it once again. It is stuck at 100% which is better than nothing but needs fixing.

 

  • WiFi will obviously not work on this laptop due to it being an intel card. i will be looking for one that hopefully has bluetooth built in to it aswell.  it is not necessary but would like to have bluetooth without a usb dongle.

This is as far as I have got. Have not been able o test other stuff with this laptop like hdmi  or a few other things but will get around to that.

 

My main focus was getting this upgraded now to 10.9.3

 

I have not had success.

 

After updating I  have tried multiple ways to boot.

 

Replacing my S/L/E folder, Replacing MAch_kernel and its backup, Replacing the Extra Folder, and even copied the hp file from the Niresh USB (which did help my get past the uptime in nanoseconds but stalled me at still waiting on dsmos. I have tried multiple things with no success Help is much appreciated.

 

 

Yes i know i have been using the usb to boot into my 32gb ssd for osx.  as soon as i am able tog et osx running stable with at least 90% of everything working I will swap and put windows 8.1 on the msata ( which i am going to upgrade to a 120 at least) and OSX on the main ssd . Even though the bios wont let me boot into the msata, chameleon or clover will. which gives me dual boot on dual drives. Or i was also thinking about getting a 300+gb ssd and using the msata pci-e port for a bluetooth card, but not sure if that is possibe.

 

Share this post


Link to post
Share on other sites

1 answer to this question

Recommended Posts

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Download Hackintosh

  • Files

  • Posts

    • Ok, so I built a new hackintosh with Niresh Mavericks 10.9.0 on a modified Dell Precision T7400 and mostly everything seems to be working correctly except for two things: Sound (The obvious one), and Online video content (Youtube, Facebook videos, etc) play at lower than 1 fps, frozen speed, after 10 seconds of playback it reaches 4 seconds of elapsed time and I have found no other forums explaining this or talking about this so I decided to bring it up here. As for the sound situation, I already bought a new card to replace the X-FI, so yes, I am aware of the Sound Blaster Audigy X-FI Xtreme Audio not being supported, but what caught my attention is that the sound was working and video playback problem was gone temporarily, I happened to hear the sound from my headphones sitting on my desk and put them on, and sound. I decided to test a video on youtube, the problem with the videos, gone. But after a reboot, they were back. However I have the logs from today and can give them to whoever wants/needs them to figure out what may have caused the sound to kick in on the X-FI and maybe add support for this sound card. I copied as far back in the time that the system was on while sound was working that I could up to the shutdown event. I know it's pretty large but I am not sure where to look, I am simply handing this out to whoever wants to see what may have given me audio on this card for the session. From what I can see that looked to be the most closely related to my issue is something to do with bluetooth (I don't have bluetooth, btw), it says in console: "9/20/17 6:49:55.785 PM com.apple.audio.DriverHelper[200]: The plug-in named BluetoothAudioPlugIn.driver requires extending the sandbox for the mach service named com.apple.bluetoothaudiod." repeatedly many times. This could be completely unrelated.   The only recent actions I made that I personally can think of that may have triggered this would be: I installed several different versions of a music player through Winebottler and it failed to start, more and likely because of the lack of .net framework 2.0 and 4.0, this is my highest suspicion of being the likeliest cause, but I could be wrong. I installed Crossover and installed the music player in it, which it ran in and is where I discovered that you need .net 2.0 and 4.0 (It had the player in it's database and installed .net automatically) Ran Discord (It uses output/input, so may as well add that in) The player was MusicBee, and when it crashed, it also left a log that I could probably try to reproduce if needed.   Specs: Dell Precision T7400, 1x Intel Xeon x5482 Nvidia Geforce GTX 660 16GB ddr2 ram 667mhz (Tested to be working correctly, please don't ask me to run a mem test I am impatient enough as it is)
    • 980m+intel 530, 6820hk 512ssd+120ssd+1TB im trying to install macOsierra, and i tried a lot of combinations of arguments and configuration, nothing seems to work, i got the same problem every time ofter i start the installation! Is saying: System uptime in  nanoseconds: some random numbers.
    • Hello guys!


      Today I tried to install macOS High Sierra from a bootable usb, but my pc froze during the booting process.
      I need help. Can you help me?

      Here I attached a demo with the problem.
      https://goo.gl/cp5E8M


      Thanks in advance!
    • Hi, I am new at this, I installed maverick on a Lenovo g460 and everything ok but when I try to start appear a screen and say "system uptime in nanoseconds..." , I use -x and -x and others but I can't solve my problem. Sorry for my English. Thanks 
    • I have faced that problem to however does not  help with my current situation. ... I deleted other partitions and created Jhfs+ on the MBR no problems at all Still remains. Can NOT install on MBR natively as suggested ..... I have no reason to make this up    Any suggestions to get this working would be good. 
  • Download Statistics

    • Files
      842
    • Comments
      2,129
    • Reviews
      2,532

×