Amd Turion Virtualbox Install - Hackintosh Mountain Lion - Hackintosh Zone Jump to content
David Goodwin

Amd Turion Virtualbox Install

Recommended Posts

First off, I would like to thank all of the hard work and dedication that goes into these distros. Secondly, I have a scenario that I seem to not be able to work through. I would like to reach out to the community for some input.

Goal: Install 10.8.5 on a VHD in Virtualbox on a laptop with an Amd Turion processor. 


System specs:

Operating System: Windows 7 Home Premium 64-bit

BIOS: Phoenix ROM BIOS PLUS Version 1.10 A02
Processor: AMD Turion X2 Dual-Core Mobile RM-75 (2 CPUs), ~2.2GHz
Memory: 4096MB RAM
File System: NTFS
      Model: WDC WD3200BEVT-00A23T0 ATA Device


I am curious as to what arguments should be used, 

What has been used with no success: amd -v, kernel=amd -v, kernel=amd -v -x.


What happens that stops me:

Completely black screen with no output, even when using -v

tsc_init: EFI not supported!...... (even though EFI has been disabled in Vbox)

numerous other errors that I cannot recollect


The same results are achieved using VMware on this laptop as well.


Any input would be appreciated, thank you for your time.


Note: I have tried multiple Niresh Distros, all usually resulting in some sort of Kernel Panic or stop error using Virtualbox or VMware.

Share this post

Link to post
Share on other sites
Guest PowerLion1
I too had the problem of it not going past a black screen (AMD Phenomâ„¢ II X4 910e Processor) until I found out that apparently it's an issue with the USB.
On the boot screen make sure that the following is entered:
amd -v USBBusFix=Yes
That will get you past the black screen and also allow you to see if there are any other issues.  Note that may seem to lockup in (-v) verbose mode in around 4 spots, but it should continue into the GUI portion of the setup.
Also note that the after reboot it will take several minutes before the setup continues.
Update: After testing it out, it seems to work with a few minor exceptions.
DO NOT go to "About This Mac", it will crash the system.
DO NOT use the LaunchPad, the system will freeze.
You might have to wait around 3 minutes from when the login screen appears before the mouse/keyboard become responsive.
Enjoy your Vackintosh!
  • Like 1

Share this post

Link to post
Share on other sites

Thank you for your input, helpful but not in my case. The furthest I get is a "type 14=page fault": Here is a screen-shot of the kernel panic:

Any other helpful boot options or arguments that can be used for an AMD Turion X2 processor laptop running 10.8.5 in Virtual Box?


Or just for AMD Athlon Turion X2 processors in general?



Share this post

Link to post
Share on other sites
Guest PowerLion1

Seems like VirtualBox 4.3.x doesn't like Mac OS X (same lockup spot as you have).


Use VirtualBox 4.2.x with the boot flags amd -v USBBusFix=Yes and it will work just as I stated before.

Share this post

Link to post
Share on other sites

Virtualbox and vmware are the most hompatible software (or hardware, i don't know hot to say it).

And, if you don't want to install it, you can look for a torrent called 'OS X Mountain Lion 10.8 Retail VMware Image' (In

After you download, open the .vmxf file and you're done. Maybe you'll need to restablish the ram. Then turn it on and the system should load perfectly.

Share this post

Link to post
Share on other sites

@ - Thank you for your insight, I have completely removed Virtual Box 4.3 and re-installed 4.2. Still no luck, same kernel panic as above. I have attempted using a wide variety of Virtual Box settings with no real results. Note, that Mac OSX 10.5 (Not sure if Niresh or competitor) is able to run in Virtual Box however no newer versions are able to successfully install. 


@deadmau5 - Ah, yes I am familiar with that method. With the pre-packaged Vmware image, I get a notification that my "CPU has been disabled" and Mac OSX locks up.


Edit: I got curious and removed virtualbox out of the equation and restored .dmg to usb using Transmac. Booted to usb, and was prompted by the familiar boot loader screen, typed in my flags and was overwhelmingly met with Kernel Panic:

"tsc_init: EFI not supported!".


Any thoughts or alternative boot flag options?

Share this post

Link to post
Share on other sites
Guest PowerLion1

By chance is your PC a hp?  If so you could try using hp -v USBBusFix=Yes.


I also read that the AMD Turion X2 likes to max out the CPU via VirtualBox and some people have disabled Page Nesting under the System -> Acceleration Tab -> uncheck "Enable Nested Paging".


If interested here is how I set up the Machine



Basic -> Version = Mac OS X (64 bit)

System -> Extended Features (Check only "Enable IO APIC" & "Enable absolute pointing device")


Everything else should be as default.


I hope that everything works out.




Also, as for the EFI not supported error and not running in VirtualBox that is most likely due to your PC having a EFI/UEFI enabled BIOS.  Try going into your BIOS settings and disable EFI/UEFI mode and see if that helps out at all.  Unfortunately, I can't tell you exactly how since it varies from machine to machine.





Note that for me USBBusFix=Yes must be included regardless of what you are installing on.


I tried in the following: Intel Core2Quad Q9500, AMD AMD Phenomâ„¢ II X4 910e (VirtualBox), Intel atom N330, and none would even boot into the installer unless I used the USBBusFix flag.  However I only ever managed to get it to install on the AMD processor.

  • Like 1

Share this post

Link to post
Share on other sites

@ thank you for your time and input, it is much appreciated. All instructions have been followed with no result. I even went to the extent of upgrading the BIOS to the most recent version, for I was unable to find any EFI entries or anything remotely close to it. I surmise that this distribution is incompatible with my laptop. Too many hours have been spent on this issue, moving on. Again, thank you for your input.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting February 2018

    Please donate to support the community.
    We appreciate all donations!

    $48.99 of $120.00 goal reached.
    Donate Now