Fix: Stuttering Sound With Amd Cpu (10.9 & 10.8) - Installation guides - Hackintosh Zone Jump to content
  • 0
Dodior

Fix: Stuttering Sound With Amd Cpu (10.9 & 10.8)

Question

Hey everybody.This is a quick way to fix stuttering Audio will start to stutter - thats why you have clear sound when you move your mouse around.

 

Now for me, i try'd different kext's and solutions like activating SSE2 on Voodoo PrefPane and almost every other solution that is floating around on the Interwebs.

 

So im using a Quadcore AMD Cpu , and my way to "fix" this bug is to put the CPU usage on 100%.

But since you're using multiple Cpu's your performance won't go down. For example i can still run everything very fast and crisp, even games still run without any problems. Long story short > i noticed no difference in performance.But this might change on a different AMD CPU . So try it on your own risk. But let me assure (this won't brick your OSX Installation its just a terminal command).

 

 

Step1. Open Terminal.app

Step2. "yes > /dev/null" without quotation marks into terminal app.

Step3. Press Enter and enjoy proper Audio.

How to Disable:   "no > /dev/null"  without quotation marks into Terminal app.

 

 

Note: Terminal have to run as long as you want to have this "Fix" applied.

When you close Terminal, it resets itself. So just start the command and minimize Terminal !

 

 

 

 

YouTube Video Proof i did:

Enjoy and have a nice day! And much thanks to Niresh crew for providing great mackintosh distros.

  • Like 2

Share this post


Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 0

This works for me, but there has to be a better way to fix this issue.  Any ideas?  I am new to the Hackintosh realm but am willing to help where I can.  I have a Phenom2 x4 965.  Everything else works perfect except the crackling Audio.

Share this post


Link to post
Share on other sites
  • 0

This works for me also. Thanks a lot was losing hope lol. Is there any way to have this automatically applied during startup? This This way it does not have to be done manualy every start up.

Share this post


Link to post
Share on other sites
  • 0

Niresh 10.9 everything works but can't fix Audio in all 3 different sound cards... 

Maybe a late response but i have the same motherboard and CPU as you and i was also screwing with it for 2 days.

Here is the FIX:

  • Enter the Bios from your motherboard.
  • Go to Jumpfree/CPU config > DISABLE "AMD TURBO CORE"
  • Do this fix and it will work! :)

I think many people with processors that have AMD Turbo Core have the same issue, and i think this needs to be set in the Niresh Install Guide

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Donation Goals

    Hosting January 2018

    Please donate to support the community.
    We appreciate all donations!



    $40.92 of $120.00 goal reached.
    Donate Now
  • Download Hackintosh

  • Files

  • Posts

    • @Niresh i forgot to say that that error was given because i have a Samsung M2 NVMe 960pro. I tried to remove it and it kinda worked but with a lot of bugs even during the installation. I can't remember everything clearly now cause it's been like 4 months ago
    • Thanks. I Have One Ethernet And One Wifi. Here Is The Terminal Log :  iMac:~ marcus$ lspci -nn 00:00.0 Class [0600]: Device [8086:190f] (rev 07) 00:01.0 Class [0604]: Device [8086:1901] (rev 07) 00:08.0 Class [0880]: Device [8086:1911] 00:14.0 Class [0c03]: Device [8086:a12f] (rev 31) 00:14.2 Class [1180]: Device [8086:a131] (rev 31) 00:16.0 Class [0780]: Device [8086:a13a] (rev 31) 00:17.0 Class [0106]: Device [8086:a102] (rev 31) 00:1c.0 Class [0604]: Device [8086:a110] (rev f1) 00:1c.2 Class [0604]: Device [8086:a112] (rev f1) 00:1d.0 Class [0604]: Device [8086:a118] (rev f1) 00:1d.2 Class [0604]: Device [8086:a11a] (rev f1) 00:1d.3 Class [0604]: Device [8086:a11b] (rev f1) 00:1f.0 Class [0601]: Device [8086:a145] (rev 31) 00:1f.2 Class [0580]: Device [8086:a121] (rev 31) 00:1f.3 Class [0403]: Device [8086:a170] (rev 31) 00:1f.4 Class [0c05]: Device [8086:a123] (rev 31) 01:00.0 Class [0300]: Device [10de:1c82] (rev a1) 01:00.1 Class [0403]: Device [10de:0fb9] (rev a1) 03:00.0 Class [0c03]: Device [1b21:1242] 05:00.0 Class [0604]: Device [1b21:1080] (rev 03) 07:00.0 Class [0200]: Device [10ec:8168] (rev 15)
    • How many network adapters do you have? Like WiFi or Ethernet? Post output of lspci -nn command
    • Unfortunately i dont have any Option to disable my Grahpic Adapter. Can i disable it in an other way? Like any Boot Flags?   EDIT: I did just an Update for my BIOS but it didn't add any Options to disable my Graphics Adapter
    • This issue is called Discrete Graphics issue of High Sierra, To bypass this you have to disable either Intel HD Graphics 630 or Nvidia GeForce GTX 1060 from BIOS, Check into your BIOS to see if you have any options to disable Graphics, Then try booting Keep me updated
  • Download Statistics

    • Files
      845
    • Comments
      2,130
    • Reviews
      2,555

    Latest File
    By 8osm3rka

    21    0

×